Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PlexTools installs but cannot find drive

25 Feb 2010   #1
tony22

Windows 7 Ultimate x64 SP1
 
 
PlexTools installs but cannot find drive

My Plextor CD-RW drive is accessible just fine through Windows File Manager and other utilities like EAC. I want to use Plextor's own PlexTools program for features not found anywhere else. I have the latest version.

I installed PlexTools as Administrator; it installed fine. But when I start it it throws a popup saying "No Plextor Drive is Detected", which is clearly not the case. I thought that maybe this software needs an ASPI layer driver but others who are using PlexTools in Win7 x64 have already indicated they do not have any ASPI drivers installed in their systems (checked with ASPICHK). I am at a loss. Can anyone help?


My System SpecsSystem Spec
.

26 Feb 2010   #2
sygnus21

Windows 8.1 Pro
 
 

Quote   Quote: Originally Posted by tony22 View Post
but others who are using PlexTools in Win7 x64 have already indicated they do not have any ASPI drivers installed in their systems (checked with ASPICHK). I am at a loss. Can anyone help?
Wouldn't it be easier to ask those guys what they are doing? And are you sure the program is compatible with 64-bit systems?

Incidentally I looked for the program but wasn't sure what you have or use so....
My System SpecsSystem Spec
26 Feb 2010   #3
Kipper

 

what model of plex CD-RW drive is it and what version of plex tools.

There is a chance that your drive is no longer supported by plextools.
My System SpecsSystem Spec
.


26 Feb 2010   #4
tony22

Windows 7 Ultimate x64 SP1
 
 

PlexTools Pro XL 3.16, which is the last version released. Premium CD-RW drive, which other users say is supported in this version.

I have since learned that PlexTools does not require a separate ASPI driver since the interface logic to the drive is embedded in the program. So it makes this sound more like an installation type problem.

sygnus, of course I asked those guys! But short of "I installed it as Administrator and it works" I got nothing. Confirmed that users have it working in x64. The link to the program is here

Downloads - Software & Utilities - PleXTools Professional XL
My System SpecsSystem Spec
26 Feb 2010   #5
sygnus21

Windows 8.1 Pro
 
 

SInce I don't use the program, I'm afraid I have no answer other than what you found out.

Good luck.
My System SpecsSystem Spec
26 Feb 2010   #6
tony22

Windows 7 Ultimate x64 SP1
 
 

Well, I uninstalled it and reinstalled as Administrator - which is what I am certain I did the first time. Or so I really believe. But this time it worked. Problem solved.
My System SpecsSystem Spec
Reply

 PlexTools installs but cannot find drive




Thread Tools





Similar help and support threads
Thread Forum
USB Hard drive gets detected/installs but doesn't show up.
Continuation from this. I've tried all steps but I can't seem to get to my hard drive. Windows 7 Professional 64x. Drivers Updated. Plugged in properly. Installed and uninstalled device driver. Gave the drive a letter and changed the letter many times. Hard drive is still working because...
General Discussion
Two installs on windows 7 pro on diff partitions of same drive
Development/Test/ Lab machine with windows 7 pro.. having SW config issues and would like to reinstall from scratch but concerned with not having it available for a few days. It has a 1T Hard drive currently with two partitions.. 130gb for Windows 7 pro OS and rest for Data files. I have about...
Installation & Setup
KB973688 & KB954430 Installs, and install, and installs...
Hello, These 2 updates are in Windows update awaiting to install. Once (and it wasn't at first install) there was an error message and i deleted some files as directed by MS help page. Now they are always in the Windows update page, I install, no error, they are still there... Thanks for...
Windows Updates & Activation
re-installs, bootmgr on wrong drive
Phenom 940BE, 4gb Corsair XMS 800, Gigabyte MA790X-UD3P Windows 7 x64 - 32GB Corsair SSD internal storage drives Samsung spinpoint 1TB (2 partitions) Samsung Spinpoint 2TB (2 partitions) im having problems with the bootmgr installing on different partitons. at first i didnt know what was...
Installation & Setup
2 installs has left 2 copies of Win7 on my drive
I've been left with two versions of Windows 7 on my hard-drive after twice installing it from an upgrade-disc. I want to know how to get rid of the earlier version if possible. Using an upgrade disc, I did a custom install on an old XP machine. Unfortunately this install ran grindingly slow...
Installation & Setup
Boot partition only installs on 2nd drive
Hi, I've read all about, and understand what the 100mb boot partition is, why windows 7 creates it etc. However my issue is that Windows only wants to create it on Disk1 i.e. the second drive, and not on Disk0 along with the OS. I don't want Windows on Disk1 because my motherboard see it as the...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App