Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Headphones Plugging and Unplugging constantly bug


21 Jun 2013   #1
newbyb0y

Windows 7 Home Premium 64bit
 
 
Headphones Plugging and Unplugging constantly bug

My problem is this, my motherboard is Biostar TP67B and I have downloaded the sound drivers from the manufacturer website which is realtek high definition audio.However, If i had left my headphone plugged into my front panel jack and when I restart my computer, the headphone icon keeps flickering saying its plugged and unplugged constantly when it is in fact plugged in. I had tinker around a little bit and I have no idea how to fix this problem now. Its going bad to worse as it unplugs itself randomly now. I'm trying to go for a full reinstall of my sound drivers.


My System SpecsSystem Spec
.

21 Jun 2013   #2
fireberd

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Have you tried a different headphone? Maybe the headphone and not the PC or headphone jack.

If not the headphone, check the connection from the front panel at the motherboard, May be a bad connection there. Reseat (unplug then plug back in) the connector at the motherboard. If it still has problems I would suspect the front panel headphone jack, or the wiring.
My System SpecsSystem Spec
21 Jun 2013   #3
newbyb0y

Windows 7 Home Premium 64bit
 
 

I have just reinstalled the latest sound drivers and it seems as if the driver does not even detect my headphones at all but it detects the microphone instead.
My System SpecsSystem Spec
.


21 Jun 2013   #4
newbyb0y

Windows 7 Home Premium 64bit
 
 

Okay tested with another headphone,my microphone is the only one detected but my headphone is not detected at all. However my speaker remains detected throughout me changing my headphones
Also,it seems as if my headphones is detected as 'Speakers' instead
My System SpecsSystem Spec
21 Jun 2013   #5
fireberd

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Reseat the front panel audio connector at the motherboard (power off the PC first) and see if that helps.
My System SpecsSystem Spec
21 Jun 2013   #6
iRazer

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Try Downgrading it again, That's the problem of drivers updates sometimes there will be a problem.
My System SpecsSystem Spec
21 Jun 2013   #7
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

OP should check the front panel connections to the motherboard, these maybe all together as blue connector or individual singles usually black plastic and labeled.

Headphone jacks going bad is pretty common, cheapo wiring and solder...

To avoid it, if you unplug/replug a specific jack a lot, buy a very short extension cable whose jack will then absorb all the abuse and of course try the offending headphones in another device, these things don't last forever.
My System SpecsSystem Spec
22 Jun 2013   #8
newbyb0y

Windows 7 Home Premium 64bit
 
 

okay, I just plugged and unplugged my HD audio connector to my mobo.Nope it does not work, my headphones is still detected as 'speakers'. However, the connector seems to be working fine to me as it still detects the microphone jack from my headphones properly though.
My System SpecsSystem Spec
22 Jun 2013   #9
newbyb0y

Windows 7 Home Premium 64bit
 
 

@faladu, I don't like unplugging and plugging it in often, it becomes a hassle. At first, I left it plugged in for 2 days before I have encountered the problem as I had originally posted, my headphones would be identified as plugging and unplugging itself in the driver management menu. I could only rectify this problem by constanly plugging out my headphone jack and plugging in when i need to use it.
@Razer2K13, I will try downgrading to the original version that was included on my PC installation CD which included all the drivers for my mobo and notify you later.
@Razer2k13, I have downgraded and it seems the mobo still detects it as speakers too, no difference.

Also, I just want to say, I don't like the idea of replacing the whole thing completely cause its just my headphones, I can opt for getting a microphone only and working with speakers. Also, I don't know how to solder and replace parts specifically, i just wanted to know if there is a solution to this or a workaround to this.
My System SpecsSystem Spec
22 Jun 2013   #10
newbyb0y

Windows 7 Home Premium 64bit
 
 

I have just used r271.exe to remove my previous installation but I did not install any new version after the reboot and it seems that the driver management now detects my headphones again albeit the same problem as I stated above still persist but this returns me to ground zero,why does the updated driver not detect my headphones but I can still hear sound playing through it but it falsely detects my headphones as 'speakers'. Much appreciated for the response.
My System SpecsSystem Spec
Reply

 Headphones Plugging and Unplugging constantly bug




Thread Tools



Similar help and support threads for2: Headphones Plugging and Unplugging constantly bug
Thread Forum
Multiple BSODs after unplugging and plugging in flash drive. BSOD Help and Support
How to enable sound when plugging/unplugging charger for laptop. Sound & Audio
How To Let The Volume Change When Plugging In Headphones? Sound & Audio
Plugging and Unplugging! Hardware & Devices
Volume jumps when plugging in headphones Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:18 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App