Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek HDMI+NVIDIA vc=No Sound


07 Aug 2010   #1

Windows 7 32-bit
 
 
Realtek HDMI+NVIDIA vc=No Sound

Hi to all.

A lot of people have this problem and I've read everything in tihs forum regarding it (in other forums too) but I still can't get it fixed.
When I connect my HDMI with the TV I get picture but no sound.Here's what I've tried so far :
-Installing lates Realtek 2.51 and NVIDIA 258.96 drivers (other device's drivers are also latest)
-Changed the SPDIF cable backwards (Somewhere that helped because the guy had it connected in the worng way)
-Both the playback and comm dev are set to HDMI :




-Recently I've noticed something that is new in NVCP-the sound was and still is enabled through HDMI in the Resolutions menu :



-Installed win7codecs,tried with VLC but still nothing

Any help would be apperciated and thanks in advance.


My System SpecsSystem Spec
.

07 Aug 2010   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

irelavv, welcome to the forums.

Would help to know which Nvidia card you have (full system specs would help as well) as most of them until recently do not have audio buit into them, and require a 2 pin SPDIF cable connected between the video card and sound card to be able pass audio over HDMI.
My System SpecsSystem Spec
07 Aug 2010   #3

Windows 7 32-bit
 
 

Hi stormy.

My specs are : 9500GT video card,Jetway BI-100 motherboard intel bearlake P35 chipset,2GB RAM with 2,5 GHz Penitum Dual Core processor.I've been told that indeed this card doesn't support audio and that's why I'm currently using the SPDIF cable but I already told you I tried connecting it differently because I don't really know is there a difference in which end should be connected to the sc and which to the vc,anyhow I've tried both ways and still no luck.
My System SpecsSystem Spec
.


07 Aug 2010   #4
Microsoft MVP

Win 7 Ultimate x64
 
 

Just had a quick look at the manual for your motherboard, nice of them to name that header HDMI-SPDIF-out, eliminates any confusion as to what it is for.

As for the cable from the motherboard to the video card, it doesn't matter which end goes where. It is possible though that you have one end on backwards; 1-2 instead of 2-1.

Also does your video card have a HDMI port, or are you using a DVI-HDMI adapter? If using an adapter did it come with the card or one you picked up? Most DVI-HDMI adapters won't work for passing audio as they are not pinned correctly for it.

One more. If it is using an adapter and assuming the card has two DVI ports, have you tried it on both DVI ports, as I believe only one of them is configured on the card to allow audio.
My System SpecsSystem Spec
07 Aug 2010   #5

Windows 7 32-bit
 
 

Thanks for the quick reply but the card I'm using has the HDMI port.I've never used adapters but obviously everything is set as it should be.Never before has this problem been bugging me so much.Maybe I've spent more than 3 days staring at the google search results and tried every single thing...One thing was little confusing - there was link that got me to a forum where one guy said that he tried a 185 driver of NVIDIA for Windows 7 and it worked (I'm not sure if it was on your forums but it doesn't matter because I've tried old drivers both for the sound and video card and I just wasted my time)...
So now I'm stuck with the latest drivers but if you or anybody else has some suggestins about the drivers or the settings or ANYTHING else I'm opened to them.
Thanks in advance
My System SpecsSystem Spec
07 Aug 2010   #6
Microsoft MVP

Win 7 Ultimate x64
 
 

Don't have anything with Realtek audio here but if you haven't ,have a good look through the Realtek control panel for a SPDIF passthrough option.
My System SpecsSystem Spec
07 Aug 2010   #7

Windows 7 32-bit
 
 

Nope I've checked there a thousand times but it has just regular options like the playback devices.However,I've enabled and disabled some of the options which were there as well as to the SPDIF input but it doesn't matter what I change because both ways it still doesn't work.
My System SpecsSystem Spec
07 Aug 2010   #8

Windows 7 32-bit
 
 

ALLELUIAH
Chanegd the video to 195.39 as amzo suggested in No sound from HDMI device Nvidia and Realtek HD Audio
Uninstaled that goddamn Realtek driver and windows did the job for me...I said what the heck it won't hurt to try the driver that the system installs before I try the R 2.35 dr. and finally I heard music and sounds through the TV
Here's what you'll need to do if the machine doesn't install the drivers - the version and date are most important here so thanks for the help and may others solve this problem sooner


Uploaded with ImageShack.usd

My System SpecsSystem Spec
07 Aug 2010   #9

Windows 8.1 Professional x64
 
 

Thanks for letting us know you got it sorted
My System SpecsSystem Spec
13 Aug 2010   #10

Windows 7 32-bit
 
 

oh well it was nice while it lasted...
sorry guys but apparently this solution wasn't good enough and the PC decided to make my life hard again...
when I turned off the computer and powered it back on WITHOUT changing my last settings with which my audio worked over HDMI the computer just started playing the video like I didn't make any changes.Now I have to start all over again with this problem and I hope you can help me out.
-Just letting you know that after I didn't succeed to play audio over hdmi again I'm not with the microsoft audio driver-I reinstalled the realtek one because I couldn't hear the speakers with the other ones...
My System SpecsSystem Spec
Reply

 Realtek HDMI+NVIDIA vc=No Sound




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:45 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33