Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Playback devices window not opening

15 Aug 2010   #1

Windows 7
 
 
Playback devices window not opening

So my problem is that the playback devices window doesn't want to open..
So I can't change my default playback device anymore, and so I can't use my headset now .

It didn't work a couple of days ago, but my computer was also running really slow so I decided to format it.
So that's what I did, I now have a clean install and so far I have gotten the window open 2 times, but it took ages before it opened...

Anybody have Any idea what could cause this and how I can solve it? Cause it's really annoying.. =s I have already tried updating my audio drivers thinking that might solve it, but it didn't..

Another problem that I'm just having right at this moment (and which I also had before the format) is that when I want to play a song in iTunes it just stays at 0:00 and if I then try to start another song iTunes just completely blocks and doesn't respond anymore..

Set-up:
MB: Asus P5Q
CPU: Intel Q9300 @ 2,5GHz
GPU: ATI HD4850

Edit: I had also ran a full system scan before I formatted and I just did one again, and neither showed up with any virusses.

My System SpecsSystem Spec
.

15 Aug 2010   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

It sounds like the reinstall was not done correctly or fully. On many systems the install requires (1) Install Windows (2) Install motherboard chipset drivers (3) Install Device Drivers. The chipset drivers (for most systems) are key to a successful reinstall and ofter overlooked. Many devices, such as sound, will either not work or not work correctly without the chipset drivers as one of the prime things they do is define (identify) all the devices on the motherboard.
My System SpecsSystem Spec
15 Aug 2010   #3

Windows 7
 
 

Problem is the sound does work, and I've actually just noticed that the playback devices window does open... only it takes 30 minutes! But once it has opened once it does open quickly again...

And I have installed all my drivers, mb, sound, gpu, lan,...


edit: nvm it's not opening at all anymore..
My System SpecsSystem Spec
.


15 Aug 2010   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Still sounds like a Windows OS problem.
My System SpecsSystem Spec
15 Aug 2010   #5

Windows 7
 
 

Any ideas on how I could fix this though?
Because it's really annoying I really want to use my headset but I just can't because I can't switch the default device.. =S
My System SpecsSystem Spec
Reply

 Playback devices window not opening





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:06 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33