Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Sound Driver?

25 Aug 2010   #1

Windows 7 Ultimate x64
 
 
No Sound Driver?

So I upgraded my Windows XP to a Windows 7 64 bit and
everything works except two things.

1. The Display monitor got all glitchy. There's black/multi color horizontal lines all over the place.
I can stilll see the majority of the screen but the flickering is quite annoying.

2. My Sound, Video, Game drivers thing in Device Manager disappeared.
I know that the orignal sound driver was a sigma tell one, but have been unsuccessful in downloading a windows 7 x64 compatible version.

If anyone could help me work these problems through steps, I'd appreciate it. I'm somewhat computer savvy so that should make it a bit easier to explain.
I also partitioned my harddrive when I updated it if that matters.





OS Name Microsoft Windows 7 Professional
Version 6.1.7600 Build 7600
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name KYUNGJUNG-PC
System Manufacturer Sony Corporation
System Model VGC-RC310G
System Type x64-based PC
Processor Intel(R) Pentium(R) D CPU 3.20GHz, 3199 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date Intel Corp. PR94510J.04T.0115.2006.0417.1135, 4/17/2006
SMBIOS Version 2.3
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "6.1.7600.16385"
User Name KyungJung-PC\KyungJung
Time Zone Eastern Daylight Time
Installed Physical Memory (RAM) 2.00 GB
Total Physical Memory 2.00 GB
Available Physical Memory 971 MB
Total Virtual Memory 4.00 GB
Available Virtual Memory 2.67 GB
Page File Space 2.00 GB
Page File C:\pagefile.sys


My System SpecsSystem Spec
.

26 Aug 2010   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

Andrew, welcome to the forums.

You can find the full specs (or at least most of them) on your computer here,

VGC-RC310G | Sony® VAIO® VGC-RC310G | Sony | SonyStyle USA

For the audio driver it took looking at the driver download page for that computer to find out it has the Sigmatel audio on it, of which the Vista driver here,

http://esupport.sony.com/US/perl/swu...=4465&os_id=28

should work just fine.

For the video card sounds like either it needs the driver as well, or it is also possible that the card is on the way out. If you haven't changed the card from what the Sony specs show (7600 GT) then the driver directly from Nvidia is all you will need. For a card that old I wouldn't necessarily bother with the latest driver as it is made more with the current crop of cards than one a few generations old and go with something like this one,

NVIDIA DRIVERS 197.45 WHQL
My System SpecsSystem Spec
27 Aug 2010   #3

Windows 7 Ultimate x64
 
 
Thanks

Audio Device on High Definition Audio Bus
Multimedia Video Controller
code 28?

This is what I find in the Device Manager.
both have a yellow sign to the left of it.

Is it possible that I'd have to purchase a new sound driver if so which one?

My dad suggested downgrading to x32, but that's not the issue. is it?
My System SpecsSystem Spec
.


27 Aug 2010   #4

Windows 7 Ultimate x64
 
 

Also, the NVDIA file is for 32 bits only. :/

so I guess downgrading might be the option.

I'll only act after your reply.
My System SpecsSystem Spec
27 Aug 2010   #5
Microsoft MVP

Win 7 Ultimate x64
 
 

64 bit is here,

NVIDIA DRIVERS 197.45 WHQL
My System SpecsSystem Spec
27 Aug 2010   #6

Windows 7 Ultimate x64
 
 

Any comments on fixing the sound problem?
My System SpecsSystem Spec
27 Aug 2010   #7
Microsoft MVP

Win 7 Ultimate x64
 
 

You try the Vista driver for it?
My System SpecsSystem Spec
27 Aug 2010   #8

Windows 7 Ultimate x64
 
 

yea, didn't work it.
My System SpecsSystem Spec
27 Aug 2010   #9
Microsoft MVP

Win 7 Ultimate x64
 
 

What was the error message?
My System SpecsSystem Spec
27 Aug 2010   #10

Windows 7 Ultimate x64
 
 

I'll try it again, I forgot to write down the error message. but several times when the computer restarted itself.
I saw something about PFN List and IRQL NOT EQUAL.
My System SpecsSystem Spec
Reply

 No Sound Driver?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:28 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33