Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: problem with sound cracking in USB DAC when watching video files

05 Sep 2010   #1
pjuegos

windows 7 professional 64 bits
 
 
problem with sound cracking in USB DAC when watching video files

Hi all,

I have a problem with my USB DAC in my media center PC, and I would be delighted to receive your help

When I play music everything works perfectly. However, when I play some video files in WMC the audio cracks continously, it becomes unacceptable and I have to quickly stop the video for not damaging the speakers. It also happens when resizing the video screen or switching to full screen mode.

The DAC is a MUSILAND MD10, which uses the generic USB audio DAC driver from Microsoft.

In order to check if the problems were linked to this USB MUSILAND DAC setup, I have also installed another USB soundcard EMU 0404, which uses its own driver. I can confirm no cracks occur when using the EMU.
So, this is nothing related to windows process running in parallel or system load.

Could it be the windows 7 USB audio DAC driver? I tried to update if from the dev manager but it has the latest. Any thoughts?

Thanks a lot!!!


My System SpecsSystem Spec
.

05 Sep 2010   #2
pjuegos

windows 7 professional 64 bits
 
 

Hi again,

I have installed the ASIO4ALL driver in the PC. In order to play the files in WMC and WMP I have also installed the ASIO plugin for WMP. However, when I try to play an audio file I get the following error:
"ASIOWmpPlg: Failed to create ASIO interface, error code 80004002,"

I seem to have 2 problems now: how to use ASIO4ALL in WMP in win7 PC, and the annoying cracking sound...

cheers
My System SpecsSystem Spec
06 Sep 2010   #3
pjuegos

windows 7 professional 64 bits
 
 

hi all,

Just in case someone can understand what is going on in my PC with the audio, I will add up more findings of the problem.

I have downloaded VLC media player, and every single avi I played had perfect audio using my MUSILAND DAC player.

So, the problem is down to the use of the MUSILAND DAC player in WMP/WMC.
As mentioned in previous posts, if an EMU USB card is used in WMP/WMC, everything OK. Also, installing ASIO4ALL in WMC throws an error.

Any thoughts?

Cheers
My System SpecsSystem Spec
.


07 Sep 2010   #4
pjuegos

windows 7 professional 64 bits
 
 

More findings...

I have grabbed the USB DAC, and I have connected it to a laptop with same WIN 7 OS version as the media center PC

First, I can use the ASIO driver in WMP.
Second, the audio does not complain with the same video files I played in the media center PC.



Also, I have tested using WMP/WMC in the media center PC with the onboard sound card. It also played without problems

In summary, the problem is when I use WMC /WMP in the media center PC with that USB DAC....

I am lost............Help pleaseeeeeeeeeee
My System SpecsSystem Spec
08 Sep 2010   #5
pjuegos

windows 7 professional 64 bits
 
 

It is me again...

I reinstalled WMP using the windows features control panel, and I still have the same problem...

going mad...
My System SpecsSystem Spec
12 Sep 2010   #6
pjuegos

windows 7 professional 64 bits
 
 

Hi, it is me again!!! I know, I am very stubborn

I am stilll trying to make some sense of my PC audio problem...

I have reinstalled windows, and now I am even more confused... Now, if I play an aVI file in WMP using the USB DAC for playing the audio, everything is fine, which made me thiniking the problem was gone...
However, if I play the same file with WMC I have the same crakling probrem with the audio as I had before restarting...

How can that be possible? I thought that WMC was using WMP audio and video API and codecs....

I am not being too lucky... Does anybody have an idea of what is going on?

Thanks!!!
My System SpecsSystem Spec
Reply

 problem with sound cracking in USB DAC when watching video files




Thread Tools





Similar help and support threads
Thread Forum
BSOD watching video files,
Hi friends, I am getting random BSODs especially when watching video files 720p or 1080p and I am using frame interpolation which uses a lot of CPU+GPU(Open CL) power. But sometimes BSOD occurs rarely, for example I am writing this post and bingo! the BSOD again. Or pc is downloading torrents...
BSOD Help and Support
Sound Cracking (Z77-D3H)
Hi everyone, I installed my new PC (Specs stated) this time last week. Ever since, i have been having really horrible crackling sounds coming from any audio output device (Headphones, USB Headphones, Speakers), in the beginning it slowed the pace of the sound with a sort of wauble and extreme...
Sound & Audio
BSOD Whilst Watching Youtube Video, After Watching Tumblr Video.
Would appreciate any help. Thank you! I just want to make sure it's nothing too serious. When I was watching the Tumblr Video, It went all green, and then I got a popup bubble from the task bar saying something crash and restarted successfully, then when i went to YouTube i clicked the video to...
BSOD Help and Support
Cracking, dragging sound, causes video lag..struggling for 6 months!!
I'm not very good with computers, so I'll try to explain this the best I can. I have a Toshiba laptop that came with Vista. I upgraded to Windows 7 home premium 64 bit Around 6-8 months ago, my computer started to get sound that pops, cracks, and drags, and when it does this is also lags the...
Sound & Audio
no sound on tv after watching video from puter
Ok, I'm far from a computer geek or know let alone understand the lingo, so please feel free to throw yellow crayons if needed. But my issue is this. I have hooked up my HP laptop with an HDMI video/sound cord to my HDTV HDMI, all was fine and dandy, was able to get sound on my tv watching the...
Media Center
Video Freezing, Sound Skipping and Cracking
I've had this problem for a little while. It was originally only with Skype but in recent days has gotten a lot worse with Skype and I've had it come up while just watching YouTube videos or other streaming videos. It starts out fine. A few minutes in, the video can freeze and skip. The audio...
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App