Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sound blaster live does not work

30 May 2009   #1

windows 7
 
 
sound blaster live does not work

hey my sound blaster live dosențt work at all it says that it is installed and everething seems fine ... just does not work

My System SpecsSystem Spec
.

30 May 2009   #2

Windows 7 Ultimate x64, Mint 9
 
 

My Sound Blaster Audigy SE did not work under Seven either. I think it is too old, and there are not drivers for Vista or up.......

~Lordbob
My System SpecsSystem Spec
30 May 2009   #3
Microsoft MVP

Win 7 Ultimate x64
 
 

As far as that SB Live goes Creative will never release a Vista or Windows 7 driver for it, as they declared that card (and all other Live series cards) EOL a long time ago. best I can suggest is to try this one,

SB Live! series Support Pack 1.0 (04/04/2009) - Sound Blaster - Creative Labs

If that doesn't work for you it is time to either,

1. Ditch the card and get something that will have Vista and Windows 7 support

2. Ditch the card and go with onboard if it is supported

3. Ditch Windows 7 and/or Vista and go back to XP if you want to continue using that card.

Lordbob you're not quite in the same situation as your card should continue to receive support as the X-Fi Xtreme Audio is basically the same thing. That being said if you haven't tried them yet there is a modded set for that serie4s of cards as well,

SB P17X Series Support Pack 1.6 (05/14/2009) - AudigySE/Value/LS_Live24bit_X-Fi XtremeAudio_SB5.1VX - Sound Blaster - Creative Labs

bit of a PITA to install if you already have previous drivers installed, but probably worth the effort.
My System SpecsSystem Spec
.


30 May 2009   #4

Windows 7 Ultimate x64, Mint 9
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Lordbob you're not quite in the same situation as your card should continue to receive support as the X-Fi Xtreme Audio is basically the same thing. That being said if you haven't tried them yet there is a modded set for that serie4s of cards as well,

SB P17X Series Support Pack 1.6 (05/14/2009) - AudigySE/Value/LS_Live24bit_X-Fi XtremeAudio_SB5.1VX - Sound Blaster - Creative Labs

bit of a PITA to install if you already have previous drivers installed, but probably worth the effort.
Well, there were not drivers, but I also suspect it is broken so.........

~Lordbob
My System SpecsSystem Spec
30 May 2009   #5

Windows7
 
 

I believe in many cases you can still find the drivers Dell offers for those cards and they still work.

Otherwise you can hunt on the internet for later Creative drivers that others have made compatible, especially if you need 5.1 surround, etc.
My System SpecsSystem Spec
01 Jun 2009   #6
Microsoft MVP

Win 7 Ultimate x64
 
 

For what it is worth,

Windows 7 beta driver for the Sound Blaster Audigy/Live! series version 1.04.0090 - Sound Blaster - Creative Labs

seems Creative is just a little slow with the drivers for those cards. And before anyone with an actual Audigy (1, 2 or 4) tries these,

Quote:
This download supports the following audio devices only:

* Sound Blaster Audigy Value/SE/LS or Sound Blaster Live! 24-bit audio devices
My System SpecsSystem Spec
02 Jun 2009   #7

Windows 7 Ultimate x64, Mint 9
 
 

Quote   Quote: Originally Posted by stormy13 View Post
For what it is worth,

Windows 7 beta driver for the Sound Blaster Audigy/Live! series version 1.04.0090 - Sound Blaster - Creative Labs

seems Creative is just a little slow with the drivers for those cards. And before anyone with an actual Audigy (1, 2 or 4) tries these,
Thanks Stormy. +1

~Lordbob
My System SpecsSystem Spec
28 Jul 2009   #8

Windows 7
 
 
Sound blaster not working with Windows 7

I sort of found a bypass for this problem. It may not work for everybody but it is good enough for me. I went into the BIOS and changed the settings so I am making use of the 'soundcard' on the mother board.
I plugged my speakers in after finding the right jack, Windows installed the drivers and I now have sound.
When Creative gets around to providing a working driver I will swith back.
My System SpecsSystem Spec
01 Aug 2009   #9

Windows 7 Ultimate x64, Mint 9
 
 

Quote   Quote: Originally Posted by Teqels View Post
I sort of found a bypass for this problem. It may not work for everybody but it is good enough for me. I went into the BIOS and changed the settings so I am making use of the 'soundcard' on the mother board.
I plugged my speakers in after finding the right jack, Windows installed the drivers and I now have sound.
When Creative gets around to providing a working driver I will swith back.
You could just take the card out and use onboard sound.

~Lordbob
My System SpecsSystem Spec
13 Sep 2009   #10

Win7/Vista/XP/Linux
 
 

KX Project drivers work just fine in Vista and 7
My System SpecsSystem Spec
Reply

 sound blaster live does not work




Thread Tools



Similar help and support threads for2: sound blaster live does not work
Thread Forum
Creative Sound Blaster 5.1 live Sound & Audio
Sound Blaster Live for Windows 7 Drivers
Sound blaster live! Sound & Audio
Sound Blaster live Hardware & Devices
Sound Blaster 5.1 Live! Drivers
Sound Blaster Live! 24 bit and Speaker stopped Sound & Audio
Creative Sound Blaster 5.1 Live! Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33