Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Creative X-fi Fatal1ty Edition

12 Nov 2010   #1

windows 7
Creative X-fi Fatal1ty Edition

Hi everyone, I am having some trouble with "Creative X-fi Fatal1ty Edition".

So here is my problem, when I have the sound card plugged in windows 7 won't boot up. My monitor won't even turn on. When I take the sound card out, windows 7 will boot up. If I want to reinstall drivers i get a stupid error(image attached).

My Pc:

Intel Core 2 Duo E4500 2.20ghz
2 gb ram
1tb hd
32 bit win 7

Yes, i have tried what is in this post but still no luck. Creative Sound Cards.

Attached Thumbnails
Creative X-fi Fatal1ty Edition-untitled.jpg  
My System SpecsSystem Spec
12 Nov 2010   #2

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

See if it's a bad power cable connected to the card.
My System SpecsSystem Spec
13 Nov 2010   #3

Windows 7/10 64 bit

If the PC will not power up with the card inserted, you could have a bad card or the PCIeX1 connector is bad. If you try to install the SoundBlaster drivers with no card installed you canl get the error that it can't find any device.

Try resetting the BIOS (on some motherboards that requires removing the CMOS backup battery on the motherboard for about 10 minues), disable the on-board audio in the BIOS and then see if you can install the SoundBlaster and boot up. If you still can't it would look like a hardware problem - either the card is bad or the PCIe slot is bad.
My System SpecsSystem Spec

17 Nov 2010   #4

windows 7

Nope, nothing worked, I am now assuming that the sound card is bad,will test it on friends pc to make sure. Because my PCI connections work.

Thanks for the help.

*If anyone outs has an idea please post it.
My System SpecsSystem Spec
18 Nov 2010   #5

Windows 7 Home Premium 64bit

PCI card not PCI-X correct?
Tried it in a different PCI slot I assume?
For sure try it on a different board, also I would make sure
I had the latest nvidia chipset drivers installed.
And disabled onboard audio in the bios.
My System SpecsSystem Spec
18 Nov 2010   #6

Windows 7/10 64 bit

All the new Xfi Fatal1ty cards are PCIeX1 (that I've seen on their web site).
My System SpecsSystem Spec

 Creative X-fi Fatal1ty Edition

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
[Fatal1ty Creative Headphones] Mic isn't working.
Hello! My problem is that my mic on these headphones will not pick up any of the things i'd like to say anymore. I've had these Fatal1ty Creative Headphones for a year now, and I haven't had any problems in the past. If someone could explain how i could fix this issue, that'd be great.! Oh,...
Sound & Audio
Creative X-Fi Fatal1ty Titanium - Should I?
Hey guys, Matt here. If anyone has been creeping about, I've been having issues with sound configuration in Windows 7. After a bit of digging, I've found a fix... Buy a new damn card. Just want all you forum goers opinions, Is this card all that it is cracked up to be? Links to...
Sound & Audio
creative x-fi titanium fatal1ty pro issues
i just got a headset (turtle beach dx12) to use for gaming. all my friends use ventrilo to voice chat. when i plugged the new headset in, it worked except if i was listening to music it would play the music i was listening to in the background behind my voice even though it wasn't loud enough to...
Sound & Audio
Help with creative fatal1ty headset
Hey so i know the problem it's that my computer is trying to read the mic jack and not the mic on the headset i hope someone can help me....thanks
Sound & Audio
Creative fatal1ty mic problem different to the other problems(i think)
I had the problem which alot of others had but because alot of others had it that meant there were ways to fix it but 3 months later my mic has broken again it no longer picks up sound and when it does it isn't right it is a screeching sort of noise. This first happened when i was on Teamspeak...
Sound & Audio
Creative Fatal1ty Mic Problem
Hey guys, I got my new headset a few days ago the Creative Fatal1ty gaming headset and it has a detachable mic, but the problem is when i try talk in ventrilo and sound record i get nothing i have checked it isnt muted and i am really at a loss as to how i can fix it. Heres a snip of my sound...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:56.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App