Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HDMI audio not working

24 Nov 2010   #1

Windows 7
HDMI audio not working

I'll apologize in advance for adding yet another thread on this topic, but I have been through the existing threads with no luck. I suspect that what I've got is a simple configuration problem that I have missed, and I am hoping that someone can point me in the right direction.

Here's my setup:
  • Shuttle SN68PTG6 (nVidia GeForce 7050 PV/nForce 630a chipset)
  • Samsung HDTV (Model LN46C630)
  • Windows 7 Ultimate (64-bit)
  • nVidia driver version 260.99 (HDMI audio driver, 7/16/2007)
Up until a couple of weeks ago, both audio and video transmitted fine over the HDMI cable, and all was good. Until it wasn't. I still get video over HDMI, but I have lost audio.

I have isolated the problem to the computer:
  • Problem still occurs when using a different HDMI cable
  • Problem still occurs when using a different HDTV as display.
That leads me to believe I have a config problem in the computer. Here is the Playback page of my Sound control panel:

I have been through the nVidia KB, and had tried installing the "HDMI_Audio_Win7_WinVista" drivers in KB 2384. The installer said its drivers don't match my hardware.

So, here are my questions: Can anyone suggest:
  • A fix for this problem?
  • Further steps for troubleshooting it?
  • Point me to a resource on the issue?
Thanks for your help.

My System SpecsSystem Spec
24 Nov 2010   #2

Windows 7 Ultimate 64bit

Can you try an earlier restore point before it stopped working and see if it works? Could have been a driver update that screwed up something.
My System SpecsSystem Spec
24 Nov 2010   #3

Windows 7

Yes, I did a restore, and even did a complete reinstall of Windows. No joy yet.
My System SpecsSystem Spec

24 Nov 2010   #4

Windows 7 Home Premium

Two Questions:

When you single left click the Home audio device do you gain access to the "Properties" and "Configure" buttons, if so, have you explored any of the options there?
Like disabling all enhancements.

When you play program material that has audio material through HDMI do you notice the level bar to the right home audio device showing signal?

make that 3 questions-

Did you install anything prior to losing audio output?

My System SpecsSystem Spec

 HDMI audio not working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
NVIDIA HDMI audio not working Win 7. Worked on Ubuntu
Athlon 64 3400+ Geforce gt210 PCIE 2gb RAM I had Ubuntu 12.04 installed on this machine as an XBMC HTPC using the HDMI video and audio with the Geforce 210 until yesterday. I had a Win 7 license to use so I planned to rebuild the machine to do the same tasks with Win 7 then I could use Hulu...
Sound & Audio
ATI HD3470 Mobility HDMI Audio output not working!!!
Hey guys I have a ASUS M51vr Notebook Running windows 7, I have the latest ATI Drivers for my ATI HD3470 mobility Plus latest Realtek HD drivers. My problem is when i plug in my hdmi output via my hdmi cable it doesn't make the new device detected sound it would make on vista then allow me to...
Sound & Audio
Please help! HDMI audio not working
Hi, first of all, I am new here so I really apologise if I have put this in the wrong place but I need help urgently. I have looked at another post similar to my problem but it didnt help me. I have recently installed windows 7 home premium 64bit on my sony vaio vgn-fz38m laptop. I had problems...
Sound & Audio
Windows 7 - HDMI out no audio - Intel HDMI audio
Hey everyone, I recently upgraded to Windows 7 (Build 7100) from Vista (32 bit) and am having trouble getting audio from my HDMI out port. I am using the Mobile Intel 965 Express Chipset and have upgraded to the latest available driver but still no luck. I have attached a screen shot of my...
Sound & Audio
HDMI audio not working on windows 7 (Vista did)
EDIT: Here is the drivers that worked on my 8600 GT (aparently, work on other Nvidia GPUs as well)*: 179.28 - HDMI Audio works fine, no overscanning, full function, no problems with unwanted clocks. 182.50 - HDMI Audio works fine, no overscanning, full function, no problems with unwanted...
Sound & Audio
onboard hdmi audio not working
hello i searched the forum but i iddn't see anyone fix the error so i just upgraded my hard drive and did a fresh install of 64 bit win 7 and everythnig went good except no audio out of hdmi. thats the only cable hooked up to my tv and the whole time i did the installation and got to teh desktop no...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:53.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App