Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bluetooth headset pairs but won't connect, not avail as playback devic

11 Nov 2014   #21

Windows 7 x64

I agree, why is it so difficult to get a set of Bluetooth headphones to work. I have an HP EliteBook 8740w and it comes with the Broadcom Software, I can pair my Philips SHB4000 headphones, but it doesn't show in the Sound device and so I can't make it the default device. I've tried it on my PC still no joy. I've tried all the suggestions made by others on this forum, nothing works. Any suggestions, before I go mad

My System SpecsSystem Spec
29 Nov 2014   #22

Wndows 7 Home Premium 64 bit

My problem is that 6 mos or so ago my HP Laptop with Win 7 could connect to all of my Bluetooth devices then suddenly stopped. My iPad and phone can connect to all of them, so the problem is in the laptop. I tried back then uninstalling and reinstalling bluetooth drivers. Today I checked updates on all of them in Device Manager, still no luck, I don't want to do a rollback that far as sometimes recommended. I see all the devices, sometimes nothing happens when I click "listen to music" and other times it says "no available services or remote device connection failure. Please check remote device connection and make sure it supports required services." Bluetooth headset pairs but won't connect, not avail as playback devic-capture-bluetooth-failure.jpg

My System SpecsSystem Spec
09 Dec 2014   #23

Windows 7 Enterprise x64

Thought I'd add to this as I was going through the same hassle as the op and found a solution, which did involve updating the Bluetooth "driver" software on my HP laptop.
I tried all the previous links posted in this thread - most of them link to a supposed driver detector, which shows obsolete drivers on your system, but makes you pay if you want to update (before you know if it is actually going to work!).
So I went to the laptop manufacturer's website (HP in my case) and downloaded the latest Bluetooth update from there. Once that was installed I got more useful dialogue boxes and eventually got the headset working.
This is the Broadcom Bluetooth update from HP - Drivers & Software - HP Support Center.
It might work for your system, but I would check your installed Bluetooth device first.
(If the link I've posted changes to a non-HP website link, don't follow it!)
Once the update was installed I got an icon for my device under All Programs/Bluetooth. This app gave me a "Connect" button which got it working.
My System SpecsSystem Spec

11 Dec 2014   #24

Windows 7 Home Premium 64 bit
Sony DR-BT101 Bluetooth Headset Connection to PC - Resolved

By searching this thread I was able to resolve the connectivity issue from my Sony DR-BT101 bluetooth headset to my PC by following JayMac's Instructions. Thank you!


Remove the device from your PC (Devices and Printers) > Click on Add a Device and set your bluetooth to pairing mode > when your device shows up in the list DO NOT HIT NEXT just yet > Instead right click and go to Properties and select ALL the options for the services and after it install everything it will work for you. Also, please don't forget to change your default sound device in Control Panel and Sound.
My System SpecsSystem Spec
17 Dec 2014   #25

Win7 Home Premium x64

I'm about ready to give up. I have a Bluetooth (v2.1+EDR) speaker that pairs & installs just fine (Win7 reports it as a "headset", but that doesn't matter.)

When my BT-3.0 adapter didn't work, I bought a BT-4.0 adapter (plugged into a USB 2.0 port). Installed the latest drivers downloaded on the manufacturers website and everything installed.

I followed "JayMac's" instructions (which aren't 100% correct. Checking those boxes before hitting "Next" disables the "Next" button. Instead, you must click OK, install the device, then Right-click on the device there and tick the Services boxes) but it didn't help.

Drivers are all installed. Speaker paired & installed, but when I try to set it as an output device, the Sound manager reports it as "disconnected" (yes, it is On and paired.)

A picture is worth a thousand words, so:

I'm stumped.
My System SpecsSystem Spec
20 Dec 2014   #26

Windows 7 Enterprise 64bit
Not there yet

Happy to come across this item, after many hours of searching for a clue. Not there yet, but trying to contribute to come to a clear conclusion...

I followed the instructions by Jaymac (which were correct - at least in my case) but that didn't make a difference, as the BT services were already available in my BT device (a Noxon B1 Rev3 BT audioplayer to stream music to an analogue amp), see screenshot.
The trouble is, as stated by famattjr, that it shows the "listen to music" link, but when I select that, nothing happens. In the audio settings the BT headphones cannot be activated, nor is there a new BT playback device shown.
Trying to find a workable solution by checking the other entries...

The support dept of Terratec, who provide the Noxon B1, have been very helpful trying to tackle this issue, but no success. The B1 should be recognized as a BT playback device by Win7...
(This Windows problem has taken me over 8 hrs of weekend time, no kidding )

Attached Images
Bluetooth headset pairs but won't connect, not avail as playback devic-noxon-b1-eigenschappen-properties.jpg 
My System SpecsSystem Spec
20 Dec 2014   #27

Win7 Home Premium x64

Quote   Quote: Originally Posted by Adelaar01 View Post
In the audio settings the BT headphones cannot be activated, nor is there a new BT playback device shown.
If your BT device is never even seen when pairing, chances are your BT transmitter/receiver is an older version than your device, or your BT drivers (the transmitter not the headphones) may need to be updated.

Are the "audio settings" you mention the ones found by clicking "Control Panel | Sound"? If your BT device is there but listed as "Disconnected", try this:

Put your BT device in Discovery Mode, Go into "Devices and Printers", right-click on your BT device (if your device is not in Discovery Mode, you'll get a "Failed to Initialize" warning) and select "Control" from the pop-up menu.

Another window should open with a "Connect" button on it. Click the "Connect" button and it should enable your headphones. In my own case, as soon as the window opens, it disappears about a second later about 75% of the time and I must repeatedly try over & over til it stays open. If this happens to you, you can try to click the Connect button before the window closes and about 50% of the time it'll work.
My System SpecsSystem Spec
20 Feb 2015   #28

Windows 7 Pro 4 bit
Solved - disable unused Profiles in BT

Autoconnect seems to fail to autoconnect if you have too many Bluetooth device profiles enabled.

By default setting up a new device pairs and installs [every profile] it can find for that device. That fails.

I read this thread and went back into Right Click on Bluetooth Device and went down the profiles for the device and {disabled} all but one.. and walla!.. suddenly autoconnect works!

here is a guess.. it selects a profile and that grabs complete control.. like perhaps the VOIP to (handsfree) profile instead of the Listen to Music (headset) profile and [stops] because the handfree profile {assumes} you will click a button to start a call. Therefore it never gets to move on to enable the Listen to Music (headset) profile.

by disabling the "grabby" control freak (handsfree) profile.. it skips it and moves on to autoenable the device profile that lets you go into headset or "Listen to Music" profile mode right away..

In any event this works!

I did not have to wipe or uninstall and reinstall drivers.

One new problem I've noticed is the "Headset" profile appears to introduce a "lag" between lip sync in video and audio.. the "Handsfree" profile does not have this lag.

here is a guess.. the "Listen to Music (Headset)" profile has a transmission higher bit rate and regularly drops bits to stay in sync and "pops" occasionally. The "Handsfree" profile is lower bit rate and stays in sync.. for podcasts or watching video this seems critical because there is no lag or problems with lip sync.

additional guess.. if its going into "watch for call button" mode with "headset" profile.. simply pretending to start a call may allow autoconnect to work... just don't let it start a call
My System SpecsSystem Spec
20 Feb 2015   #29

Win7 Home Premium x64

Quote   Quote: Originally Posted by jwillis84 View Post
I read this thread and went back into Right Click on Bluetooth Device and went down the profiles for the device and {disabled} all but one.. and walla!.. suddenly autoconnect works
What "profiles" are you talking about? My BT devices don't have "profiles" (I right-click my BT icon to "Show Devices"... of which I have 1... right-click and there are no "Profiles". Checked Properties. Not there either.

My System SpecsSystem Spec
20 Feb 2015   #30

Windows 7 Pro 4 bit

That would be the profiles here:

Notice the [disabled] ones are the Icons with the "tiny" grey circle with the even "tinier" black [downwards pointing arrow] on top of the Icons in the lower right corner of the Icons.

In this dialog screen capture "only" the Icon representing the Profile in the "first row" is not disabled.

Each "Profile" is a Bluetooth "Device Function" in hardware "driver speak" according to Microsoft.. to the rest of the world and the Bluetooth standard they are called "Profiles" -- which are basically contracts, or API's that define "if your going to make a device that offers this type of service" on Bluetooth.. then it should work -- such and such a way, over Bluetooth.

The problem is Profiles tend to be written kind of independently.. as if each Bluetooth device only had one function or purpose.. so first Profile that gets control calls "Shot gun" and all the other Profiles "suffer" the consequences.. basically they get to fight over the left overs..

Look at it this way.. "Hands Free" is like a phone with an on/off switch.. "Audio/Video remote control" is like a TV remote with an on/off switch.. it can't be "both" a Phone and a Remote at the same time.. so {which is it?} the answer is.. which ever comes first.. and the remainder doesn't get to control anything.. including autoconnect the device to the sound system.

You don't "expect" a Phone to autoconnect and provide a "Dial Tone" so that's its behavior.. it connects and doesn't provide a Dial Tone. But when Headphones autoconnects you expect them to immediately begin providing sound so that's its behavior. Whichever gets control of the system first overrides the behavior of the others.

Its just a guess, but I suspect there is a way to assign "priority" or "order of startup" to these profiles and that someone like the device driver writers have figured this out.. and that is why sometimes reinstalling a different driver pack works.. it reinstalls the Profiles in a "different" order or priority.. and things magically start working. But disabling the other Profiles achieves the same thing.. ham fistedly.. and if there isn't another driver pack available.. this might be your only option.

I use my headset mostly for listening to podcasts or music.. so phone functions isn't as important. That's my choice.. but if I can figure out in Windows how to reset or reorder the priorities of the Profiles.. there might be a better way.
My System SpecsSystem Spec

 Bluetooth headset pairs but won't connect, not avail as playback devic

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Bluetooth Headset Won't Show in Playback. EVER.
I've tried about every solution imaginable to this, found in tons of threads. I have HP Bluetooth Module in Device Manager, and my headset shows up as a Bluetooth Peripheral Device there too. I have two Bluetooth instances in the taskbar, I have all the settings on for recognizing BT devices and...
Hardware & Devices
My bluetooth adapter won't connect to my bluetooth headset
Hi !! I am having a bluetooth adapter installed on my PC. Now I wanted to connect my Samsung HM1100 headset with it. It paired and everything but during installation of driver it says "NO DRIVER FOUND". I have tried too many times and I have also installed a bluetooth driver "SILICON WAVE...
Automatically connect to bluetooth headset?
Is there any way to ease the process of connecting to a bluetooth headset? I have already paired it and it works fine, but when I restart my computer I have to go through the process of connecting to it again(including inputting the code) before I can use it. I'm using Window 7's default...
Hardware & Devices
Bluetooth Headset Won't Show up in Playback Devices
Ok, so I recently bought a new Bluetooth headset. I paired it with my computer, and got everything working fine. The next day, when I resume my computer from hibernation, I find that it's not immediately working. I check the Playback Devices in Sound, and it shows up as "Disconnected". I right...
Hardware & Devices
Can't Connect Bluetooth Headset - Nokia BH-503.
Hi I have a bluetooth dongle from 'Enter Peripherals' . Specifications read that it works with win7 (no mention of the bit though 32 or 64?) I have sony vaio all in one computer (Model VPCJ113FX/B) and I want to connect my nokia headset, model BH-503. I have tried various options : 1 - I have...
Unable to set bluetooth headset as (default) playback device
I have a bluetooth headset, and I've paired/added it to my laptop. I check all its services and the drivers installed fine. But for some reason, the sound still goes through the speakers. I went to Control Panel->Hardware and Sounds->Sounds and it only showed 2 entries- Digital Audio (HDMI) and...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:23.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App