Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound won't work form Speakers but works in headphones

08 Dec 2010   #1
Ezom

Windows 7 home premium
 
 
Sound won't work form Speakers but works in headphones

Hi everyone,

I have Sony Vaio CW26. Yesterday Sound stopped working from Speaker, it's still working from headphones. I tried to restore the system but the farther point I found was done 3 hours ago......

anyway, I found out too that the USB port ( which is next to the audio output) is not working too.

I checked the Device Manager and nothing is wrong, any ideas?

thanx.


My System SpecsSystem Spec
.

08 Dec 2010   #2
SledgeDG

Windows 7 Ultimate x86
 
 

Hi Ezom and welcome to SF!
That is most likely no driver problem. The way you described it makes me think it's a hardware issue.
Inside the headphone jack is a "micro switch that cuts the connection to the build in speakers as soon as anything is plugged in there. Sometimes those switches get stuck (especially if one uses headphone jacks that are slightly thicker than 3.5mm.
You could try plug/unplug the headphones (or a similar plug) several times to "unstuck" the switch

-DG
My System SpecsSystem Spec
18 Oct 2012   #3
ChrisPD

64 Bit Windows 7
 
 
Still reading this thread?

I had this same problem, and your suggestion worked! Thanks for that. But someone from HP told me this could indicate a problem that might create a "short" in other components. Do you think this is true--that is, do you think this could go from an isolated (and apparently fixable) problem with the headphone jack to something bigger? I kind of just want to leave this alone...

In any case, thanks for the advice.
My System SpecsSystem Spec
.


28 Oct 2012   #4
TRodd1

Windows XP
 
 

Hi SledgeDG, I signed up to these forums to say thank you. Your solution of plugging and unplugging the headphone jack solved my problem! TRODD
My System SpecsSystem Spec
Reply

 Sound won't work form Speakers but works in headphones




Thread Tools





Similar help and support threads
Thread Forum
Sound card problem - headphones work, notebook speakers don't
Hi all, I just bought an old Toshiba A210 laptop and I'm dealing with a couple of (minor) problems. As the title says, I've tried every conceivable control, I can't get any sound from the speakers. No hissing sound, nothing, completely silent. Headphones work fine though. I checked device...
Sound & Audio
Sound only works with headphones or ext.speakers
My friend's laptop has a weird problem. It was running vista fine, sound worked and everything. One day, the internal speakers randomly stopped emitting any sound. However, they do make sound effect sounds while the computer is booting... so they're not broken. I figured it was a software...
Sound & Audio
HP620 No sound from speakers only headphones work
HP620 laptop running windows 7 32bit Home Premium Plugged in headphones for an hour. When I removed them the laptop speakers no longer function. Checked volume and mute. Checked playback device area and laptop speakers are enabled and indicated as functioning. Only headphones work. Deleted...
Sound & Audio
USB headphones work but not speakers
I am running Win7 64 bit with an ATI high def audio device and an IDT high def audio CODEC. After plugging my headphones to my USB port and then REMOVING the headphones all my audio players (WMP, WinAmp etc) continue to attempt to use the USB instead of switching back to my external speakers. The...
Sound & Audio
Sound Test works, but speakers wont work
The Problem: when I do a sound test, I can hear the audio in the speakers. However when I try to play a midi file, or a DVD, the movie plays, but NO SOUND. Usually if the sound test works, the audio plays in the speakers. So I am not sure what is happening here. The History of the...
Sound & Audio
Speakers work fine but Headphones don't
I'm running Win 7 Pro. After installing the Realtek High Definition Audio update, my speakers work fine, but my headphones don't . Say's headphones are not plugged in. Apparently this was a problem in Vista as well. Anyone know a solution? Thanks.
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App