Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 ultimate not detecting SB live! Soundcard

23 Dec 2010   #1
fsxadder

Windows 7 ultimate 32bit
 
 
Windows 7 ultimate not detecting SB live! Soundcard

Hi.

Ive got a new installation of Windows 7 ultimate and everything is working fine except that it is not detecting / picking up my SB live! Sound card in the PCIe port.
It detects and is running my onboard Realtek HD and is working perfectly however i wish to have two sound cards as i had on windows XP.

In the DEVICE MANAGER i see the following:

http://i53.tinypic.com/4uxi1d.jpg

When i try to install the drivers for my SB Live! Sound card it states that its "UNABLE TO DETECT AN INSTALLED SB LIVE SOUND CARD". . .

Ive tried two consecutive drivers for my sound card - The UNIVERSAL driver and another but both show the same error upon installation.

Ive tried switching ports but the same error persists.

Please help!.


My System SpecsSystem Spec
.

23 Dec 2010   #2
fireberd

Windows 7/8.1/10 64 bit
 
 

System Specs? You failed to fill in the System Specs.

Disable the RealTek in the BIOS. Then when you start Windows check to see if Windows detects the SB. If not, if you have motherboard chipset drivers, install them, restart the PC and then see if Windows detects the SB card.
My System SpecsSystem Spec
23 Dec 2010   #3
fsxadder

Windows 7 ultimate 32bit
 
 

None of the above worked.

Windows 7 ultimate 32bit
Intel core 2 duo E7200
MSI P7n platinum 750i (Motherboard)

Please help!
My System SpecsSystem Spec
.


23 Dec 2010   #4
fireberd

Windows 7/8.1/10 64 bit
 
 

Reset the BIOS and see if that helps. Some motherboards have a jumper that can be moved to reset the BIOS and others, with the PC powered off, you remove the CMOS backup battery for about 10 minutes and that resets it.
My System SpecsSystem Spec
23 Dec 2010   #5
JazzSus

Windows 7 x64
 
 

What is the SBLive made. Check on Creative site if is supported in windows7. On certain models they drop the support.
My System SpecsSystem Spec
24 Dec 2010   #6
fsxadder

Windows 7 ultimate 32bit
 
 

SB live! 5.1 (see attachment for pic).

I've installed the chipset drivers for my mainboard and tried everything.. This is what i get



PLEASE HELP!!!!!


Attached Thumbnails
-sblive-.jpg  
My System SpecsSystem Spec
24 Dec 2010   #7
fireberd

Windows 7/8.1/10 64 bit
 
 

First, you DO NOT have a PCIe port sound card, that is an old PCI sound card. A 5.1 sound card is relatively old and as noted may not even be compatible.

Get a new Windows 7 compatible sound card.
My System SpecsSystem Spec
24 Dec 2010   #8
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

It isn't even the SB Live 5.1. Going by the model number on it (CT4830) it is the Dell OEM version of the SB Live Value. which is only a 4.1 card (and yes I have two of them collecting dust in an old parts box).

One thing I can tell you is that you can stop looking for Windows 7 drivers for it as there is not now and never will be any from Creative. The best you can do with that old card is seeing as your running 32 bit Windows 7 is to try the last XP driver for it, that or you can try this modded driver,

SB Live! series Support Pack 2.0 (04/30/2010) - Creative Labs

Failing that fireberd's suggestion would be the next step, not too mention that that card is somewhere in the vicinity of 12 years old or so from when it was first released.
My System SpecsSystem Spec
24 Dec 2010   #9
fireberd

Windows 7/8.1/10 64 bit
 
 

This model Dell card must have Dell drivers. SoundBlaster drivers will not detect the card as it's a custom model made for Dell. We went through that, on the Dell users forum, when Dell started using these cards.

Sorry to say, it's a "trash bin" item.
My System SpecsSystem Spec
24 Dec 2010   #10
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Actually that does work the reference Creative drivers, I used to use mine that way. I even went so far as to self mod the Audigy (or was it Audigy 2) drivers (links I used to use have gone dead) on it and it worked great.
My System SpecsSystem Spec
Reply

 Windows 7 ultimate not detecting SB live! Soundcard




Thread Tools





Similar help and support threads
Thread Forum
windows 7 latency issues...soundcard?
Can anybody help with my latency issue. I use Audacity to record, but since purchasing dell optimus with windows 7- I cant record due to latency issues. I tried a few sound cards from my tech, but they either distorted or had the same latency issues. Can anybody recommend a decently priced...
Sound & Audio
Windows 7 Soundcard Needed
As so often happens my Realtek soundcard has gone the way most of these do. Can anyone suggest a Windows 7/64-bit compatible soundcard (not USB) and drivers which will permit 'What You Hear/Stereo Mix' on this OS?
Sound & Audio
USB Not detecting in Windows 7 ultimate
Dear All,,, Pls help me asap..as my laptop of sony vaio (windows 7 ultimate 32 bit) .is not detecting hard disk / nexus mobile. With previous OS of windows 8,,it was working fine. M in no mansa land as my laptops hard disk is almost full and m nt able to download any big size files like full...
Hardware & Devices
Windows 7 soundcard problems
A novice and first post.Please be gentle.:D My laptop gets muted when I play Youtube, as the audio gets diverted to HD Realtek , instead of the default "speakers".Though the Realtek's LED shows,no sound comes out the speakers.This knocks off my Windows Media Player as well.Often, I could fix it by...
Sound & Audio
Windows does not recognise new soundcard
I have windows 7 Premium and I have been using my onboard sound (realtek) which came with my Motherboard (ROG Maximus IV). I then purchased the Asus HDAV 1.3 Deluxe soundcard and installed in my PCI-E slot. The soundcard was not recognised by my pc at all. When I tried to install my driver, it...
Sound & Audio
Win7 suddenly does not reconige SB LIVE! 24 soundcard
Hi gents, Just coming of a clean install (hoping that would sove the issue) of win 7. but still my soundcard problem persists (code 10, unable to start device) http://www.plaatjesupload.nl/bekijk/2010/09/20/1285015978-060.jpg Any1 knows whats causing this ? this happened all of...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App