Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Fun Realtek AC97 installation issue

17 Jun 2009   #1
mattimcmillan

Windows Vista/Windows 7 Beta Build 7000
 
 
Fun Realtek AC97 installation issue

So my front mic jack has ALOT of static from processor/harddrive interference, so I want to change it to the back mic port. I go through my device manager and realize the only drivers installed are the Windows default. I download the Win7 drivers/software from realtek and when I try to install I get into a loop at the "Begin install...." part of the installation. It comes up with the "This driver isnt signed, do you want to install?". I click "Install anyway" but it continues to come up with the prompt shortly after clicking, if I tell it not to install it stops the installation and I'm still stuck.

Any suggestions? I already attempted to manually install the drivers, but the device manager says the drivers installed are newer than the ones I'm trying to install. Also tried to disable UAC, that didnt help, and any other security (including the Vista fix with bcededit ect. at the command prompt." All this AND tried the manual override of the pin config in the registry, but there are no registry values that equal what was put into the post.


My System SpecsSystem Spec
.
17 Jun 2009   #2
akash3656

Windows 7 32-bit; no 64 coz its a P4 478
 
 

Get driver sweeper>Boot Safe Mode>Remove Realtek Sound driver>RE-boot normal mode> Re download the latest AC' 97 Driver from Realtek >Install it now>Should work.... If not then report back
My System SpecsSystem Spec
03 Jul 2009   #3
mattimcmillan

Windows Vista/Windows 7 Beta Build 7000
 
 

Ok, so that didn't work :\ And I had given up on the issue. I just recently had to reinstall the Windows 7 Beta to the RC version and I decided to try again. I began looking through my settings and finally realized that I was looking for the wrong drivers! I was so used to AC97 drivers because of my work (all old Dell PC's) that I just got accustom to using/looking for those. I downloaded the realtek High Definition Windows 7 drivers and its working great now.

Thanks for you help
My System SpecsSystem Spec
.

Reply

 Fun Realtek AC97 installation issue




Thread Tools





Similar help and support threads
Thread Forum
Realtek ac97 Win7 Problem
Hi, I have installed Windows 7 recently. The problem is the sound doesn't work. A cross mark is placed on the speaker icon in the system tray. I've already read all of articles on this forum and I've tried all of links mentioned there. I also visited Realtek websites and used its links but it...
Sound & Audio
Problem with Realtek AC97
Back when I was just using Windows Vista, my computer recognized my sound card as Realtek AC97, which is what's built into my motherboard (ASUS M3A79-T Deluxe). However, when I started using Windows 7, all that Windows would show for my sound card is "High Definition Audio Device" for some reason....
Sound & Audio
Realtek AC97 Drivers Not installing
So i installed windows 7 late last night (from xp Pro) and everything seemed to work fine but these audio drivers (seems to be a common enough issue as far as i can tell) I've downloaded or installed 3 versions of the drivers. The ones that came with the MotherBoard(Abit IL9 Pro) disc, but it...
Drivers
realtek ac97, onboard sound
hi guys, new here and is my first post, so i have a dell comp, with a realtek ac97 onboard sound card, now running windows 7, but have no sound coming from pc. have uninstalled sound drivers and reinstalled new ones, have done this 3 times now, but still no sound, finally i have sound going to...
Sound & Audio
Realtek AC97 lacks output
Just installed W7, using a motherboard with onboard Realtek AC97 sound. I eventually got windows to realize that this was the sound hardware, and in installed a driver automatically (6.0.1.6243 from 6/18/2007). It appears to work, but nothing comes out of the headphones I plug into the jack. Is it...
Sound & Audio
Can't set Quadraphonic (4) speaker with RealTek AC97
Windows Update installed the driver for me. The front speakers work fine. However if I use the RealTek applet or the Sounds applet in Control Panel, I cannot set it to use 4 speakers. When using the RealTek one, it just doesn't save the setting. Or it'll switch to the digital output (which I...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:08.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App