Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Problem Under Windows 7 Ultimate 32bit


09 Feb 2011   #1
abhi69

Windows 7 Ultimate 32bit
 
 
Sound Problem Under Windows 7 Ultimate 32bit

Dear forum members,
i'm a Regular windows user since Windows XP SP2. few months ago i upgrade to Windows 7 ultimate (32 bit). i have onboard sigmatel sound card which works under Windows XP SP2/SP3 without any issue after installing sigmatel audio driver for Windows XP. but it's not working under win 7
i tried to install that XP driver under windows 7 with 'windows XP SP2' compability mode. it installs well, but no sound except some heavy noise from speaker when i play any kind of music, video etc.. I use a Microlab 2:1 speaker.
i also tried Win Vista driver for sigmatel high definition audio codec, but same issue happens again. that means, no sound except heavy noise from speaker.
built-in audio driver (high definition audio codec) working good under Windows 7. but there is also an issue with it as well. i can play sound nicely with this driver when i connect my audio jack with front panel. but no sound when i connect it with Rear panel.
that means, i only listen clear sound with this driver when i use front panel, but not Rear panel
but in Windows XP i can listen sound from both front & rear panel, but under windows 7 (with default/built-in audio driver) only front panel working, not rear panel.
so everytime i want to listen music or watch video i need to disconnect my audio jack from rear panel & connect it with front panel to hear sound. it's a very annoying work.
i search online many times to find a solve for this problem but no luck
recently i heard about this forum & decide to give a post here about my problem.
i think if anyhow i find an audio driver for my sigmatel which will work under my windows 7 ultimate flawlessly i can hear sound from rear panel as well.
this problem is making me crazy......
is there any solution of my problem? plz guys help me!
Regards.


My System SpecsSystem Spec
09 Feb 2011   #2
yowanvista

Windows 8.1 Pro x64
 
 

The problem lies in the device driver which has not been updated for Windows 7, get a new sound card as this one is clearly too obsolete

What is the exact model of this sound card?
My System SpecsSystem Spec
09 Feb 2011   #3
abhi69

Windows 7 Ultimate 32bit
 
 

Quote   Quote: Originally Posted by yowanvista View Post
What is the exact model of this sound card?
sound card model is: SigmaTel STAC9221 A1

isn't there any way to enable sound in rear panel as well (like front panel) with built-in/default audio driver?
BTW, i have another OS installed (Ubuntu 10.04) in my system, sound working well under it with both front & rear panel.
My System SpecsSystem Spec
09 Feb 2011   #4
PwnFrnzy

Windows 7 Home Premium 64-bit SP1
 
 

My computer from 2003 ran audio well when I had it's original motherboard in it (but the rear audio input died after a month, hence the motherboard replacement), so just use Windows Update, it should find the correct driver and sound should be working after you restart.
My System SpecsSystem Spec
09 Feb 2011   #5
abhi69

Windows 7 Ultimate 32bit
 
 

Quote   Quote: Originally Posted by PwnFrnzy View Post
so just use Windows Update, it should find the correct driver and sound should be working after you restart.
i finished installing all updates (about 250+ MB) found via windows update, but still no luck
still no sound from rear panel.
what else i can do now?
My System SpecsSystem Spec
09 Feb 2011   #6
yowanvista

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by abhi69 View Post
Quote   Quote: Originally Posted by PwnFrnzy View Post
so just use Windows Update, it should find the correct driver and sound should be working after you restart.
i finished installing all updates (about 250+ MB) found via windows update, but still no luck
still no sound from rear panel.
what else i can do now?
Get a new sound card as this one isn't Windows 7 Certified
My System SpecsSystem Spec
10 Feb 2011   #7
abhi69

Windows 7 Ultimate 32bit
 
 

thats the real problem with M$ things, M$ should understand that it not always possible for a user to keep changing his/her hardwares randomly to keep pace with the so called new technology of M$, just think that- after few more years present hardwares (Win 7 certified) will expire & they'll tell us to buy new hardware to meet requirement of their new OS! such a pity! thats why some user start preferring Linux over windows, because even old hardwares work flawlessly with any new version of Linux distro (i.e. my sigmatel sound card), so user don't need to chage his hardwares in random. M$ should think about such issue. not all user of the world has the ability to always change his hardwares to use new version of windows....it's high time to think about it.
My System SpecsSystem Spec
10 Feb 2011   #8
yowanvista

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by abhi69 View Post
thats the real problem with M$ things, M$ should understand that it not always possible for a user to keep changing his/her hardwares randomly to keep pace with the so called new technology of M$, just think that- after few more years present hardwares (Win 7 certified) will expire & they'll tell us to buy new hardware to meet requirement of their new OS! such a pity! thats why some user start preferring Linux over windows, because even old hardwares work flawlessly with any new version of Linux distro (i.e. my sigmatel sound card), so user don't need to chage his hardwares in random. M$ should think about such issue. not all user of the world has the ability to always change his hardwares to use new version of windows....it's high time to think about it.
Microsoft is not responsible for making audio drivers, MS only makes the OS, the rest is up to the manufacturers. Your sound card manufacturer is the culprit for not providing any updated driver not Microsoft.
It is obvious that manufacturer discontinue old products so upgrading to a new sound card will fix it

Quote:
M$ should understand that it not always possible for a user to keep changing his/her hardwares randomly
Old hardware drivers won't obviously be updated for newer OS
My System SpecsSystem Spec
Reply

 Sound Problem Under Windows 7 Ultimate 32bit




Thread Tools



Similar help and support threads for2: Sound Problem Under Windows 7 Ultimate 32bit
Thread Forum
problem on my PC with no sound, with OS Windows 7 Ultimate PT-pt Sound & Audio
Solved Installed Windows 7 ultimate 32bit driver problem Hardware & Devices
Problem with blue screen (windows 7 ultimate 32bit) BSOD Help and Support
Upgrading from Windows ultimate 32bit to Ultimate 64bit Installation & Setup
Windows 7 ultimate 32bit, sound device not recognized Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:13 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App