Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Creative XFI Xtreme problem

08 Mar 2011   #41

windows 7 Pro 64 bit

The best way I have found to prevent windows from installing the driver is to disconnect from the internet (wire going to your ethernet device in back) before trying to even un-install the driver. It will attempt to install it anyway the first time you remove the driver, but uninstall it again and then it won't try the second time. Then before reconnecting your internet connection install the driver of your choice. This is the preferred method if you don't want to go into windows services to disable the auto-find drivers function. Also, I would recommend initiating and performing all of this while in "safe" mode. If you don't know how to boot in safe mode, just tap F8 till the boot options appear and then select "safe mode"

My System SpecsSystem Spec
09 Mar 2011   #42

Windows 7

Everything still works great!

But I thought I would post the mistake I made over and over again in case someone with the same problem reads this thread, and I also wanted you to know in case you have to help out another like me.

When you told me to go Programs and Features and uninstall everything related to Creative Labs, I thought I did. I uninstalled everything that had the words Creative Labs in it.

When I made my last attempt yesterday to sort this out and I carefully followed the steps in the link you provided all the way to the end and got to the step where it said to go to Program Files and delete the Creative Lab folder and everything in it, it wouldn't let me. So I went inside the folder and deleted all the sub-folders except for the 2 folders Windows wouldn't let me delete. Then I opened those and tried to delete the files inside but got the message the file was being used by another application and I couldn't delete it no matter what I did. Then I looked at the folder name and it was called Volp and I caught on! Volume Panel! I needed to unsinstall the volume panel which I had never done in all my previous attempts. So after uninstalling the Volume Panel I deleted the Creative Folder and I also emptied the Recycle Bin and restarted my comp. Then I installed the drivers in the pack you had told me to download and now we have good sound again.

So thanks again for the great help, this forum is the best place to get help with a problem but also for all kinds of hints and advice and to read up on new stuff.
My System SpecsSystem Spec
09 Mar 2011   #43
Microsoft MVP

Win 7 Ultimate x64

You're welcome, and glad to have helped. Also good to hear that everything is back to working.

P.S. Good catch on the Volume Panel, I probably would have missed it on myself for the same reason you did.
My System SpecsSystem Spec

08 Jul 2012   #44

Windows 7 Ultimate

Here's the tip. Dump your Creative sound card in the trash can where it belongs and buy an Asus or M-Sound card.
Creative make cards for gamers with headphones and that is about all they are good for.
I got fed up with Creative's screwed up devices and drivers long ago and have never looked back.
My System SpecsSystem Spec

 Creative XFI Xtreme problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Creative SB X-FI Xtreme Gamer / upgrade
Hello. I want to upgrade my soundcard Creative SB X-FI Xtreme Gamer and i don't if it's worth. For now i use my headphones Sennheiser 429 HD + Logitech 5.1 x530 but soon i'll have Behringer MS40 instead Logitech 5.1 x530 What would you advice me ? Should i go for Asus Xonar ? Should i go again...
Sound & Audio
Creative X-fi Xtreme Audio
Bought this card today. Because it said support for vista, I thought it would work in Windows 7 as well. Installed the card and I had immediately sound. Then I went to the creative site to install the drivers because I had only control over the volume. There was no EAX, no bass control, nothing....
Sound & Audio
Creative Sound Blaster X-Fi Xtreme Audio PCI - microphone problem
Hello there. Yesterday i've installed this sound card and everything works fine but no microphone. I can see it in control panel but it doesn't work. Mic is fine as i was using it before. I have Win 7 64bit. If you have any idea what can cause the issue please help, if nothing will work i will...
Sound & Audio
Creative SB x fi xtreme audio delay problem!
Hi, I've recently bought a creative SB x-fi xtreme audio, and no matter what update i do, I keep having delay problems( 0.5 to 1sec) when connecting my guitar through the mic/line entry....... To make things worse, the driver even crashes and all sounds get delayed, i mean even in windows media...
Sound & Audio
Creative X-Fi Xtreme Audio
Does anyone know where i can download drivers for this card for the Windows 7 RC1? ive tried the Beta drivers off Creative and had no joy, the ones that came out when the "leaked" RC1 was out and im gettin majorly cheesed off.... ive got everythig else set up how i want except the fact ive no sound...
Sound & Audio
Creative X-Fi Xtreme Audio x64
Hello, my Windows 7 x64 (7100) found after a clean install new optional updates which included drivers for my soundblaster X-Fi Xtreme Audio. I also used the drivers I got with the cd and installed them on my system. Everything is working now except a few options. I get sound in 5.1, but when I...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:42.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App