Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek audio working for 64 bit, but not 32?

29 Mar 2011   #1
however

Windows 7 Home Premium 64bit
 
 
Realtek audio working for 64 bit, but not 32?

Hi. I'm using 64 bit Windows, and I'm having an issue.

Applications that are 64 bit seem to play sounds fine. Browsers, some games, etc. 32 bit applications, on the other hand, don't detect a sound device. Winamp, for example, gives a "bad directsound driver" error.

DxDiag continues the problem. The 32 bit version doesn't detect a sound card, but the 64 bit version shows no problems.

I've tried updating the realtek drivers a few times. Tried cleaning beforehand or letting the installer do it. No dice.

Any bright ideas? I've attached both dxdiag outputs. Thanks.

Motherboard is a GA-P67A-UD4-B3.




Attached Files
File Type: txt DxDiag.txt (26.0 KB, 11 views)
File Type: txt DxDiag64.txt (36.5 KB, 8 views)
My System SpecsSystem Spec
.
29 Mar 2011   #2
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Hi! however, welcome to 7F

Check in your C: drive and both Program Files folders; Program Files, Program Files(x86).

Do you see a realtek folder in Program Files(x86)? If not, your problem is there are no 32bit files to run the 32bit side of your OS.

If you would have had your system specs listed I could have help you find them. But since not, you will have to find the ones appropriate for your system, and install them.
My System SpecsSystem Spec
29 Mar 2011   #3
however

Windows 7 Home Premium 64bit
 
 

There does indeed appear to be a realtek folder in Program Files(x86). So I don't know if it's that.

I've tried using the drivers from the CD that came with my mobo, downloading from the mobo site, and downloading from realtek's site.
My System SpecsSystem Spec
.

29 Mar 2011   #4
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Here are a couple of things to try for now.

  • Type Services in your 'Start-Search' box.
  • Click on services at the top.
  • When that opens scroll down to 'Windows Audio', and 'Windows Audio Endpoint Builder'.
  • Make sure they are both started and on Automatic.

  • Check your winamp preferences.
  • Open Winamp.
  • Ctrl + P to bring up preference window.
  • Go to Plug-ins-->Output.
  • In each any every choice click on one to highlight it, then click 'Configure'.
  • A new window called 'wave-out setting' pops out.
  • In Device:drop down box, make sure it is selected to your sound device sound card.
  • Apply, okay your way out.
  • Check to see if that helps.
My System SpecsSystem Spec
Reply

 Realtek audio working for 64 bit, but not 32?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Realtek audio, Gigabyte mobo: strange-sounding audio, mic not working
I have a self-assembled desktop PC - full specs in the signature below, but in short, it has an AMD Phenom II X6 1090T processor on a Gigabyte GA-970A-DS3P mainboard, which uses a Realtek Azalia ALC887 on-board sound system. I have no loudspeakers and listen to the computer sound exclusively...
Sound & Audio
Realtek Audio HD Driver is not working
Hi, I am new to these forums and I've tried every possible way to fixing this problem, but I still cant fix it. My problem is that my sound icon says "No audio output device is installed". Ive tried installing Realtek through Device Manager and legacy installs. Even through Windows Troubleshooter...
Sound & Audio
Win7 realtek audio balance not working
Hello, im using Windows 7 64bit Motherboard Name Intel Whitesburg DP55WB Realtek ALC888/1200 @ Intel Ibex Peak PCH - High Definition Audio Controller PCI Headphones steelseries syberia v2 - 3.5mm jack this is integrated sound card so my problem is, what not working balance. then I...
Sound & Audio
realtek audio just stopped working
hi all. For some reason my realtek audio has stopped working on my windows7 64bit system. I just turned it on this morning. No sound. I checked in playback devices and noted that under 'speakers' it tells me "Realtek high definition audio not plugged in" Under that there is 'Realtek Digital...
Sound & Audio
Realtek HD Audio microphone not working
Hi there, I have recently built my own computer for the first time, and it seems to have gone pretty well. The only problem is that I can't seem to use a microphone, and it's really frustrating. First of all, when I plug the microphone into the front panel, the computer thinks i've Unplugged it....
Sound & Audio
Realtek HD Audio - Enhancements Stopped Working
I recently purchased a Razer Carcharias which has a low microphone. I have to put the microphone boost on +30db for it to be adequate for ventrilo/teamspeak. With that being said, it has static due to the extreme microphone boost. There's an "enhancements" tab under the microphones properties...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App