Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Sony vaio no sound through hdmi

05 Apr 2011   #1

Windows 7 Home Premium 32 bit
 
 
Sony vaio no sound through hdmi

I have a sony vaio VGN-ARN61E, which originally came with windows vista, but i have since upgraded to windows 7 home premium 32 bit. I have recently got a flatscreen tv and would like to be able to watch stuff streamed on my laptop on the tv. I have a hdmi cable (which claims to do both audio and video) and my laptop manual says that the hdmi port is for audio and video. however, when i plug the tv in, i get video but no audio. (so the audio still comes from my laptop speakers)

On my sound devices, a hdmi device is listed, but i cannot configure it, and when i play the test sound i get the error message "playback failed" if i select the hdmi device as my default device, then i get no sound at all.

I read online somewhere that i needed to upgrade my graphics card driver. I seem to remember (and think I also came to this forum for advice) that when i first upgraded to windows 7, i had a bit of a problem forcing the computer to recognise the nvidia graphics card driver. On nvidia online, the latest update for my graphics card (Geforce 8400M GT) includes a HDMI audio driver. However, this update is not suitable for sony laptops and when i try and install it, it says no suitable hardware was found.

I would appreciate any help with this problem, as I have tried everything I can think of, and it is starting to bug me now!

Many thanks in advance for any help

Ezme

My System SpecsSystem Spec
.

05 Apr 2011   #2

Several, including Windows 7 x64 Ultimate
 
 

Unfortunately, if Sony does not provide the drivers then it wont work. There may be some work-around for it, but I don't know of one.

This is quite a major and all too common problem with a lot of "Brand Name" machines. They are fine until you want to change or upgrade something.

If you do a quick Google search on "sony vaio VGN-ARN61E HDMI", you will find that lots and lots of people have the same problem.

This MIGHT!!! work;

http://esupport.sony.com/CA/perl/swu...=3625&os_id=28

Regards....Mike Connor
My System SpecsSystem Spec
06 Apr 2011   #3

Windows 7 Ultimate SP1
 
 

This might help you:
Sony eSupport - VGN-AR690CU - Drivers & Software

Also check the Device manager for any missing driver's devices,
I recommend you reinstall the HDMI sound driver to ensure the driver install correctly.
My System SpecsSystem Spec
.


Reply

 Sony vaio no sound through hdmi





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:10 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33