Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Test works, but speakers wont work

11 Apr 2011   #1
carlpopp

Windows 7 Ultimate (32 bit)
 
 
Sound Test works, but speakers wont work

The Problem:

when I do a sound test, I can hear the audio in the speakers. However when I try to play a midi file, or a DVD, the movie plays, but NO SOUND.

Usually if the sound test works, the audio plays in the speakers. So I am not sure what is happening here.


The History of the issue:


I Upgraded my emachine from Vista to Windows 7. I went to the Emachine website to update the audio drivers. The drivers that Emachine has are outdate.

I went to the Realteck website and downloaded the newest drivers.

I noticed in the device manager that their is a NVIDIA High Definition Audio, and a Realtek High Definition Audio listed.

Ok, so here is the setup.

I have a HDMI Visio TV plugged into the Emachine. Audio workes fine if I disable Realtek High Definition Audio in the device manager.

Here is the big problem: When I plug a simple set of speakers (that work on other computers) into the back of the computer, the audio will not work on the speakers.

If I enable the Realtek audio in device manger, I can get the Realteck audio options screen. Where Realtek sees that I plugged the speakers in the rear of the machine.

when I do a sound test, I can hear the audio in the speakers. However when I try to play a midi file, or a DVD, the movie plays, but NO SOUND.

Usually if the sound test works, the audio plays in the speakers. So I am not sure what is happening here.

Can anyone advise.


My System SpecsSystem Spec
.

12 Apr 2011   #2
carlpopp

Windows 7 Ultimate (32 bit)
 
 

Ok, I found the problem, and wanted to share. I was using a VGA extension cable to connect the computer to a 55" LCD TV across the room. I noticed during trouble shooting that the left pin, on the second row of the VGA extension cable was pushed back. When I oulled the pin out, and reconnected the VGA cords, the sound worked GREAT. I have no idea what a video cord has to do with audio, but it worked. If anyone knows the teck on this issue, please shoot me the understanding. Thanks for this site!
My System SpecsSystem Spec
Reply

 Sound Test works, but speakers wont work




Thread Tools





Similar help and support threads
Thread Forum
Sound only works with headphones or ext.speakers
My friend's laptop has a weird problem. It was running vista fine, sound worked and everything. One day, the internal speakers randomly stopped emitting any sound. However, they do make sound effect sounds while the computer is booting... so they're not broken. I figured it was a software...
Sound & Audio
No sound in headsets, but speakers works fine.
So yesterday I was just installing PowerPoint, and watching some youtube videos meanwhile. Then suddenly I didn't hear any sound from the headset. I plugged it in and out and so on, nothing. I tried with another headset, nothing. I tried with headphones, nothing. I uinstalled PowerPoint to see if...
Sound & Audio
Sound won't work form Speakers but works in headphones
Hi everyone, I have Sony Vaio CW26. Yesterday Sound stopped working from Speaker, it's still working from headphones. I tried to restore the system but the farther point I found was done 3 hours ago...... anyway, I found out too that the USB port ( which is next to the audio output) is not...
Sound & Audio
My computer speakers do not work but headset works fine.
I get the following error. "The peripheral does not appear to be plugged in" I've updated the driver and it says the realtek device is working fine. Sound worked just fine on this computer but then stopped. I do not have external speakers. How can I plug in the speakers or fix the problem? :(
Sound & Audio
Speakers wont work but headphones do
Hi, I have a dell inspiron 1545 laptop. My warranty just expired and my speakers stopped working. when i diagnose them on my computer it says everything is fine. Ive reinstalled my drivers and there isnt anything wrong in the device manager. if i plug in my headphones i can hear. Please tell...
Sound & Audio
Sound Works.. when speakers are OFF!?!?!
Ok, i updated my integrated sound drivers with windows 7, and now my speakers only work when i have them off. and its very faint. Whats going on?!
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App