Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 5.1 sound recognized but working wrong :S

29 May 2011   #1
Joselas

Windows 7 Ultimate x64
 
 
5.1 sound recognized but working wrong :S

First of all, hello everybody, im new there... i present myself, my name is Jose, i live in spain and im Telecomunications and informatic technic, now lets go with my trouble

Well, my prob is:

I have a 5.1 genius sound system conected to my pc, my OS is win7 ultimate 64 bits edition and it doesnt work fine like it did in my old win XP.

What have i done? I have updated my drivers to the last version available, when i test the system I see that every speaker and subwoffer works fine so its not about that issue with jack re-positioning which i have readed in this forum.

When I play games like Blur the sound is really nice and it works perfectly, but godamnit i cant get my 5.1 sound with the Windows Media Player when i play music :S

Does anyone know how could i fix this?

Thank you all for reading this, I hope somebody can help me because im a music entusiast and this is really giving me a big headhache.

Regards, Jose!


My System SpecsSystem Spec
.

29 May 2011   #2
jebuchanan

Windows 7 Ultimate x64 (Retail)
 
 

You need to install a plugin for WMP, such as SRS HAL
This will give you what you are looking for.
My System SpecsSystem Spec
29 May 2011   #3
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
Does anyone know how could i fix this?
It is doing exactly what it is supposed too do. You have to remember that to get 5.1/surround sound the source has to be encoded as such (DVD audio for example). Other than that any surround sound from music is upmixed/simulated.

You don't list your specs or what you are using for a sound card, but for Realtek audio you need to enabled the speaker fill option and for Creative sound cards you need to enable CMSS3D (no idea what it is called on the others).
My System SpecsSystem Spec
.


30 May 2011   #4
Joselas

Windows 7 Ultimate x64
 
 

First of all thank you for your replies

I forgot to say which sound card i have, big fault, its a realtek, cant specify which one now since im at work, later i will post it..

First thing i will do is to try with stormys solution since i prefer to try that before installing any plug-in at my pc, i already though about my music is not 5.1 sound, but didnt think its the problem because in winXP the music used to sound through the whole sound system, well it might be simulate a 5.1 by default, i dont know, i will try to use that fill option

After that, if it doesnt work i will try with that plug in, jebuchanan, later i will post the result, I hope it works fine with this

Regards, Jose!
My System SpecsSystem Spec
30 May 2011   #5
Joselas

Windows 7 Ultimate x64
 
 

Whoa! Working perfect now! I tried with that filling option, also enabled the low frecuancy redirection option and the subwofer sounds damn nice, just like it used to do in winXP, also configured the rear speakers gain and distante so i hear all speakers fine...

Thank you so much guys, specially to stormy for your good answer

Regards and thanks again, if any mod read this you can close this topic, i can say now... PROBLEM FIXED!!
My System SpecsSystem Spec
30 May 2011   #6
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

Thanks for the feedback Jose and rep to the people that helped you would be much appreciated, I'm sure.

You can always notify the mods that a thread is solved by clicking on the red triangle at the top of your comment and type "solved" in the text box.

I'm not a mod, but I've notified them on your behalf.
My System SpecsSystem Spec
Reply

 5.1 sound recognized but working wrong :S




Thread Tools





Similar help and support threads
Thread Forum
No sound through earplugs, although plugging in is recognized
Hi all, I have a curious problem, which I'm not able to solve on my own although I've a couple of solutions. Here is the problem: When I plug my earphones in, its recognized that something is plugged in, the sound output changes, but I hear nothing through my earplugs. I'm sure that: the...
Sound & Audio
Headphones not being recognized correctly or playing sound
Howdy-hey, everybody. Lately, my Acer Aspire laptop hasn't been able to play sound from headphones, or recognize that I have headphones/earbuds plugged into the headphone jack. A scan for my headphones from the "Add a device" option doesn't turn up anything. In fact, the last solution I tried...
Sound & Audio
USB previously working not recognized
Hi everybody, I read the topics in the forum, but I did not found something that suits my needs, so I start a new thread. I'm running a Windows 7 Enterprise 64bit on a nHP EliteBook 8470p laptop, and I'm experiencing a strange issue. Connecting a USB device to the port, it works properly for...
Hardware & Devices
Possible to add a sound to wrong password on logon?
Me and my friend at college are messing around with computers and are trying to get his personal one pretty much all on a starcraft theme. We have been getting pretty far, his OS is Windows 7 Build 7600. We want to get it so that if a wrong password is entered, it says "Access Code Denied" in the...
Customization
Mic not recognized, no sound
I have a built-in mic on an Inspiron 1521 laptop that does not work ever since I have installed Windows 7. I've been told it could be solved by installing drivers, but I'm not sure which drivers those would be. Also, I've looked at the settings and set one microphone as default, but it still wasn't...
Sound & Audio
Sound Card not recognized in W7
I have an asus A8n-sli board with the Nforce4 chipset. I have creative x-fi xtreme music installed on the board and the sound works fine in XP. The issue is that the when I try to install the drivers it keeps telling me that there is no compatible hardware installed. In device manager it shows...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App