Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Blaster X-Fi Xtreme Audio / Creative.com

30 May 2011   #1
natedp

Windows 7 Home Premium 64-bit
 
 
Sound Blaster X-Fi Xtreme Audio / Creative.com

Ok, so I read the stickied topic about the X-Fi Xtreme Audio driver, as I think this maybe a part of my computers less-than stable condition after recent Fresh Installs of Windows 7 Home Premium 64bit.

I got 2 things...

1) When I install Drivers off my CD, I get a SpiRunE.dll error about a module isn't there/cannot load. But the installation completes and I restart PC and it loads up the Creative Register/Update program.

2) Creative.com website is down. Does anyone have a Mirror site available for this driver or the Daniel K's? Is this compatible with Win 7 H.P. 64bit?

Thanks


My System SpecsSystem Spec
.
30 May 2011   #2
Fumz

7 Ultimate x64
 
 

PCI or PCI-E?
My System SpecsSystem Spec
30 May 2011   #3
natedp

Windows 7 Home Premium 64-bit
 
 

I'm sorry, I really don't know how to check that. When looking at my MOBO through the casing, it sits below my Video Cards which is the last slot open to the back of my case.
My System SpecsSystem Spec
.

30 May 2011   #4
Fumz

7 Ultimate x64
 
 

If by "back" you mean "bottom", then that's a black PCI-e slot... so your card would have to be PCI-e. Newegg.com - ASUS Sabertooth X58 LGA 1366 Intel X58 SATA 6Gb/s USB 3.0 ATX Intel Motherboard

I can't get to creative.com too.. but I recall extreme audio drive issues. Not sure if you still have to use the Vista driver, or if there's been an update from Creative?

I'd wait till they're back up before doing something risky...
My System SpecsSystem Spec
30 May 2011   #5
natedp

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by Fumz View Post
If by "back" you mean "bottom", then that's a black PCI-e slot... so your card would have to be PCI-e. Newegg.com - ASUS Sabertooth X58 LGA 1366 Intel X58 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
Not sure if this helps, but there's a snapshot.


And I was afraid I might have to wait, heh...


Attached Images
 
My System SpecsSystem Spec
30 May 2011   #6
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

I have the Xtreme Audio support pack 2.7 by Daniel_K here,

Gamefront

don't remember now if it works with the PCI-E version of the card or not, but I believe it does.

P.S. Unless the driver disk has Windows 7 drivers on it, don't use it at all.
My System SpecsSystem Spec
30 May 2011   #7
natedp

Windows 7 Home Premium 64-bit
 
 

EDIT / UPDATE

Creative website came back up and I found the file.

Thanks for the assistance all.
My System SpecsSystem Spec
30 May 2011   #8
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

2nd from the bottom.

Gamefront
My System SpecsSystem Spec
Reply

 Sound Blaster X-Fi Xtreme Audio / Creative.com




Thread Tools





Similar help and support threads
Thread Forum
Sound Blaster X-Fi Xtreme Audio: Speakers pop when I click some things
I put in a Creative Sound Blaster X-Fi Xtreme Audio (PCIe), installed the latest driver from Creative, found here: Creative Worldwide Support (1.04.0000, released 30th June, 2009), and it seems that whenever I click things that make noise (a good example being the volume slider in the system tray),...
Sound & Audio
Creative X-Fi Xtreme Audio plays no sound
Hi, I installed my soundcard, everything works perfect. I installed drivers and i get no trouble at device manager. After I plug my headphones in and try to play music, i get no sound. At the sound options in windows i see the soundcard and it looks like it works, because the green bar goes up...
Sound & Audio
Creative Sound Blaster X-Fi Xtreme Audio PCI - microphone problem
Hello there. Yesterday i've installed this sound card and everything works fine but no microphone. I can see it in control panel but it doesn't work. Mic is fine as i was using it before. I have Win 7 64bit. If you have any idea what can cause the issue please help, if nothing will work i will...
Sound & Audio
Creative's Sound Blaster X-Fi Xtreme Audio PCI Express
Hey mates, Today I bought and installed a new sound card. Creative's Sound Blaster X-Fi Xtreme Audio PCI Express. More information about the card can be found here: Creative Labs Online Store (Europe) | Sound Blaster | Buy Creative PCI Express X-Fi Xtreme Audio Anyway, this card is a...
Sound & Audio
Sound Blaster X-Fi Xtreme Audio 70SB104000001
Hi guys I treated myself to a new pc but the only thing missing is a soundcard. Im looking at Sound Blaster X-Fi Xtreme Audio 70SB104000001 Creative Labs Online Store (UK) | Sound Blaster | Buy Creative PCI Express X-Fi Xtreme Audio I am running windows seven home premium 64bit and i...
Sound & Audio
Creative Sound Blaster X-Fi Xtreme Audio
Hi, im running windows 7 (7100) 32 bit. Ive got Creative Sound Blaster X-Fi Xtreme Audio in, ive downloaded the xp, vista and 7 beta drivers from creative, they either say driver version not found OR they say the device isnt plugged in properly, which it is having run it with xp. The only thing i...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App