Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek Audio Control Panel wont open


11 Jul 2011   #1

Windows 7 Home Premium 64bit
 
 
Realtek Audio Control Panel wont open

Hello out there; first time on this forum, but first time I've hit a problem I can't seem to find a working solution for, so I hope someone can help. I've seen similar issues, and tried multiple solutions, but so far nothing has changed.

I recently purchased a Dell XPS laptop running Windows7 (upgrade from my old Lenovo which ran VistaSP2), and it comes with the Realtek HD Audio Manager. Fantastic sound from the internal JBL speakers and subwoofer - I have no complaints about Realtek's driver. My problem is that, when I plug my headphones in, the sound continues to play from the speakers, and nothing from the headphones. Suggestions online said to change headphones to the default in Control Panel > Sound, but my headphones don't appear on the list. I also noticed I wasn't getting the notifications for headphones plugged in / unplugged; I checked, and the notifications are enabled, so clearly the problem is that my headphones aren't being detected (tried with multiple headsets and speakers to be sure). Another check online said to change the settings for auto-detection in the Realtek HD Audio Control Panel, found under the Windows control panel or from the orange icon in the task bar.

OK, so here it is: the Control Panel wont open. I found the icon in the Windows control panel, but the Realtek software wont load. I don't even have the orange icon in my taskbar, just a black-and-white icon that does nothing. The Realtek HD Audio Manager works great, except I can't access the Control Panel to fix my problems.

Every solution I've found just involved reinstalling the Realtek Audio Manager. I tried rolling back to the original version on the CD that came with my laptop; I've updated through Dell's site; I've updated to the newest version from Realtek's site; I've tried downloading it and updating manually through the Device Manager. I even tried running the compatibility version for Vista which worked so well on my old laptop. After many reboots, I've successfully updated the DRIVER over and over again, with no change to the CONTROL PANEL.

So is there some compatibility issue here, or how do I get the Realtek HD Audio CONTROL PANEL (not just the driver/audio manager) to work on Windows 7 as I've seen screenshots of it from many other users?

My System SpecsSystem Spec
.

11 Jul 2011   #2

Windows 8.1
 
 

Hi Their FyreFiend, Welcome to Seven Forums


My First Thought is can you access the Original EXE for the Audio Manager either from the Windows Folder or from Program Files (Both Folders) It should Be something Similar to

C:\Program Files (x86)\Realtek\Audio\Drivers
C:\Windows\System32\
Try opening the Exe in their and see if it solves your Problem
My System SpecsSystem Spec
11 Jul 2011   #3

Windows 8.1
 
 

On the taskbar is the Audio Manager if you can right click and press the PLayback devices, then change it to your headphone jack such then it should work also.

See Below \/\/\/
My System SpecsSystem Spec
.


11 Jul 2011   #4

Windows 7 Home Premium 64bit
 
 

I'm not sure what audiodg.exe does as nothing appears to happen. And I don't see anything related to the control panel in the Realtek folder. I tried everything in there earlier, I can launch the "audio manager" a few different ways (that's where the black-and-white speaker icon in my system tray is coming from, but I don't get the typical orange icon that's supposed to link to the control panel) but I have no way to open the control panel except the broken link under Windows' Control Panel.

Also forgot to mention, I ran a diagnostic from the boot menu and the headphone jack works fine, just to prove it's a software issue that I need to fix from the reluctant realtek control panel.

A few things I noticed about the Realtek installation:
1)It uses the same version for 7 as vista anyways (1 download file, the folders it creates are under ...\Vista64\...
2)Every time I run the installer, just as it finishes I get a weird error from Windows: Host process "Rundll32.exe" has stopped working and was closed. ??
3)I don't even have a folder in my start menu for Realtek Audio...depending which installer I use I sometimes get it or right now I have a folder for "Dell Audio by Realtek" which will launch the manager (black-and-white icon) but has nothing for the Control Panel.
My System SpecsSystem Spec
11 Jul 2011   #5

Windows 8.1
 
 



That now sounds like you have the Wrong Version for the Audio Deck that you are using,

and ignore the Audiodg i clicked it by accident and didnt check my post.

If you have the actual Zip file with the audio codecs and Exe in it can you not extract it to a folder and run it directly from there?

AS to your Broken link im trying to remember how i got around that on my pc... Give me a while and ill do some digging for you..

Cheers
My System SpecsSystem Spec
11 Jul 2011   #6

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Windows Sniper View Post
On the taskbar is the Audio Manager if you can right click and press the PLayback devices, then change it to your headphone jack such then it should work also.

See Below \/\/\/
Yes I can get to the Playback Devices, where my headphones are not listed. They are not detected by the audio manager, a problem which can apparently be solved through the audio control panel...which wont load.
See my compound issue here?
My System SpecsSystem Spec
11 Jul 2011   #7

Windows 8.1
 
 

Right i've just looked up your LP Model and Drivers.

Try using this Alternate Driver Package, Its the Xp and Vista Drivers in one package and has your ACL665 Added to the package.

I'm thinking that Dell are offering an out of date Driver.

http://downloads.guru3d.com/downloadget.php?id=2151&file=4&evp=3dac154c00093e461a3fe419950bf9ef
My System SpecsSystem Spec
12 Jul 2011   #8

Windows 7 Home Premium 64bit
 
 

Good news! Problem Solved!

In the end the solution came from home after all, but thank you for your help and advice WindowsSniper as it pointed me in the right direction. My sister ended up buying the same laptop, and we noticed that hers works just fine with headphones. Funny part was, the Realtek Control panel on hers looked nothing like the screenshots I had seen; turns out Dell uses their own customized OEM version of the software, the control panel has their logo all over it and that's why my taskbar icon is black-and-white. I knew a lot of laptops came with OEM drivers, but I didn't think that would be preventing the download from Realtek's site from installing properly.

In any case, after several times reinstalling Dell's version from the driver CD with no effect, and getting that same error message "Rundll32.exe has stopped working" I figured there might be a corrupted file on there or my laptop because it obviously was not installing/running properly. As a second thought, it may have been conflicting with the Soundblaster X-fi MB software if that didn't install properly.

Solution: I manually uninstalled the entire Realtek package, making sure to clean out everything. I then reinstalled the SoundBlaster software, using the full installation settings. After that, I picked up the Driver CD that came with my sister's laptop and used that to reinstall Realtek - this time no error message, and the control panel / headphone detection is working fine now. I'm still running an older version of the driver, I'll try to update that later through the device manager but at least I know this version of Realtek is working

I might be wrong, but my suspicions are:
Either SoundBlaster didn't install properly and was conflicting with Realtek, or the download I got from Dell didn't install properly, causing the original problem.
A tiny scratch on the disk says my Driver + Utilities CD was not reinstalling Realtek properly. Downloaded versions weren't working right because I needed Dell's OEM version.

Again, thanks for all the advice; I'm just glad I don't have to send this back in
My System SpecsSystem Spec
12 Jul 2011   #9

Windows 8.1
 
 

Thats Great News FyreFiend,

Glad That Everything Is Sorted for you now.

Dont Be a Stranger o the Forums
My System SpecsSystem Spec
31 Oct 2011   #10

Windows 7 Home Premium 64bit
 
 

Hey FyreFiend, I just register to this forum to thanks you!!

I have the similiar exact problem, except it's start with loud high pitch buzzing sound for few days. Then this host error and waves control panel won't appear.

I did exactly as you describe, uninstall realtek driver, uninstall and reinstall SoundBlaster X-Fi MB and re-install driver from the CD, it solved my problem.

I wonder if it's okay to update the Realtek driver now, because Dell has release latest Realtek driver at support website.

Now, tomorrow Dell technician will visit me with new speaker for replacement. Guess I'll get a new speaker for all the hassle. :P

Thanks FyreFiend!
My System SpecsSystem Spec
Reply

 Realtek Audio Control Panel wont open




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:45 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33