Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 and X-Fi conflict

08 Aug 2011   #1
Blade7658

Windows 7 Home Premium 64bit
 
 
Windows 7 and X-Fi conflict

Newbie here, so sorry if I this is a repeat. I searched the forum and couldn't find what I needed. I upgraded to Windows 7 64 bit and my Sound Blaster X-Fi Hendicks that came with the computer is now acting strangely. It is plugged in correctly (according the the jack detection) but in entertainment mode it auto-detects 5.1 but on testing (within Creative Console Launcher) it only plays the left/right channel. In game mode, it only sees 2/2.1 and again only plays left/right channel. My driver is 6.0.1.1376 from 5/5/2010 which was the latest I could find for this card but I am at wit's end. Any help is much appreciated.


My System SpecsSystem Spec
.
09 Aug 2011   #2
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

so you've gone through and uninstalled all previous drivers (link on how to completely remove all traces of previous drivers) related to the product and then installed the latest, correct drivers (win7 64bit)? After that did you go into the control panel for the product and search anything that might switch the mode from 2.1 to 5.1? You might also check the windows audio control panel and see if that has anyhting in it, though I don't think it does. I am not at home so I cannot check at this moment (on XP). Let me know
My System SpecsSystem Spec
10 Aug 2011   #3
Blade7658

Windows 7 Home Premium 64bit
 
 

Out of town for a few days, so will uninstall again (just to make sure I removed all and will follow the instructions link - thanks!) and check the panel when I get back. Will reply some time this weekend, thanks!
My System SpecsSystem Spec
.

10 Aug 2011   #4
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

let us know when you get back!
My System SpecsSystem Spec
15 Aug 2011   #5
Blade7658

Windows 7 Home Premium 64bit
 
 

OK, I feel like an idiot. No driver issues so then I checked (again, for the 100th time I am sure) and see the configure buttom below the playback device list found in the Control Panel. Sure enough, I had "stereo" selected as my configuration. Changed it to "5.1 Surround" and it works fine. Sorry for the confusion, thanks for the reply!
My System SpecsSystem Spec
21 Aug 2011   #6
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

you are very welcome and I am glad you found the problem. Mark the thread as solved (should have a green button on the very bottom if you scroll down) if you would be so kind
My System SpecsSystem Spec
21 Aug 2011   #7
Blade7658

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by DustSailor View Post
you are very welcome and I am glad you found the problem. Mark the thread as solved (should have a green button on the very bottom if you scroll down) if you would be so kind
Marked it as solved last week, so I think we are good.
My System SpecsSystem Spec
Reply

 Windows 7 and X-Fi conflict




Thread Tools




Similar help and support threads
Thread Forum
VPN Anyconnect and Windows 7 conflict ?
Is anyone else having this issue and do you have any solutions for this? We are using a software application that is using port 16011 to open up a map. Below is what I'm experiencing. Win XP Pro & Anyconnect = Works Win 7 32bit via wired network not using Anyconnect = Works Win 7 32bit via...
Network & Sharing
windows 7 and macrium conflict
Hi if i backup and restore my computer using windows 7 and also do the same using macrium reflect wouldn't they conflict? thanks
Backup and Restore
Windows Installer language conflict?
Just moved up to 64 bits Windows 7. I have the Dutch language version. I am trying to install MSXML2 Sp2 (msxml.msi). One can choose from a number of languages, but not Dutch, so I choose English (which is what I always did previously, and without problems). As soon as I click on Install, my...
Installation & Setup
conflict between nvidia and windows 7
Hi, ive just installed a gts250 graphicscard, installed the drivers on the cd. they were outdated, so i updated them. only, when i turn the computer down, and then turn it back on, it somehow got back into the old drivers. could it be that windows 7 somehow doesnt save the new nvidia options?
Graphic Cards
Windows 7/XP conflict
I recently rebuilt my computer and decided to install a new hard drive with Windows 7. My old hard drive was fine and had XP but I had video driver issues when playing high end graphics games. However, when I tried to start Win 7 with the XP HDD as the slave it wouldn't load. I could start the...
Hardware & Devices
OpenDNS windows 7 conflict
Hello everyone, I've been reading posts here for a while but I just registered today. I just installed OpenDNS on my router last night and everything is working fine on my vista 64 machines. The first time I booted my laptop, which has been working great with windows 7, it immediately froze and...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App