Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X-fi Titanium HD install nightmare. Win7 64

14 Aug 2011   #11
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

After I posted my question, I DID find it and installed it.

Not surprisingly:






My System SpecsSystem Spec
.
14 Aug 2011   #12
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
The driver file that gets downloaded is XFTI_PCDRV_LB_2_17_0008.exe which is about 49MB.
Which won't work with the Titanium HD as it has its own driver different from the rest of the X-Fi cards,

Creative Worldwide Support > Sound Blaster X-Fi Titanium HD

Quote:
File Name : SBRL_PCDRV_LB_3_00_1004.exe
This download is a driver providing Microsoft® Windows® 7 and Windows Vista® support for Creative Sound Blaster® X-Fi™ Titanium HD. For more details, read the rest of this web release note.
P.S. Mewp please stop resizing your screen shots, makes them very hard to read without a magnifying glass.
My System SpecsSystem Spec
14 Aug 2011   #13
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Your dxdiag screenshots are too small for me to see clearly. They've been resized I guess.

Anyway, it looks like our two CTAUD2K.SYS drivers differ on their dates. Mine is from 7/7/2010 and yours looks like it's from 5/2011. That may be because you have an X-Fi Titanium HD card, and mine is simply an X-Fi Titanium.

Anyway, my dxdiag output is as follows:



My System SpecsSystem Spec
.

14 Aug 2011   #14
Mewp

Windows 7 Ultimate x64
 
 

Sorry guys, I'm just copying and pasting the img link from photobucket..
My System SpecsSystem Spec
14 Aug 2011   #15
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by Mewp View Post
Sorry guys, I'm just copying and pasting the img link from photobucket..
I use Imageshack, but does Photobucket provide a setting for indicating the intended size of your display screen?

Imageshack default is 800x600, but you can change it. I've specified 1024x768 so that the resize of large screenshots doesn't get shrunk too much.



If Photobucket has a similar setting, you should make it larger than whatever you currently have... which honestly is too small (especially since your Win7 has "normal 100%" font size, whereas mine is "medium - 125%" so that things for me are already 25% larger anyway).
My System SpecsSystem Spec
14 Aug 2011   #16
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

My System SpecsSystem Spec
14 Aug 2011   #17
Mewp

Windows 7 Ultimate x64
 
 

*Edit*
My System SpecsSystem Spec
14 Aug 2011   #18
Mewp

Windows 7 Ultimate x64
 
 

Here we go.


Attached Thumbnails
X-fi Titanium HD install nightmare. Win7 64-capture.jpg   X-fi Titanium HD install nightmare. Win7 64-capture1.jpg  
My System SpecsSystem Spec
14 Aug 2011   #19
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Much better. Thank you.

Anyway, I think the errors must all be just different costumes of the same basic problem. It's now clear that the Titanium HD driver is different from the regular Titanium driver... which is, unfortunately, one more variable that cannot be duplicated or tested by me since I don't have an HD card.

So we don't know if you've got a new hardware failure problem, or if there's an inherent problem in the Creative driver for the HD card.

But again... if this just started happening a week ago, what happened at that time? Did you install some software updates?

Do you have a System Image or System Restore Point from before a week ago that you can try going back to, to see if it resolves the problem?
My System SpecsSystem Spec
14 Aug 2011   #20
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by Mewp View Post
Here we go.
Interesting that the HD driver does not say "WHQL logo'd", as the regular driver does.
My System SpecsSystem Spec
Reply

 X-fi Titanium HD install nightmare. Win7 64




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Need IE9 , IE11 nightmare for win7 64 bit
Hello I hope this is correct place for this posting, as its during install. I have win7 64, and I was using IE9 with zero problems. I had to re-install(fresh install) win7 64bit and now IE9 is no longer available! I go to this page for IE9 and microsoft says we recommend IE11 , the...
Browsers & Mail
Install on latter partition nightmare
Please help I've been struggling to install 7 home premium OEM onto a 320gb hard drive on a Toshiba laptop.# Think make and model is unimportant. It's a mates laptop and the first 60gb are damaged so I have partitioned the first 60gb and left it as unallocated. Then install 7 onto the later...
Installation & Setup
Windows 7 install from x32 to x64 error! Nightmare!
Hi, New to this forum, but read a lot of information off here, but none has helped me as yet. Probably due to the almost infinte variables between computer parts and software. My problem is the "no cd/dvd Drive Device driver" on a clean install of windows 7 ulitimate x64. So I'll give you...
Installation & Setup
Fresh install missing CD/DVD driver nightmare
The horror… The horror… Take pity… Please help… Save me from more of this… The same “CD/DVD drivers missing” msg as so many others. Desperately attempting to fresh install Win7, 64bit (Genuine OEM disk) (This is what I get by trying to "Move on up" from XP) If I set the BIOS to...
Installation & Setup
Audio Problem(Win7) Creative Sound Blaster X-Fi Titanium Champion Seri
Hi everyone, so I just purchased the Creative Sound Blaster X-Fi Titanium Fatal1ty Champion Series Sound Card. I'm having issues with audio(even before I bought the card) and I'm not sure how to fix them. I'll describe the main issues. Sound Issues: -Odd popping noise at the beginning and...
Sound & Audio
SB Titanium will not work under Win7
I've posted elsewhere here about my Win7 upgrade. I run a Dell XPS 420. Upgraded to Win7 x64 Ultimate (no regrets overall - love it!). But my SoundBlaster X-Fi Extreme Audio would no longer record "What U Hear." Creative admitted that X-Fi Audio cards will not record What U Hear under Win7. They...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:06.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App