Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X-fi Titanium HD install nightmare. Win7 64

14 Aug 2011   #21
Mewp

Windows 7 Ultimate x64
 
 

I just bought the card on Friday and haven't had it working yet. I did notice the WHQL thing as well..But then again. I'm running the beta driver so that might be it maybe.


My System SpecsSystem Spec
.
14 Aug 2011   #22
Mewp

Windows 7 Ultimate x64
 
 

Here's a better shot of a previous still


Attached Thumbnails
X-fi Titanium HD install nightmare. Win7 64-direct.jpg  
My System SpecsSystem Spec
14 Aug 2011   #23
Mewp

Windows 7 Ultimate x64
 
 

well the driver version xxx1006 is the latest beta driver. I'm going to try uninstalling and reinstalling to an older driver and see what happens.
My System SpecsSystem Spec
.

14 Aug 2011   #24
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by Mewp View Post
I just bought the card on Friday and haven't had it working yet. I did notice the WHQL thing as well..But then again. I'm running the beta driver so that might be it maybe.
Looking at the Creative site for the HD card, it appears that (as was pointed out) the official driver version for that card is SBRL_PCDRV_LB_3_00_1004.exe, dated February 2011... not the May 2011 version you're trying to use (which you say is a beta version).

How about uninstalling the current driver, and then installing the official February version, to see if that makes any difference?
My System SpecsSystem Spec
14 Aug 2011   #25
Mewp

Windows 7 Ultimate x64
 
 

I'll give that a try. I uninstalled the beta but it keeps reinstalling the beta.I'll try driver sweeper and reinstall the 1004's. Thanks
My System SpecsSystem Spec
14 Aug 2011   #26
Mewp

Windows 7 Ultimate x64
 
 

Same thing


Attached Thumbnails
X-fi Titanium HD install nightmare. Win7 64-1004.jpg  
My System SpecsSystem Spec
15 Aug 2011   #27
nireagle

Windows 7 Ultimate x86
 
 

Try this if you haven't already:

Extract the driver file (SBRL_PCDRV_LB_3_00_1004.exe) using 7zip. Then go to Drivers folder and run setup.exe (Run as administrator)

Click Driver Uninstallation and check "Delete all shared Creative audio driver file" it will prompt for restart, do so. then again run the setup and install the driver. Don't forget to check "Overwrite existing shared Creative audio driver file" it will install the driver itself wait for few minutes then restart and you're done!


Attached Images
X-fi Titanium HD install nightmare. Win7 64-creative-driver-update-utility.png 
My System SpecsSystem Spec
15 Aug 2011   #28
Mewp

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by nireagle View Post
Try this if you haven't already:

Extract the driver file (SBRL_PCDRV_LB_3_00_1004.exe) using 7zip. Then go to Drivers folder and run setup.exe (Run as administrator)

Click Driver Uninstallation and check "Delete all shared Creative audio driver file" it will prompt for restart, do so. then again run the setup and install the driver. Don't forget to check "Overwrite existing shared Creative audio driver file" it will install the driver itself wait for few minutes then restart and you're done!
I'm going to try that. If this works, I will piss myself lol
My System SpecsSystem Spec
16 Aug 2011   #29
nireagle

Windows 7 Ultimate x86
 
 

I hope it works for you. I had the similar problem once. My windows wasn't detecting my X-fi. Tried this and worked like a charm! let us know how it goes for you.

NIR
My System SpecsSystem Spec
16 Aug 2011   #30
Mewp

Windows 7 Ultimate x64
 
 

Nir,
Still getting no output device installed

My System SpecsSystem Spec
Reply

 X-fi Titanium HD install nightmare. Win7 64




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Need IE9 , IE11 nightmare for win7 64 bit
Hello I hope this is correct place for this posting, as its during install. I have win7 64, and I was using IE9 with zero problems. I had to re-install(fresh install) win7 64bit and now IE9 is no longer available! I go to this page for IE9 and microsoft says we recommend IE11 , the...
Browsers & Mail
Install on latter partition nightmare
Please help I've been struggling to install 7 home premium OEM onto a 320gb hard drive on a Toshiba laptop.# Think make and model is unimportant. It's a mates laptop and the first 60gb are damaged so I have partitioned the first 60gb and left it as unallocated. Then install 7 onto the later...
Installation & Setup
Windows 7 install from x32 to x64 error! Nightmare!
Hi, New to this forum, but read a lot of information off here, but none has helped me as yet. Probably due to the almost infinte variables between computer parts and software. My problem is the "no cd/dvd Drive Device driver" on a clean install of windows 7 ulitimate x64. So I'll give you...
Installation & Setup
Fresh install missing CD/DVD driver nightmare
The horror… The horror… Take pity… Please help… Save me from more of this… The same “CD/DVD drivers missing” msg as so many others. Desperately attempting to fresh install Win7, 64bit (Genuine OEM disk) (This is what I get by trying to "Move on up" from XP) If I set the BIOS to...
Installation & Setup
Audio Problem(Win7) Creative Sound Blaster X-Fi Titanium Champion Seri
Hi everyone, so I just purchased the Creative Sound Blaster X-Fi Titanium Fatal1ty Champion Series Sound Card. I'm having issues with audio(even before I bought the card) and I'm not sure how to fix them. I'll describe the main issues. Sound Issues: -Odd popping noise at the beginning and...
Sound & Audio
SB Titanium will not work under Win7
I've posted elsewhere here about my Win7 upgrade. I run a Dell XPS 420. Upgraded to Win7 x64 Ultimate (no regrets overall - love it!). But my SoundBlaster X-Fi Extreme Audio would no longer record "What U Hear." Creative admitted that X-Fi Audio cards will not record What U Hear under Win7. They...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App