Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: No Sound on HDMI out

26 Jul 2009   #11

vista x64/ win 7 x64
 
 

the only thing i can come up with why it works with xp and not 7 is there's still a bug in the driver/windows interface which prevents the HDsignal to be passed along.

HDMI needs extra information ( mostly DRM related ) to process the video/audio stream.

Direct spdif doesn't. But for spdif any cable will do for a tryout if you a have cinch output.
Just take a stereo cinch audio cable and use just one of the wires.

If it works you know why. If it doesn't then you'll have to wait for the driver issues to be resolved. In that case be sure to report it.

My System SpecsSystem Spec
.

27 Jul 2009   #12

Windows 7
 
 

Hi tosunthex,

did u found any solution, because I've got exactly the same Problem : / ?
My System SpecsSystem Spec
28 Jul 2009   #13

Windows 7 Build 7600 64bit/Ubuntu/Leopard
 
 

HDMI on my laptop works.
My System SpecsSystem Spec
.


30 Jul 2009   #14

windows 7 build7600
 
 

i m still searching for answer some laptops and desktops have excatly same problem with me but no body have answer for that. so right now im using my old coaxial cable
My System SpecsSystem Spec
30 Jul 2009   #15

Windows 7 Ultimate X64
 
 

I have a HP G60-230US and my HDMI is working fine with sound. but at first it did not, the HDMI cable was not pushed in right , I have to make sure the cable is pushed in all the way for it to work, so maybe it's just your cable, I went out and got one of those cheap ones, so you get what you pay for.
My System SpecsSystem Spec
01 Aug 2009   #16

Windows 7
 
 

I think this is a Nvidia driver bug!
I use the Nvidia 182.50 driver for Vista on my Windows 7.
This is the last Nvidia driver witch works with sound over hdmi (for me).

HDMI audio doesn't work with new drivers - NVIDIA Forums

GeForce Release 182
My System SpecsSystem Spec
09 Aug 2009   #17

Windows 7
 
 

I have a very similar problem.

My computer is a Sony Vaio Z laptop. While on Vista, video and audio are outputted over HDMI to my LCD TV without any problems.

Once I upgraded to Windows 7, however, the audio no longer outputs. When I go to the Sound panel, it tells me the HDMI Output works, but that the cable is not plugged in (it is definitely plugged in as the video works).

I have an Nvidia GeForce 9300M GS and Realtek HD Audio.

Any ideas??

There is definitely a bug somewhere.
My System SpecsSystem Spec
09 Aug 2009   #18

Windows 7
 
 

i think there was a recent update because when i first upgraded from vista to Windows 7 my dell inspiron 1525 with sigmatel HDMI audio worked fine with both HDMI output audio and video... as of yesterday... after a windows update( it was automatic... i noticed the system was updated because i have new themes and wallpapers i did not download) my HDMI audio does not work but video works fine... it seems as if this problem was only affecting a small number of PCs at first but after a recent update MS somehow managed to mess it up for a lot of us....
My System SpecsSystem Spec
10 Aug 2009   #19

vista x64/ win 7 x64
 
 

to all, just be patient and don't wear yourself out looking for answers. It's the driver/audio sublayer interaction.

My system has a nice trick (7600 + realtek HD) if it wakes from sleep only the leftchannel works. Rebooting doesn't help. I have to take out the audiojack wait for a while and reinsert it and it works again till the next sleep.

Guess we'll have to live with it till this gets sorted out.
My System SpecsSystem Spec
25 Aug 2009   #20

windows 7 build7600
 
 

Quote   Quote: Originally Posted by desmo View Post
I think this is a Nvidia driver bug!
I use the Nvidia 182.50 driver for Vista on my Windows 7.
This is the last Nvidia driver witch works with sound over hdmi (for me).

HDMI audio doesn't work with new drivers - NVIDIA Forums

GeForce Release 182

thx for your help m8 now my hdmi port works perfectly iwas format my pc yesterday and use geforce 182 driver now i have sound and video on hdmi
My System SpecsSystem Spec
Reply

 No Sound on HDMI out





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:29 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33