Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Sound on HDMI out

25 Jul 2009   #1

windows 7 build7600
 
 
No Sound on HDMI out

hey there

first sry for my bad english
after searching google all day and upgrade my soundcard,motherboard and graphic drivers still i cant fixed my sound problem. Still i cant hear anything on Palit 9800 Hdmi out. i change my default playback device to "Realtek Digital Output" but still no sound on hdmi. when i use my pc speaker everything is working very good but i want to watch my MKV s on my tv.

i was upgrade from windows xp and when i using xp my system was worked very good

Name:  Capture.JPG
Views: 302
Size:  38.5 KB
My Pc Spec
gigabyte p35c ds3r mobo with Realtek alc889
palit 9800gt
Windows 7 build 7600 64bit

My drivers
Realtek R229 "vista_win7_r229.exe"
Nvidia 190.38 "190.38_desktop_win7_winvista_64bit_english_whql"

My AV Reciever
Philips DFR 9000 "its support dts thx and other things"

How can i fix this problem ??




My System SpecsSystem Spec
.

25 Jul 2009   #2

 

Only some video cards carry audio over the HDMI port. The RealTek hi-def audio port is NOT on the HDMI cable. Coonect the RealTek digitial audio port directly to your TV/system.
My System SpecsSystem Spec
25 Jul 2009   #3
Microsoft MVP

Win 7 Ultimate x64
 
 

You get a cable like this with your video card,



If not contact Palit and ask them about getting one, as no Nvidia card can do audio over HDMI without one of those cables going from the sound card to the video card.

Edit: And here is how you do it,

http://www.overclock.net/nvidia/4411...ml#post5305349
My System SpecsSystem Spec
.


25 Jul 2009   #4

windows 7 build7600
 
 

thx for help guys but i have that cable and it works perfectly in windows xp . when i was upgrade to windows 7 my problems start. i m talking about working system guys still same cable still same card i make same connection like this only chage is windows 7. but now i cant transfer sound on hdmi port.
My System SpecsSystem Spec
25 Jul 2009   #5
Microsoft MVP

Win 7 Ultimate x64
 
 

You have it set to SPDIF/digital out in the Realtek controls as well as the Windows one?
My System SpecsSystem Spec
25 Jul 2009   #6

windows 7 build7600
 
 

thx for fast reply stormy
if you change one (in windows control or in realtek control panel) other one is automatically change but yes i did and check both of them again still no sound.
No Sound on HDMI out-capture2.jpg


My System SpecsSystem Spec
25 Jul 2009   #7

Windows 7 Build 7600 64bit/Ubuntu/Leopard
 
 

which version...200
My System SpecsSystem Spec
26 Jul 2009   #8

windows 7 build7600
 
 

Quote   Quote: Originally Posted by 7Dreams View Post
which version...200
i dont understand what r u asking for but you can check my first post for drivers and windows7 version
My System SpecsSystem Spec
26 Jul 2009   #9

vista x64/ win 7 x64
 
 

if you have a digital input on your amp, try first if you can get sound using a spdif cable.

I myself don't use the hdmi for sound. I plug the spdif to my surround amp. And it worked even with a v186 Realtek driver.
My System SpecsSystem Spec
26 Jul 2009   #10

windows 7 build7600
 
 

my system was work very good in xp and now why i need a new cable now :S if i transfer everything in one cable why i use 2 cable... and i think you cant give me guarantee for spdif is work when i will buy a new cable because they r same.. i think nothing is change taking out on mobo jumper or taking out from back of mobo spdif..
My System SpecsSystem Spec
Reply

 No Sound on HDMI out




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33