Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Another HDMI Audio Problem

21 Aug 2011   #1
Bytowner

Windows 7, 32 bit
 
 
Another HDMI Audio Problem

Hi everyone,
I know this topic is a popular one, I've done enough searches on google to figure out I'm not alone with this problem, but still, after a few years, I still can't find the answer. I realise there is a similar thread active right now but my problem is a bit different in that I don't have the option of HDMI in my playback devices at all.

I'm using
Samsung R480 laptop
Intel Core i5
nVidia GeForce GT 330M
High Definition Audio Device (EDIT: when I was updating the drivers Realtek uninstalled itself, this should read Realtek High Definition Audio)

This is a familiar story by now BUT: when I first got my computer my HDMI video and sound worked fine hooked up to my Samsung Plasma. I recall having some problems when I first tried to hook it up, but I figured it out (somehow, this was a couple years ago) and I'm 75% sure it had to do with the drivers. Then I went away for a year, came home and the audio is gone. I have updated all my drivers (I think) and Samsung Update Plus doesn't have anything for me. "Speakers" are the only choice in my playback devices menu and I have show disabled devices checked.

Apologies, I know this comes up often, but I'm at the end of my rope.


My System SpecsSystem Spec
.
21 Aug 2011   #2
seth500

Windows 7 Ultimate x64
 
 

What shows up in device manager? Does it show the HDMI device and does it show it's working properly?


Attached Thumbnails
-8-21-2011-5-05-52-pm.png  
My System SpecsSystem Spec
21 Aug 2011   #3
Bytowner

Windows 7, 32 bit
 
 

Thanks for the quick response.

Under sound, video and game controllers I have:
Bluetooth handsfree audio
Realtek High Definition Audio

It says the device is working properly.
My System SpecsSystem Spec
.

21 Aug 2011   #4
metalmania31

Windows 7 Pro 64bit build 7601 SP1
 
 

Did you make sure the cable is good? What about any settings on the tv itself too?
My System SpecsSystem Spec
21 Aug 2011   #5
Bytowner

Windows 7, 32 bit
 
 

Yep cable is fine. Can't see anything in the tv settings that look off. Source is definitely correct.
My System SpecsSystem Spec
21 Aug 2011   #6
Sardonicus

Windows 7 Home Premium 64 bit
 
 

From what you've mentioned, you don't seem to have an HDMI audio driver installed.
You should see an Nvidia High Definition Audio Device in the device manager.
Your HDMI audio driver would be included in the Nvidia driver package.
It could be as simple as re-installing your Nvidia drivers or maybe not, but you should try that first.
My System SpecsSystem Spec
21 Aug 2011   #7
Bytowner

Windows 7, 32 bit
 
 

Thanks p5bdkw. I tried doing a clean install for the NVIDIA drivers, the video installed but the audio did not (just said "not installed"), so I assume my audio isn't going through there (???). Pretty sure I'm not delusional though, it was definitely working before I left home.
My System SpecsSystem Spec
22 Aug 2011   #8
Sardonicus

Windows 7 Home Premium 64 bit
 
 

Sometimes a system restore may fix the problem. You may have the option of a Samsung restore, as well as a Windows 7 restore.
You can also try using the original drivers from the Samsung support website.
Be sure to select your correct model and model code.
Samsung
My System SpecsSystem Spec
22 Aug 2011   #9
Bytowner

Windows 7, 32 bit
 
 

You get the prize p5bdkw!
I have the Canadian version, so went to the Canadian website and downloaded the first "HDMI" driver. Turned out to be HDMI Audio for NVIDIA and bingo my HDMI option has returned. No idea how it got removed. Thanks so much!
My System SpecsSystem Spec
Reply

 Another HDMI Audio Problem




Thread Tools




Similar help and support threads
Thread Forum
HDMI audio out problem
Hey! I'm trying to hook up my pc to the tv through a hdmi cable. The image is just fine, but there is no sound coming out from the tv (the sound is always coming from the notebook) Some things: I updated the video drivers and the audio drivers In the sound configuration, it says that the...
Sound & Audio
hdmi audio nvidia g100 problem.. HELP
ok my computer is acer aspire x1700 and it comes iwth a discrete nvidia geforce g100 video card with HDMI output,when i hook it up tomy tv theres no audio. but if i use the motherboard hdmi it has audio, how do i get my NVIDIA TO PLAY AUDIO. plz help i have the latest drivers
Graphic Cards
Hdmi audio problem
ok well i was watching a movie online with the hdmi it was all working fine and all and after the movie i shut off the laptop off for a little bit to cool it down and when i turn it back on the computer it say that i have a hdmi to dvi when its hdmi to dvi and doent detect the hdmi audio any...
Music, Pictures & Video
HDMI Audio Problem
Okay guys, didn't think this would turn out to be such a problem as it is: Basically we got new computer 3-4 weeks ago - Acer Aspire X3900 running Windows 7 Professional x64 - and the GeForce 320 GT in it is HDMI ready. So we went out and bought a Full HD monitor and an HDMI cable and all was...
Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI
hi all, I have my media center PC connected to a Sansung LCD TV through an HDMI cable. Everything works fine; the PC detects TV and both audio and video travel through the HDMI cable from PC to TV The problem happens when I turn the TV OFF and ON. In this case, the video is back but not the...
Sound & Audio
Windows 7 64 bit HDMI Audio Problem
I have just built an i5 rig and can't get the audio to work over the HDMI, I have seen many posts but none of the solutions seem to work for me. I have: 1) Realtek ALC888 onboard audio - R240 drivers. 2) A 9600GT with DVI to HDMI adapter - 195.62 drivers. (Tried the 181 drivers as well)...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App