Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cracking Popping audio. DPC latency checked. Atheros AR5B87.

05 Sep 2011   #1
Karnage420

Windows 7 Home Premium x64
 
 
Cracking Popping audio. DPC latency checked. Atheros AR5B87.

I just bought a new Acer Laptop.
I have been experiencing audio issues in the form of random cracks and pops, its really annoying and a relatively powerful computer like this shouldnt be having just simple issues.

I have read a few threads on here with similar issues.
i downloaded DPC latency and was able to isolate the problem to the ATHEROS AR5B97.
I have two atheros devices on my computer (see screenshot)
i frist tried disabling the second one (Atheros AR8151 PCI-E Gigabit ethernet controller NDIs 6.20), no change.

I disabled the first one (Atheros AR5B97 Wireless Network Adapter) and i got no red lines on DPC latency!
now that i have found the problem, what do i do?
Thanks in advance! this forum really is a godsend!


My System SpecsSystem Spec
.
06 Sep 2011   #2
Karnage420

Windows 7 Home Premium x64
 
 
anyone?

I can provide any information you guys need.
please help!


Attached Images
  
My System SpecsSystem Spec
26 Sep 2011   #3
Bushin

Windows 7 64-bit
 
 

Hey Karnage,

I have the exact same problem as you. Let me guess: Acer Aspire 7750G-6634?

You are on the right track to solving this problem. I too have isolated the cause to the Atheros Wireless W-LAN adapter. I've been troubleshooting this issue for a few weeks now and I thought I had it resolved when I updated the PCI-E Ethernet controller. For a few days there was no poping or latency that I could hear. But then it started up again.

I am in the process of tracking down the latest drivers for the Atheros AR5B97 Wireless Adapter. I found some on a Czech site, but they're not signed so I'm a little hesitant about installing them. If I don't find anything better, I will probably try them out tonight.

ATHEROS drivers for Microsoft Windows

The specific drivers are here:

Drivers for Atheros AR5B97 and Windows 7
My System SpecsSystem Spec
.

26 Sep 2011   #4
Karnage420

Windows 7 Home Premium x64
 
 

yes! same laptop.

i installed a program that scans my computer for drivers and auto updates them. this fixed the problem.
My System SpecsSystem Spec
26 Sep 2011   #5
Bushin

Windows 7 64-bit
 
 

Really? You mean like Driver Doctor or something like that? I always thought those things were not that great to use, and carry spyware.

Which one did you use, and do you know which drivers the program updated to solve the problem? I'm thinking the W-LAN drivers confilct with the Realtek Audio Drivers.
My System SpecsSystem Spec
26 Sep 2011   #6
Karnage420

Windows 7 Home Premium x64
 
 

driver genius professional edition.
highly recommend it.
My System SpecsSystem Spec
26 Sep 2011   #7
Bushin

Windows 7 64-bit
 
 

Thanks for the info. But I'm going to try to do this the old-fashion way and pin-point the exact driver to install. Any info you can provide would help alot. If I get it fixed I'll make sure to post the exact cause and solution here.
My System SpecsSystem Spec
08 Oct 2011   #8
Unknown1

Windows 7 HP 64bit
 
 

Hello, can you say driver version that fix dpc problem?
My System SpecsSystem Spec
10 Oct 2011   #9
Bushin

Windows 7 64-bit
 
 
Pretty much solved

Sorry for not getting back here on this sooner, had a crazy few weeks of work.

I installed only the WLAN Atheros 9.0.0.202 W7x64 drivers. Latency still occurs but much much less than before. These are the best drivers for the W-LAN card so far.

DPC Latency still has spikes, but not enough to cause repeated stuttering or popping in the audio or video. The sound glitch will only occur if DPC latency spikes to or above 16000us. I have been testing the laptop extensively and it has been running beautifully.


Attached Images
 
My System SpecsSystem Spec
29 Dec 2011   #10
Xeroxis

Win-7
 
 

I had the same problem with AR5B97, I am not sure when this started but it was annoying, finally I was able to solve it completely, I installed a modded AR9287 driver from a post in MODDED ATHEROS DRIVERS TO ENABLE ALL KNOWN SETTINGS 8.0.279 x86 & x64-IMPROVES PERFOR. Windows showed a warning before installing it but after that eveything worked like charm, WLAN speed is same but I think that signal strength is improved. I registered to share this, hope it helps.
My System SpecsSystem Spec
Reply

 Cracking Popping audio. DPC latency checked. Atheros AR5B87.




Thread Tools




Similar help and support threads
Thread Forum
My audio is skipping, and cracking really bad.
I can barely watch youtube videos because the sound is skipping and cracking so bad I have the latest Realtek HD audio codec, I even tried uninstalling the driver and re-installing it Is there maybe a solution of a something different that Realtek? This isn't really a new problem, but I...
Sound & Audio
Cracking audio via video card's HDMI port.
Hey guys, just wanted to check if anyone has experienced this issue. Specs are below: ASUS z97-A motherboard EVGA GeForce GTX 970 SC ACX 2.0 (running on stock) Corsair Vengeance 2x4GB 1866 i5 4690k (running on stock) There is very alarming crackling audio when I use my PC via my video...
Sound & Audio
Cracking sound after installing realtek HD audio drivers.... plz help
hi all. I'm new to this forum and i've recently installed windows 7 ultimate on my MSI vr440 laptop. after installing it i was unable to use my Mic so i installed Realtek HD audio drivers after downloading it from their website. now the problem is that i have a crackling sound coming out of my...
Sound & Audio
Realtek HD audio - Front jack makes cracking sound
MODS: I post this thread to isolate the most important problem from my previous thread and to make it clearer and easier to answer. I hope that's alright. I have this on onboard Realtek HD audio card. And no matter if I connect the AC'97 or HD audio adapter to the motherboard, the sound that...
Sound & Audio
Sound popping/cracking/interference
Hi there. First post, but you guys seem to know your stuff! I'm reviving an old computer currently and put Windows 7 64bit on it. I couldn't for the life of me get the onboard sound working (ASUS A8N-SLI Deluxe). So I went and bought an uber cheap PCI soundcard, this one in fact Asonic 4 Channel...
Sound & Audio
Cracking / Popping Sound
Hello everyone, I've been noticing a "popping" or "cracking" noise coming from my speakers/headphones. The first I noticed it was during a movie, and I assumed it was the movie's audio - but since then I have been hearing it during music and other movies and from both speakers and headphones....
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App