Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound from SPDIF Xonar DS output to TV with Windows 7

07 Sep 2011   #1
qwiksilvertrav

Windows 7 Home Premium 32bit
 
 
No sound from SPDIF Xonar DS output to TV with Windows 7

Ok before I had Windows XP...have a Xonar DS Audio card with a SPDIF output going to my Nvidia 9500GT Video card...the video card is connected to my Yamaha V-867 Reciever via HDMI and then of course the reciever to the TV via HDMI.

So with XP it worked great. Had the video card set via the Nvidia control panel to Clone display so it'd just be two identicle displays on each monitor. Sound would be on my pc AND on my TV at the same time.
Well now I just upgraded to Windows 7 with the same connections. I only get sound on my PC speakers and NOT on my TV or Receiver speakers. The reciever shows it's not being fed any audio information. I have the audio set in my Xonar DS Center the same as it was in XP and nothing shows up on the equalizer when playing movies in Xonar DS. So it seems WMP is using the Xonar card to play audio of course...but not feeding it to the Xonar Center and not sending it out the SPDIF output. It's something with Windows 7 and the sound card?
Any help would be great...let me know if you need anymore info.


My System SpecsSystem Spec
.
07 Sep 2011   #2
qwiksilvertrav

Windows 7 Home Premium 32bit
 
 

Ok so of course after posting this I semi figure it out. lol On my audio device settings it has 3 hardware options...1 SPDIF output device, then two speaker outputs....one being the Xonar output and other being Realtek output device.

If I select Xonar output to the speakers I get sound on the reciever speakers (not on the TV though but not a big deal I guess) but no sound on the computer speakers. With the Realtek the opposite.

So NOW my question is how can I set this up to have sound on both without having to mess with options each time I want to watch a movie. Is there some way I can the Xonar card to just run everything?
My System SpecsSystem Spec
Reply

 No sound from SPDIF Xonar DS output to TV with Windows 7




Thread Tools




Similar help and support threads
Thread Forum
No sound through SPDIF out (red) Optical.
Hi, I have a Gigabyte GA-Z68X-UD3h-B3 Motherboard, which has a SPDIF out port on it. I followed the instructions by going into the Realtek Audio manager and setting it to "Digital Output (Optical) " and when I test it, no sound comes out, it is hooked up to a Vizio HD Tv, Im using a Nvidia 8800 GT...
Sound & Audio
NO sound whatsoever with Realtek AC'97 and SPDIF output
This one has got me pulling my hair out!! I hope you guys can help.. I'm surprised I havent found anyone else in my boat out there! I have a little Shuttle G2 6100H, also known as the SB61G2v3.It has the FB61 v3 motherboard made by Shuttle themselves and an onboard Intel Springdale 865...
Drivers
My SPDIF Output sends bad data
Hello SevenForums, This issue just occurred out of nowhere, my optical audio output used to work fine. Now when i set my "Realtek Digital Output" to default, the bars work as they should and the red light passes through the optical fiber cable. But when it reaches my "receiver" (Logitech...
Sound & Audio
Audiophile 2.1 sound system for Xonar D2X sound card.
I have given up on getting a good 5.1 or 7.1 sound system for my pc since it requires a receiver and all. What I am looking for right now is a 2.1 sound system that can be directly plugged in to my Asus Xonar D2X sound card. The system should have a really decent subwoofer with tight and deep...
Sound & Audio
spdif output not working properly
Hi , i have been using Windows 7 RC for awhile now .I have the coaxial spdif output on my Gigabyte Ep 45-ds3r board connected to my home theartre amp.Have been getting 5.1 sound with no problems.I recently installed Windows 7 enterprise edition to my pc and now only have 2.1 sound.Have tried the...
Sound & Audio
AC-97 SPDIF output, just linear no Dolby surround
First of all , hi to everyone, this is my first post in this forum and since i found no welcome threat, i just post the first part here :D so second is my somewhat awesome problem. I recently just switched to windows 7 on my pc. specs. Abit NF7-S rev. 2.0 AMD BArton 3000+ 2x 512 MB Ram
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App