Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Audio Endpoint Builder Service Not Starting

11 Sep 2011   #1
deadman7387

Windows 7 Ultimate x64
 
 
Audio Endpoint Builder Service Not Starting

Hello,

My system's sound suddenly stopped today. I checked the speakers and they are working fine. I also reinstalled the drivers but to no avail. I opened Windows Sound in Control Panel and there it mentioned that the Windows Audio Service wasn't working. I tried starting it and I got a message stating that one of the dependencies are not started. Of the three dependencies, Windows Audio Endpoint Builder service wasn't started. When I attempt to start this service, I get the following message :


This service's dependency i.e. Plug and Play is working fine. Event viewer shows the following entry for this failed attempt :

Code:
Log Name:      System
Source:        Service Control Manager
Date:          11-Sep-11 4:02:15 PM
Event ID:      7023
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Vrushank_Desai
Description:
The Windows Audio Endpoint Builder service terminated with the following error: 
The RPC server is unavailable.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7023</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2011-09-11T10:32:15.674120000Z" />
    <EventRecordID>194706</EventRecordID>
    <Correlation />
    <Execution ProcessID="576" ThreadID="2592" />
    <Channel>System</Channel>
    <Computer>Vrushank_Desai</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Windows Audio Endpoint Builder</Data>
    <Data Name="param2">%%1722</Data>
  </EventData>
</Event>
Could someone please let me know what's the issue ?


My System SpecsSystem Spec
.

11 Sep 2011   #2
fireberd

Windows 7/8.1/10 64 bit
 
 

See THIS thread that I found doing a search for "windows audio endpoint builder". There are a lot of google hits for this error.
My System SpecsSystem Spec
11 Sep 2011   #3
deadman7387

Windows 7 Ultimate x64
 
 

Found the solution. It was the Power Service that wasn't listed as dependency but was required. I started the service and rebooted and I can hear sound again...
My System SpecsSystem Spec
.


11 Sep 2011   #4
fireberd

Windows 7/8.1/10 64 bit
 
 

Thanks for the feedback and that you found the problem
My System SpecsSystem Spec
Reply

 Audio Endpoint Builder Service Not Starting




Thread Tools





Similar help and support threads
Thread Forum
audio service not working, dependency service does not exist...
hi can anyone help? i have a medion akoya laptop running windows 7 64 bit i have no audio. if i click troubleshoot problems it says the audio service is not running it says the windows audio and endpoint builder arent working if i go into services, windows audio is set to automatic but its...
Sound & Audio
"Windows Audio Endpoint Builder" service will not start
The audio services worked fine at first. But after optimizing the system for gaming and security, the "Windows Audio Endpoint Builder" service fails to start. It gives the error: "Error 1722: The RPC server is unavailable" This is required for the "Windows Audio" service, so I have no sound now....
Sound & Audio
Weird behavior of Audio Service and Audio Endpoint Builder
Hi, Since this week, I'm experiencing strange behaviors of my sound installation. At times, the Windows Audio Service does not start. The "Audio Endpoint Builder" and the "Multimedia Class Scheduler" do have started. I tried some fixes, like changing the NDIS value (which led me to completely...
Sound & Audio
Windows Audio Endpoint Builder Consumes High Memory?
I recently applied windows 7 updates, didn't see what was updated since it frequently updates something. After that the memory usage increased from normal 30+ percentage to 50+ percentage. I checked with task manager it was svhost.exe and the service it was running is the "Windows Audio...
Performance & Maintenance
Windows Audio Endpoint Builder issue
I've noticed high CPU utilization on that one particular service from time to time, sometimes hitting as high as 85,000k in Windows task manager, and I'm not even running anything with sound on it at that particular moment. I've tried Googling for answers but the issues most people are running...
Performance & Maintenance
windows audio endpoint builder???
Anyone knows what that service is and why it needs to eat over 60,000k of ram?
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App