Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Asus SupremeFX X-FI

01 Mar 2010   #111

Win 7 x64

was initially having some problems and could not make it work, but then i was using the drivers and utils from the support cd. so i downloaded the driver and util from the asus site and it worked like a charm =p

My System SpecsSystem Spec
02 Mar 2010   #112



Good luck
My System SpecsSystem Spec
06 Mar 2010   #113

Win7 Ultima


i have an issuse with this mobo and sound as well, thought id start a new thread as it was diffrent. tho no one bothered replying.
windows 7 is not seeing my audio card and when i place the cd rom in, i don't get options for the sound card drivers. still evan better is when i go to asus and download there drivers driect i get an issuse with them installing and i get an error that they are not for the os: WNT_6.IP_64_MCE
ps they are from the win7 64 list of drivers

any suggestion please.

ps. i had no trouble using this on the evaluation edition of windows 7
My System SpecsSystem Spec

13 Oct 2010   #114


1) You tried to disable your onboard soundcard (if available) in BIOS?
2) Try to deplug your soundcard, blow into the slots to get the dust out of it. And finnaley plug it back again.
3) Still not working? Try another PCI port? Make sure its good connected.
4) Try the driver I added the link at the bottom of this message.
5) The latest option is to reinstall Windows... (deinstall all current drivers of this sound-card)
6) Soundcard is broken, however that will be very unlikely.
Download Driver Mirror:
  1. 2shared - download
  2. http://***************/files/
My System SpecsSystem Spec
25 Oct 2010   #115

Windows 7x64

"There are no supported audio device available. You need to close the application. Click OK to close the application now."

I've got a Sound Blaster X-Fi 5.1 Surround and that bug is driving me nuts; tried EVERY SINGLE solution provided here but alas, to no avail!

My System SpecsSystem Spec
28 Oct 2010   #116

Windows 7x64

My System SpecsSystem Spec
29 Oct 2010   #117

Windows 7x64

Nevermind, installing Pax Drivers did the trick... problem solved ^^
My System SpecsSystem Spec
25 Jan 2011   #118

Windows 7 Ultimate x64

Нужна Ваша помощь...
У меня win 7 x64 и не отображается подключение 5.1 в Volume Panel SB X-Fi MB...
Вот что показывает....
Asus SupremeFX X-FI-.jpg

Asus SupremeFX X-FI-2.jpg

Что делать?

My System SpecsSystem Spec
25 Jan 2011   #119

Windows 7 Home Premium 64bit

Quote   Quote: Originally Posted by drobila View Post
Нужна Ваша помощь...
У меня win 7 x64 и не отображается подключение 5.1 в Volume Panel SB X-Fi MB...
Вот что показывает....
Attachment 134271

Attachment 134272

Что делать?
Do you have a set of 5.1 speakers connected?
If Im not mistaken, the options for 2,4,5,and 7.1 only appear if you do.
This may be why its not allowing it to be changed.

If this is the ASUS X-Fi that came with the board, it may also be slightly different. Im not sure, although it should be the same.

Oh, and English please.
My System SpecsSystem Spec
25 Jan 2011   #120

Windows 7 Ultimate x64

I have a redundant system is Logitech Z-5500 DIGITAL, I hooked it through the optics Spdf into your sound card ...
Tested on the redundant system Win xn - all without a problem as you and writing appears different connection, up to 7.1 ....
And then only 2/2.1 and all, and even choose not ... But you saw the picture ....
Why not see the connection 5.1?
My System SpecsSystem Spec

 Asus SupremeFX X-FI

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Asus Laptop can't find startup entries for Asus Programs
Asus has some way of starting their programs that I can't find. In particular, I want to disable their Wireless Console 3 (wcourier.exe). There are other programs but I can't remember what they are right now. I can only tell you that is does not show up in msconfig or HJT. Does anybody know...
Performance & Maintenance
ASUS HD 6850 or ASUS GTX 560 (non-Ti, DirectCU, 810MHz)?
Helllo everyone, I wanted to buy the Radeon HD 6870 but it's not on the market here anymore, so I will have to buy another one -- hopefully not the HD 7850 xD. So, which one should I pick: the ASUS EAH6850, or the ASUS ENGTX560. Give your reasons please. I need the answer before Wednesday (2nd...
Graphic Cards
upgraded frpm asus P6T to asus P6T deluxe 2...
do i need to reformat???
General Discussion
SupremeFX X-Fi 7.1 HD -Audiodg memory prob.
Anyone got any clue how to fix the bug I've got when the audiodg eats my RAM. It's exactly the same as for everyone else. Just keeps climbing and eating It's way up.
Sound & Audio
SupremeFX II Win 7 !Doesnt Work!
Hi there, before beginning the explanation, sorry for my bad English ... :confused: so the thing is, that the new drivers that are in the ASUS site, don't work, it tells me that the hardware doesn't support the software, soo, any solution for this? cuz i'm desperate here :cry:
SupremeFX on windows 7
Hi people.. I have problem configuring my asus supremeFX soundcard on windows7.. I did'n find the right driver... The default drivers don't allow us to config the 5.1 feature.. This came with my motherboard Asus Crosshair-1.... So some one help me with this... Thanks
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:17.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App