Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Asus SupremeFX X-FI

25 Jan 2011   #121

Windows 7 Home Premium 64bit

Im not sure, sorry.

My guess would be that it has something to do with the SPDF connection.

You may need to set 5.1 with Z5500s control panel.
The only other thing I can suggest would be try hooking it up with the analog connections and see if it starts showing up.

Hopefully someone with more experience with such setups can offer something more helpful.

My System SpecsSystem Spec
25 Jan 2011   #122

Windows 7 Ultimate x64

The fact that I plugged in all possible ways both analog and through the SPDF, when switching from analog to optics is sound, but another question ....
Program Volume Panel Sat X-Fi MB I can not customize the sound to 5.1 - that's the problem ...
Showing only connection 2/2.1 and all without options ....( although windows xn - everything is displayed and you can select variant)
My System SpecsSystem Spec
25 Jan 2011   #123

Windows 7 Ultimate x64

may have a problem with drivers, although I installed all the manufacturer's website and drive home with a wood for the motherboard ....
My System SpecsSystem Spec

18 Feb 2011   #124

Windows 7 Ultimate x64

@ drobila

I also have same sound card and the problem you are facing is normal. First of all I think you don't need to provide config for 2.1 or 5.1 or anything while you are using S/PDIF or Digital output. The card automatically recognize that according to output from your player and gives output from Digital or S/PDIF port accordingly. You can post process on sound from your receiver or speaker system. Well this is because the sound card we are using does not have that function to process on digital output. I can give you tip on how to change that thing to 5.1 but again I whatever changes you make in ENTERTAINMENT MODE panel doesn't effect anything on your digital output. I already tried and came to the conclusion that it is lake of functionality in sound card.

I am also desperate like you to apply those settings on digital output and really appreciate if somebody can guide us but till now I can say that we can't.

Anyways, Go to control panel > Hardware and Sound > Sound and there you can click on Speakers and Click Configure. There you can select 5.1 and then in ENTERTAINMENT MODE you can see 5.1 instead of 2/2.1. But remember still it won't make any changes to SPDIF Interface.
My System SpecsSystem Spec
27 Jan 2014   #125

Win7 64bit

Hi guys,

sorry, for digging out this old thread.
I've had a similar problem with my fake X-Fi and Rampage 2.
Drivers partially worked and had a quite strange result like Firefox working correct,
with 5.1 sound and everything, but VLC, or WMP only play stereo, with subwoofer silent.
So I googled my ass off, finding no solution to that problem in any forum.
Finally, I found something, that worked, and so I took on the task to register
at every forum I came across, to post the solution, which as it seems, doesn't really exist until today.

Allright, here it comes:

1. Downlaod the SoundMax Treiber Version from the Asus-site (NOT THE BETA-VERSION!):
Find it under the AUDIO-Tab:

2. Install, then reboot.

3. Download the Creative Driver (Sound Blaster X-Fi Utility V1.0(R19) for Windows XP 32/64bit & Vista 32/64bit & Windows7 32/64bit.(WHQL):
Find it under the UTILITIES-Tab:

4. Install & reboot.

5. Now, if you try to open up the new Creative-Tool from the taskbar, you will get an error, saying
"no proper audio-device found", or similar.
Now the fix for this particular problem unexpectedly comes from Dell:
Driver Details | Dell US

6. Download & install, no reboot required

7. Now you can open up the Creative-Tool and configure CMSS3D, Bass-routing, etc.

Hope, the next guy searching for some solution doesn't need to google his ass off :-) .

My System SpecsSystem Spec

 Asus SupremeFX X-FI

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Asus Laptop can't find startup entries for Asus Programs
Asus has some way of starting their programs that I can't find. In particular, I want to disable their Wireless Console 3 (wcourier.exe). There are other programs but I can't remember what they are right now. I can only tell you that is does not show up in msconfig or HJT. Does anybody know...
Performance & Maintenance
ASUS HD 6850 or ASUS GTX 560 (non-Ti, DirectCU, 810MHz)?
Helllo everyone, I wanted to buy the Radeon HD 6870 but it's not on the market here anymore, so I will have to buy another one -- hopefully not the HD 7850 xD. So, which one should I pick: the ASUS EAH6850, or the ASUS ENGTX560. Give your reasons please. I need the answer before Wednesday (2nd...
Graphic Cards
upgraded frpm asus P6T to asus P6T deluxe 2...
do i need to reformat???
General Discussion
SupremeFX X-Fi 7.1 HD -Audiodg memory prob.
Anyone got any clue how to fix the bug I've got when the audiodg eats my RAM. It's exactly the same as for everyone else. Just keeps climbing and eating It's way up.
Sound & Audio
SupremeFX II Win 7 !Doesnt Work!
Hi there, before beginning the explanation, sorry for my bad English ... :confused: so the thing is, that the new drivers that are in the ASUS site, don't work, it tells me that the hardware doesn't support the software, soo, any solution for this? cuz i'm desperate here :cry:
SupremeFX on windows 7
Hi people.. I have problem configuring my asus supremeFX soundcard on windows7.. I did'n find the right driver... The default drivers don't allow us to config the 5.1 feature.. This came with my motherboard Asus Crosshair-1.... So some one help me with this... Thanks
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:02.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App