Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 5.1 Sound doesnt work at Realtek High Definition Audio Device

14 Oct 2011   #1
Skrip

Windows 7 Ultimate 64-bit SP1
 
 
5.1 Sound doesnt work at Realtek High Definition Audio Device

Hello, Some time ago i was tried to connect my 5.1 creative speakers to my laptop and when i wass connecting one by one the cables windows 7 asked me what speakers it will play ( Rear, Front, Center) but now i try to connect them again and it does not ask me that ... and only 2 speakers and sub is playing know ... and cant find what is the problem and when i go to Sound and press at the speakers that is working configure there is not a choice of 5.1 as it was before ... What is the Problem know please can anyone help me ?


My System SpecsSystem Spec
.

14 Oct 2011   #2
Sub Styler

Windows 7 Ultimate x64
 
 

Do you have the VIA HD Audio Deck installed with your sound driver. It may be in the control panel, systray or not installed. It should be compatible with your realtek onboard audio. I usually have more luck using this to configure my speaker setup than windows as in may versions it supports jack switching.
My System SpecsSystem Spec
14 Oct 2011   #3
Skrip

Windows 7 Ultimate 64-bit SP1
 
 

Its not installed where do i find it ?
My System SpecsSystem Spec
.


14 Oct 2011   #4
Sub Styler

Windows 7 Ultimate x64
 
 

Doh, dont listen to me, realtek and VIA are both very different cards, they are just both so common I overlooked the obvious. For the Realtek Mixer try here (the realtek version of the same thing) Realtek
My System SpecsSystem Spec
14 Oct 2011   #5
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

If you laptop is like the majority of them made then there is no problem. Reason being is that it only has a single jack for connecting speakers/headphones, and you cannot get 5.1 sound from a single jack it takes three; one for the front speakers, one for the rears, and one for the center/sub.
My System SpecsSystem Spec
14 Oct 2011   #6
Skrip

Windows 7 Ultimate 64-bit SP1
 
 

No ok i Just Fixed all ! I just gone to Dell site And dowloaded drivers for my onboard Sound car ! and its all as was before ! but thanks for your answers ... SIGMATEL Driver for SIGMATEL STAC 92XX C-Major HD Audio Version: 6.10.0.5866, A03
My System SpecsSystem Spec
14 Oct 2011   #7
Skrip

Windows 7 Ultimate 64-bit SP1
 
 

Hey i have another Question ! there is no Ajustment of Level of rear or front Speakers.. How can i Ajust them Because the rear is very low and all i hear is from the front and center ..
My System SpecsSystem Spec
14 Oct 2011   #8
linnemeyerhere

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64
 
 

I don't believe you'll be able to as the rears are just being averaged off the content of the mains as it's not a true 5.1 set up.
My System SpecsSystem Spec
14 Oct 2011   #9
Skrip

Windows 7 Ultimate 64-bit SP1
 
 

Hmm i think and Believe that there is a way to do it ... but dont know how anyone else with some idea on how i adjust the rear speakers ?
My System SpecsSystem Spec
14 Oct 2011   #10
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

How many audio jacks are on your laptop? It takes 3 of them (usually color coded green, black and orange) to get 5.1 sound from an analogue connection, anything other than that and it is nothing more than stereo upmixed by the speaker set itself with no way to control any levels via software.

Would help to know the make and model of the laptop, as well as the model of Logitech speakers.
My System SpecsSystem Spec
Reply

 5.1 Sound doesnt work at Realtek High Definition Audio Device




Thread Tools





Similar help and support threads
Thread Forum
realtek high definition audio and high definition audio device problem
Hi everyone, I would be very grateful for some help please! My laptop recently installed a BIOS update - I don't know what this was but since it happened I have been having sound problems with my laptop. After the update I had no sound. I read around and found how to get the sound back on - I...
Sound & Audio
High Definition Audio Device - No Sound
Hi everyone. I bought my mom a refurbished PC and no sound comes out of the speakers. I have made multiple attempts to update the sound driver with no luck. The salesperson over the phone told me I needed to download a new sound driver, but offered no help in identifying which one. I have...
Sound & Audio
no sound ,Win7-ultimate x86,realtek high definition audio card
hi i had windows Xp Sp2 for several years and yesterday i have upgraded to Win7. everything went fine except for the sound. i have K9A2 cf-f MSI main-board with on board realtek high definition audio card(i saw the name on device manager it was below of AMD high definition audio device).after...
Sound & Audio
Realtek High Definition Audio, No Sound
This is the second time this has happened. My audio is not working. No output at all. My audio card is motherboard integrated. As said in the title, it is Realtek High Definition Audio (Speakers). Like I also said, this is the second time this has happened. Last time, I reinstalled my drivers...
Sound & Audio
realtek high definition audio device - no sound
Hi, I just got a new PC and I can't get the sound to work. My PC has the following specs: Microsoft Windows 7 (6.1) Enterprise Edition 64-bit Service Pack 1 (Build 7601) DirectX Version 11.0 CPU Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz Mainboard Model ...
Sound & Audio
Realtek High Definition audio no sound after latest update r2.65
Please help...my sound wuz and had been working great for a year now after the purchase bt then i decided to update it to r2.65 yesterday then after the first boot it ddnt work..i have spent almost 5 hours chcking da forums n googling and cannot find a solution to this. Sony Vaio vpcea16fg...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App