Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HDMI Sound randomly not working - test in settings gets it working?

15 Oct 2011   #1
Livin

Windows 7 Pro
 
 
HDMI Sound randomly not working - test in settings gets it working?

I have started having an issue over the past week (config/drivers/etc not changed in months) where sound will randomly not be output by HDMI.

System config/specs...
Win7 SP1 all patches, nearly a stock install... only running WMC and XBMC.
Only 3rd part stuff installed are SpeedFan an ATI drivers. (problem occurs if Speedfan is running, or not)
system runs 16 hrs per day, auto shutdown at night.
Dell Optiplex, 6GB RAM + Core2Duo E7400, SSD - no swap file
HDMI is the default, and only sound device enabled (disabled all others in OS)

History... was working perfectly for over 2 years. One Win7 rebuild in that time. Updated video card once and drivers occasionally.


Symptom...
Approx half the time when I start up WMC or XBMC sound output via HDMI does not work. The other half of the time it works fine.
-- to get it working I can open Sound CPL and run "test". Sound will play through HDMI and all is fine usually the rest of the day, but sometimes it has the problem again if I don't use the system for several hours.
-- it never faults (stops working) while in use... only on initial XBMC or WMC startup... again system is always running hours before I start the apps.



Any ideas?


My System SpecsSystem Spec
.

15 Oct 2011   #2
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

This sounds like a problem with the video driver pack (also includes hdmi audio driver)
I would completely remove what you have now then download and reinstall the latest fresh again.
It could just be a glitch in the matrix so to speak.
My System SpecsSystem Spec
Reply

 HDMI Sound randomly not working - test in settings gets it working?




Thread Tools





Similar help and support threads
Thread Forum
Sound on Laptop and Desktop Randomly Stops Working and Working
So recently the sound on my desktop and my laptop has stopped working. For seemingly no reason. I really don't understand it. I first noticed it with my desktop. The sound just randomly stopped working. But not...entirely. It's really strange and complicated what's been happening, so bare with...
Sound & Audio
HDMI output not working (just sound)
My playback device for my HDMI output is an AMD HDMI Output. I just got a new Bush Smart TV after cracking my old LG. HDMI output sound worked perfectly fine on my old tv and it works fine on my other Samsung TV. However the soud only refuses to work on my new Bush TV. The picture works fine and...
Sound & Audio
HDMI sound not working
I have my laptop connected to my TV via HDMI. The video works but the sound plays through the laptop speakers. This sound worked yesterday and for the last year or so but for some reason it stopped working today. When I go into my playback devices I only have two listed (Speakers and Headphones,...
Sound & Audio
HDMI sound randomly stopped working
sorry for starting a new thread but i have searched through so many and still not found a fix for my issue I was watching a movie and sound worked perfectly fell asleep woke up the next morning and no sound through my tv connected via gainward gtx550ti HDMI port it still shows in playback...
Sound & Audio
HDMI 5.1 surround sound not working
I am aware that there are a number of threads on this topic here and elsewhere, yet I have spent hours searching, reading, and attempting fixes to no avail. I have a computer with a NVIDIA GeForce GT240 graphics card that is passing audio and video via HDMI through a Denon AVR-591 receiver, and...
Sound & Audio
Windows 7 HDMI sound not working
My computer IS able to send sound through the HDMI port as I remember it working once. It isn't working now though. I have a Nvidia Geforce GT 120 video card and my sound did work once i believe when I was allowed the option for S/pdif output, but now I only have 3 options shown in the photo. I'm...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App