Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 5.1 surround problems (realtek)

04 Sep 2009   #91

Windows 7
Maybe solved


I think i solved the same problem ( only 2 front speakers used ).

Just turn in room correction!
My 5.1 AC3 movie test was fine with this setting.
Winamp needed that Vista sound 5.1 plugin

But it's a half solution

My System SpecsSystem Spec
04 Sep 2009   #92

Windows 7 RC1
Dolby thingy..

Guys, I think I found the solution!!!

My problem was exactly like yours and I had tried every method mentioned. However salvation was actually right before my eyes

Now, go to Control Panel -> Hardware and Sound -> Sound

Now, choose "Speakers" and press "Properties".

Right there, you must be seing a "Dolby" tab. Go to that one and enable "Pro Logic IIx"

The sound now can be heard as stereo upmix. However, I must state that this upmix is not exactly like upmix in Windows XP, it's more like the one that is in Windows Vista (I think i must say, it's like Creative CMSS; not like Dolby Surround)

However, I liked it that way and it's not bad at all, I think.

And also, I didn't read the whole forum - so if this solution is already posted; sorry for that...

Attached Images
Windows 7 5.1 surround problems (realtek)-prothingy.png 
My System SpecsSystem Spec
05 Sep 2009   #93

Windows 7

Thanks, but unfortunately I don't have that tab.
My System SpecsSystem Spec

05 Sep 2009   #94

Windows 7 Enterprise x64

No fix in new Realtek R2.32 driver! :-(
My System SpecsSystem Spec
05 Sep 2009   #95

Windows 7 RC1

My sound chipset is ALC889A, I must say that...

It was available in the R2.26 version and R2.32 version (which can be found as the latest driver in Realtek company website)

However, I must also clearify that this Dolby ProLogic thing doesn't always produce good results. I found out that it causes some electro-techno musics to become distorted.
My System SpecsSystem Spec
09 Sep 2009   #96

Windows 7 Ultimate x86

I have this problem also, nothing from above works..

So as temporary solution i use a 3.5mm jack-split. I know it's just stereo sound, but now i can use my 5 speakers instead of 3 without crappy matrix sounds...

Still hope for a driverupdate from Realtek soon.

My System SpecsSystem Spec
19 Oct 2009   #97


Got the exact same problem as "simonfilth". Really annoying, since it sounds pretty crappy.
My System SpecsSystem Spec
19 Oct 2009   #98

Windows 7

I am really surprised that they still haven't found a fix for it.
My System SpecsSystem Spec
20 Oct 2009   #99

Windows 7

Hello Guys,

First of all i am sorry for my english still trying to make it better )
let's work on our common problems i found some plugins for 5.1 on winamp and driver for realtek + ac97.

Winamp > Preferences > Plugins > Output > DirectSound Output > Configure

These 2 links are for 5.1 on Winamp for Windows 7

VL Sound for Vista v1.0.0.5 - Winamp
A3D Output Plug-in - Winamp

These 2 links are for Realtek Driver and Realtek Audio Software

Link 1

Link 2

I hope, all these things will solve your problems Have a nice day!

After i have done all these, my surround system has started to work ( 5.1 )

Attached Images
Windows 7 5.1 surround problems (realtek)-post-107-1091723974.jpg 
My System SpecsSystem Spec
20 Oct 2009   #100

Windows 7 --previously (Vista)

Quote   Quote: Originally Posted by bellerophon View Post
Quote   Quote: Originally Posted by neilsouth View Post
the realtek hd drivers worked fine for me but what i really hate with this realtek hd on board sound is the speaker fill option... With creative i could use cmss and surround which put winamp music through all four speakers clearly. With this realtek it sounds like someone listening to music underwater(rears). The worst music rear sound i have ever heard from a sound source. I googled this and found others with the same issue there is a fix but its its just a hack job.
hi neil, you weren't using it with the highlighted option below were you?

can you please help!!! How did you get that option on realtek???? I had same thing like --change sound room and all that you have in that picture, but when i downloaded new realtek it doesnt give me that option and my sound like ****t...............
My System SpecsSystem Spec

 Windows 7 5.1 surround problems (realtek)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek® ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:39.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App