Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 5.1 surround problems (realtek)

02 Dec 2010   #251


I found a few WMA codecs but none that work for my files.

My System SpecsSystem Spec
02 Dec 2010   #252

Windows 7 Ultimate SP1 x64

I don't have wma files. Almost everything is in mp3.
Anyways, i tried converting an mp3 to the following wma formats.

Both files play normally without ffdshow. WMP does not use ffdshow to decode it.
My System SpecsSystem Spec
03 Dec 2010   #253


ah thanks, I'll just delete and rip them in MP3.
My System SpecsSystem Spec

24 Dec 2010   #254

Win 7 Home Premium 64

This worked for me but not until I also hit the Configure button and selected 5.1 Surround

Quote   Quote: Originally Posted by kerph32 View Post
here's what worked for me to get sound out of my rear speakers-

right-click on taskbar speakers > playback devices > properties > enhancements > enable Environment (ROOM) and Speaker fill

hope that helps someone!
My System SpecsSystem Spec
10 Jan 2011   #255

Windows 7 x64
5.1 direct 6 channel cable issue.

Hi, I recently upgrded my speakers from a very old Creative cambridge 2.1 to a Logitech z5500 on my recently purchased system with the following configuration

Processor: Intel i7 860
Mobo: MSI Big Bang Fuzion (LGA 1156)
For reference :
Grafix card: ATI HD 5970
HDD: WD Black 1
Audio: Xfi card provided with Mobo

My problem is that I am not able to make all the speakers (Especially the centre 1) functional using the 6 channel direct cable to connect to the sound card. Instead if I use the Coaxial cable all the speakers work fine but am not able to configure the speakers depth and alignment as the Realtek manager does not show the 5.1 arrangement like in the 6 channel direct cable.

I have another issue

Scenario: I am doing a voice over skype while in the middle of a game Battlefield badcompany2 suddenly when I alt tab to accept a conference call or some other call the realtek Audio manager pops up and the frnt panel Mic and headfones get disabled and the pig plug in pop up dialog pops up again and when I confirm they get disabled and this loops again and again while my friends voices are shuffling from my headfones to speakers to headfones again.
My System SpecsSystem Spec
17 Jan 2011   #256

Windows 7 Pro 64bit

Just downloaded the newest 1.4.2011 update...still does not fix this ridiculous problem. Has anyone been able to manage a solution instead of a work around involving Dolby Prologic II which not everybody has, or the terrible sounding speaker fill option?

All I want to do at this point is clone my front speaker audio to the rear speaker audio...this worked just fine in Windows XP without any sort of tinkering or setup. It worked when I plugged everything in.

Was this an error in Windows XP? Why did it work on the old OS and not now? I have never had rear speakers but yet they worked at all times with any software. I get full sound out of the "rear speakers" when I do the test in the HD Audio toolbar.

I was not able to get that pin selector working in the system registry.
My System SpecsSystem Spec
18 Jan 2011   #257

windows 7

Well you might as well get over it, Windows 7 is just a beta piece of crap. Looks great but functions like crap. The sound problem will never be fixed. Now they are talking bout windows 8. For what??? 7 never worked why try another one.
My System SpecsSystem Spec
18 Jan 2011   #258

Windows 7 Professional

The key to 5/7.1 sound in Windows 7 is simple. It has everything to do with "Run as administrator".

When installing drivers and player software "run as administrator".

After installing player software change the compatibility Privilege Level properties of executables to "run this program as an administrator".

I'm using Arcsoft TotalMedia Theater 3 but I also have Powerdvd 7 and 9 working.
My System SpecsSystem Spec
19 Jan 2011   #259

windows 7

Another joke! Why should the normal user have to run everything as administrator in win7? It should just work!

And yes exclusive mode applications will allow rear and side speaker functionability but not for playing music and stuff like that.

So like I said...
My System SpecsSystem Spec
22 Jan 2011   #260

Windows 7 Home Premium 64

Quote   Quote: Originally Posted by bigblocktowncar View Post

...All I want to do at this point is clone my front speaker audio to the rear speaker audio...this worked just fine in Windows XP without any sort of tinkering or setup. It worked when I plugged everything in. ...
Hi. I just joined here due to this amazing thread.
I used a splitter cable to have 2 front outs, 1 to my receiver and 1 to a receiver in the basement. But then I started getting feedback from the basement if someone was listening to something else downstairs (like the radio).
So I retasked the rear out to front out. That worked great, but wouldn't save the setting. So I tried using the front headphone jack, but of course, that silenced the speakers.
Finally, I found a reference to the folder in the upper right next to the word ANALOG. Check the box that disables front panel detection. Then you can use the headphone jack for speaker out without turning off the main speakers.

I'm not having any problems with W7, but I'm only using this PC to play music. I'm using Media Monkey, which makes itunes look amateur. Try it, you'll like it.

Doesn't it seem strange that this Realtek Audio Manager doesn't appear to have any kind of help file?

EDIT: I'd like to add that although I said I'm not having any problems with W7, the did fix a few things that weren't broken with XP. Fortunately, I didn't have to deal with Vista. My wife did, and that was bad enough.
My System SpecsSystem Spec

 Windows 7 5.1 surround problems (realtek)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek® ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:19.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App