Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Blaster Audigy

14 Aug 2009   #11
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
but how would i make it figure that out
A quick check in the bios, and make sure that the onboard audio is disabled.

Just in case this is the driver you need,

Creative Sound Blaster audio driver 1.04.0090

After downloading use something like Winrar to extract the downloaded file. Once extracted open Device Manager, go to the multimedia device, right click on select "Update driver". Then,

1. select Browse my computer
2. select "Let me pick'
3. click on "have disk"
4. click on Browse and find the extracted folder and point it to the folder that contains p17.inf, will look like this,

SB24_PCDRV_LB_1_04_0090\Drivers\vista

Assuming the unknown multimedia controller is your Audigy that should get the driver installed. Give it a try and please report back whether it worked or not.


My System SpecsSystem Spec
.
15 Aug 2009   #12
Zerolife

Windows XP
 
 

omfg, that worked, thanks so much, now ill probably never boot in xp tho lol
My System SpecsSystem Spec
15 Aug 2009   #13
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Good to hear (no pun intended).

Up to you but if you want some of the apps to go with it you can give this a try,

SB P17X Series Support Pack 2.0 (07/31/2009) - AudigySE/Value/LS_Live24bit_X-Fi XtremeAudio_SB5.1VX - Sound Blaster - Creative Labs

It is based on the same driver you just installed, and comes with some of the apps from the X-Fi Xtreme Audio (which is basically identical to your card).
My System SpecsSystem Spec
.

31 Oct 2009   #14
Barnfly

windows 7
 
 
How to fix your problem

hi

I had the same problem of my creative soundblaster not being seen in Windows 7.

What I did was
1. Go into Bios and disable onboard sound card
2. Shut down and power off your computer.
3. Take out the sound blaster, plug in the power and reboot your computer without the soundblaster card in.
4. Shut down your computer and take out power cable and then reinsert your sound blaster.

It should then be detected by windows 7
Then install the latest drivers and software from Creative and it should work.

Hope this helps
My System SpecsSystem Spec
01 Nov 2009   #15
Twister

windows 7 home premium 64 bit
 
 

will give these 2 solutions a go in a few days time
My System SpecsSystem Spec
03 Nov 2009   #16
mushroomboy

Windows 7, Linux
 
 

My System SpecsSystem Spec
04 Nov 2009   #17
Crispy

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)
 
 

Download these drivers Creative Worldwide Support I got a Audigy 2 ZS the only problem I have is with the mic not working.
My System SpecsSystem Spec
04 Nov 2009   #18
Twister

windows 7 home premium 64 bit
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Quote:
but how would i make it figure that out
A quick check in the bios, and make sure that the onboard audio is disabled.

Just in case this is the driver you need,

Creative Sound Blaster audio driver 1.04.0090

After downloading use something like Winrar to extract the downloaded file. Once extracted open Device Manager, go to the multimedia device, right click on select "Update driver". Then,

1. select Browse my computer
2. select "Let me pick'
3. click on "have disk"
4. click on Browse and find the extracted folder and point it to the folder that contains p17.inf, will look like this,

SB24_PCDRV_LB_1_04_0090\Drivers\vista

Assuming the unknown multimedia controller is your Audigy that should get the driver installed. Give it a try and please report back whether it worked or not.
tried this today and it works, absolute legend.

the only thing is that 2 of the speakers sound a little bit crackly? i had this issue with xp on my old 5.1 surround set also, and now on W7 it does it with both my old and new set so maybe the sound card itself has a slight issue?
My System SpecsSystem Spec
Reply

 Sound Blaster Audigy




Thread Tools






Similar help and support threads
Thread Forum
Sound Blaster Audigy 2 Platinum ex does not sound in Win7x64
Hello; I'm trying to make my "Sound Blaster Audigy 2 Platinum ex" works on Windows 7 64 bits, I did install the most new version of the drivers provided by Creative Labs, it seems like it is installed without any problems....the Device Manager shows all drivers are installed correctly...when I...
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Sound Blaster audigy 2 Value malfunction
Hi. First of all, i would like to say, that i am from central europe, non-english speaking country so be tolerant to my language mistakes, please. Thanks. I didn't find here, or anywhere else, someone with similar problem, so that im asking you for help. Some time ago my sound card just stop...
Sound & Audio
Sound Blaster Audigy 2 isn't nearly as loud in Win 7
my sound card is the SB audigy 2. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. however in windows 7 the drivers that were automatically installed upon the OS installation do NOT play audio at the regular decibel levels. I tried going to downloading the...
Sound & Audio
Sound Blaster Audigy 2 isn't nearly as loud in Win 7
my sound card is the SB audigy 2 zs platinum. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. in vista i had to try a few different sets of drivers but got it working correct. however in windows 7 the drivers that were automatically installed upon the OS...
Sound & Audio
creative sound blaster audigy se drivers
i have just downloaded the ones that stormy showed and i also downloaded from the creative website itself. i have installed and reinstalled and restared my computer many times and still no luck what so ever. all it says is that there is no audio output device installed when actually i have...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App