Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No audio output device...


16 Aug 2009   #1

Vista and 7 RC 32bit
 
 
No audio output device...

I have installed an Asus Xonar DX 7.1 (Working in perfectly in Vista) and I have also installed the drivers from the cd which installed without errors. I have also downloaded asus win 7 beta drivers yet I still get no sound.

In device manager I can see my asus card with the yellow ! signs. If I try to update the drivers it says I have the latest up to date drivers

At the bottom right near the clock it still reports no audio output device is installed.

Any help would be greatly appreciated. Thanks in advance.


Mike

My System SpecsSystem Spec
.

16 Aug 2009   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

Right click on your card in Device Manager and select Properties, what does it list (if anything) for an error code?
My System SpecsSystem Spec
16 Aug 2009   #3

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Mr Tickle View Post
I have installed an Asus Xonar DX 7.1 (Working in perfectly in Vista) and I have also installed the drivers from the cd which installed without errors. I have also downloaded asus win 7 beta drivers yet I still get no sound.

In device manager I can see my asus card with the yellow ! signs. If I try to update the drivers it says I have the latest up to date drivers

At the bottom right near the clock it still reports no audio output device is installed.

Any help would be greatly appreciated. Thanks in advance.


Mike
I'm not sure why it's saying that no audio device can be found? But there is a patch you need for those Windows 7 Xonar drivers to work properly in Windows 7.

There is a patch on the Vista part of the Asus forum where you get the sound card drivers. That patch is needed if you want your Asus Xonar drivers to work with the newer builds of Windows 7 "7200" and up. You will first need to uninstall all remnants of the Windows 7 Xonar and Vista Xonar drivers and reboot.

You will also need the latest Windows 7 Xonar drivers from the Windows 7 section of the soundcard driver downloads.

After that go to the Vista section of the Asus Xonar driver page and download the patch at the top of the page. There is no mention that this patch fixes the problem but it works perfectly none the less.

After you get the patch reinstall the Windows 7 Xonar drivers again but, instead of rebooting when prompted, install the patch and then reboot. The patch is a very small file and only takes about a second to install.

After rebooting everything should work perfectly.
My System SpecsSystem Spec
.


16 Aug 2009   #4

Vista and 7 RC 32bit
 
 

My build of 7 is 7100. I tried the patch as per your instructions but still the same problem.

When I click properties of my card is says:-

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)
My System SpecsSystem Spec
17 Aug 2009   #5

Windows 7 Ult, Windows 8.1 Pro,
 
 

You don't need the patch for 7200 and earlier. You should delate that driver and use driver sweeper to get rid of the extra parts of the driver. It would help to know your system specs because there is another fix that may apply.
My System SpecsSystem Spec
03 Sep 2009   #6

win 7 pro pl
 
 
i solved this problem with hotfix

Yo.

i had many problems to make it right, but i did it xD

i got win 7 pro, and none of realtek's released drivers was working fine or wasn't working at all.

try to install UAA BUS Driver Hotfix (i've tried hotfix for vista) before other sound drivers, then just install drivers from win update. that works for me.


peace & love from poland!
My System SpecsSystem Spec
04 Sep 2009   #7

WIN,XP,7,VISTA,SERVER
 
 

I had the same problem when i have installed my 7 ultimate 7600 rtm,i got the same thing like no audio devices and bla,bla,bla,where i have a sb x f extrem audio,from creative,i had googled across the net and i found the exactly updated drivers for my sound card right on time and works now like a charme,but don't install it via your cd driver installation,just take a look on the net to find the the exactly updated drivers for your card on the site of your sound card manufacturer.
Good Luck,maate.
My System SpecsSystem Spec
Reply

 No audio output device...




Thread Tools



Similar help and support threads for2: No audio output device...
Thread Forum
No audio output device is installed Sound & Audio
No audio output device installed Sound & Audio
No audio Output device is enabled Sound & Audio
Realtek Audio: No Audio Output Device is Installed Sound & Audio
No Audio Output Device Sound & Audio
(ask) audio output device not installed Sound & Audio
NO audio output device Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:05 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33