Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IDT Audio Drivers Won't Install - Win7x64, clean install

30 Jan 2012   #1
Badger21

Windows 7 Ultimate x64
 
 
IDT Audio Drivers Won't Install - Win7x64, clean install

Hi all,

I'm working on a re-install of all components following a complete corruption of the boot sector on my drive which could not be fixed with repairs. The last time I installed everything fresh, I had no issues. Between then and now, there have been no hardware changes on my system, but now I am having issues installing the IDT Codecs.

I keep getting an error along the following lines:
Quote:
ExitError: Error=Device Object not present, restart the system and run setup again.
Running under compatibility mode, and running drivers from both the motherboard CD and the manufacturer website both have the same effect. The CD, when booted, says "This OS not support!" and only contains 32-bit vista codecs. ECS' website download indicates the IDT drivers as being compatible with Win7. Both do not work. It is almost as if the hardware "disappeared," despite the fact that I was using the drivers quite successfully till just 2 days ago, when the boot sector went kaput.

Windows has installed its own default set, which do nothing to power the 8mm jacks which I use with my speakers, but instead put sound through the HDMI, which is useless because I use a dedicated graphics card. I have tried uninstalling this codec and re-installing IDT, to no effect. Windows replaces with its own default codec.

I have referenced this thread here, but offered solutions do not seem to work for me: Intel IDT Audio Driver will not install

Looking for any guidance, seeing as how ECS is not forthcoming with any help.


My System SpecsSystem Spec
.
31 Jan 2012   #2
fireberd

Windows 7/10 64 bit
 
 

Do you actually have the newer IDT audio chip or an older SigmaTel audio chip. In most cases the newer IDT drivers will not work with the older SigmaTel chips.

If the drivers are Vista compatible and the correct IDT or Sigmatel (32 and/or 64) they should work in Win 7.

When you reinstalled did you install any motherboard chipset drivers? Generally, on a reinstall if the chipset drivers are not installed then some device drivers and especially sound drivers will not install.
My System SpecsSystem Spec
31 Jan 2012   #3
Badger21

Windows 7 Ultimate x64
 
 

Honestly, I am assuming that the chip is an IDT, since that is the driver software which the motherboard CD was packaged with. It worked great for over a year like that, hence my conclusion.

I did install all my chipset drivers. That was an odd one, because all CD-based drivers were not compatible with Win7, and I had to download new ones from the ECS site to comply. Those allow me to use the on-board HDMI output for graphics and sound, which I currently have hooked up, but now do not allow me to use my dedicated graphics. I'd like to get back on the discrete card, if I can just make these sound jacks work right.

Should I attempt using SigmaTel drivers on the off chance something funky was going on before, and I actually have a SigmaTel on my board? Or will that cause more problems than necessary?

I submitted a support ticket to ECS last night attempting to get some other drivers they may not have published. While I'm not an A+ technician or an expert, I was quite stunned when they responded not only quickly, but with bs. I was essentially told that I would need to re-install my OS on a new hard drive, as, " You are using a 1.0TB HDD ? For this motherboard we would not recommend anything above 750.0MB if even that."

I don't buy that for one second. I bought my system components at the same time as a friend, and we matched nearly everything but cases and RAM. He has never had an issue using his RAID0 with two, 1TB drives. I don't see how my single TB is causing the problem.
My System SpecsSystem Spec
.

31 Jan 2012   #4
fireberd

Windows 7/10 64 bit
 
 

If the motherboard vendor supplied IDT then it's a newer sound chip and the IDT should work OK. The generic HD Audio Codec that Windows installs does not work or work properly in many systems.

However, you are talking two separate things. IDT audio (PC Audio) which would appear on the speaker jacks and on the front panel Headphone jack and the HDMI which is only via the video card and is normally only active when an HDMI cable is plugged in. How the HDMI audio is generated depends on your video, some video cards have their own sound module built on the video card ONLY for HDMI audio and others use an S/PDIF connection to the PC's motherboard for HDMI audio.

Since it worked until you did a reinstall, suggests a possible corruption in the new install since it won't install and gives you an error. Sadly, it may take another complete, clean, install to get it working. Another reinstall is the last resort but if something was inadvertantly missed or the install is corrupted that is what it will take. I don't like to take the typical "tech support" response of "reinstall", but with the complexity of everything sometimes it is needed.

You can try the generic IDT drives and see what happens, won't hurt at this stage.
My System SpecsSystem Spec
31 Jan 2012   #5
Badger21

Windows 7 Ultimate x64
 
 

I'll try some generics when I get back to the house, and edit here if something else changes the situation I'm in.

When I referenced HDMI, windows did install drivers for the onboard HDMI-out connector on the back of the motherboard, and sound/video does work through this connection, and the S/PDIF. But yes, I'm looking to get the audio jacks themselves working.

Thanks for the help so far!
My System SpecsSystem Spec
31 Jan 2012   #6
fireberd

Windows 7/10 64 bit
 
 

I really haven't helped much other than possibly given you some food for thought. But if it helps to point you in the right direction, great.
My System SpecsSystem Spec
Reply

 IDT Audio Drivers Won't Install - Win7x64, clean install




Thread Tools





Similar help and support threads
Thread Forum
How do i clean install drivers?
I know this has been asked to DEATH but 7 forums search doesn't seem to be working. I have just purchase a new ati 7870 gfx card from newegg and am wanting to clean install the drivers. Do I simply go to device manager and remove the old 8800 drivers? Or is there a more complete method that...
Graphic Cards
clean win7x64 installed on hp dm1 4302ep(win8),now i cant find drivers
that's pretty much the topic.. did a clean win7x64 with sp1 install, but now some drivers are missing, i cant use the ethernet, or the Fn keys on laptop.. does someone knows a solution? these are the ethernet possibilities, i got them trough the info on the windows 8 driver: ...
Installation & Setup
Clean install of Windows 7 and drivers
I have an HP laptop, and it will not boot up. Have tried safe mode, repair, everything. But no go. So right now I am reinstalling W7 from the original CDs. After I get that done, I have the drivers CD. So, my question is what is involved in doing that installation?
Windows Updates & Activation
How to know what drivers you will need for clean install.
I am upgrading from Vista premium to 7 pro. I'm doing a clean install. I have read allot to prepare and I am lost when it comes to the following questions. Yes I know I ask allot of questions but I'm stupid and it's my job. :D I have read that I need to download all the latest system...
Installation & Setup
Onboard audio not working and audio drivers won't install
Hello everyone, I'm having a problem using my motherboardís onboard HD audio instead of my video cardís audio, so without further ado here is the situation; I have an Asus maximus iii gene motherboard which has a SupremeFX X-Fi built-in sound card (this is a very nice card provided you can...
Sound & Audio
clean install hd audio problem
Hi just wondering if any one has seen anything like this . upgraded a friends computer from xp to win7 home edition computer is a asus main board intel cpu. after installing codecs and drivers using dvbdream (dvb tv software) the system sound works fine and the sound in dvbdream works fine on...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App