Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Creative Sound Cards.

05 Sep 2011   #171
Microsoft MVP

Win 7 Ultimate x64

After using something like Driver Sweeper (or Driver Cleaner), more than I care to think about over the years. One reason I am loathe to recommend programs like that at all.

My System SpecsSystem Spec
06 Sep 2011   #172

Windows 7 Ultimate x86

Quote   Quote: Originally Posted by Gonz View Post
Further to my mission to get this pesky card to work, on going to check the IRQ's of the graphics card and sound card i discovered that the sound card isn't showing up in the device manager anywhere, even though its working near enough fine in certain games?! I'm assuming that its going to be a windows reinstall for me to have any hope of getting this working

Ever heard of that happening before?
I had the same problem. I fixed the problem by swapping sound card to graphics card slot. Try it and see if it works or not
My System SpecsSystem Spec
07 Sep 2011   #173

Windows 7 Ultimate X64

Well i reinstalled windows today but it hasn't changed anything Soundcard is now appearing in the device amnager at least.

Installed the nvidia chipset drivers first then installed the creative drivers before the graphics card but it made no odds. Sound card is using IRQ 19 and the graphics card is 18. Still getting the crackling in windows, won't play MP3's etc.

Anyone got any other suggestions i can try?
My System SpecsSystem Spec

04 Oct 2011   #174

Windows 7 Ultimate x86

Latest Update available:

Release date : 12 Sep 11

File Name : XFTI_PCDRVBETA_US_2_17_0008B.exe
This download is a beta driver providing Microsoft® Windows® 7, Windows Vista® and Windows XP support for Creative Sound Blaster® X-Fi™ Titanium series of audio devices. For more details, read the rest of the web release note.

Take note of the following:
  • THIS IS AN UNSUPPORTED BETA DRIVER. There is no technical support for this driver.
  • We recommend that only experienced users install this driver. Do not install this driver on a system used to perform critical tasks.
  • Users who are looking for stable drivers should wait for the final release. When this happens, user should install the latest Sound Blaster X-Fi Titanium series driver available.
This download supports the following audio devices only:
  • Creative Sound Blaster X-Fi Titanium Fatal1ty® Champion Series
  • Creative Sound Blaster X-Fi Titanium Fatal1ty® Professional Series
  • Creative Sound Blaster X-Fi Titanium Professional Audio
  • Creative Sound Blaster X-Fi Titanium
  • Minimized the issue of no audio playback on certain system configurations.
Known Issues:
  • Audio stutters during the opening video for certain game titles while Dolby Digital® Live is enabled. This issue occurs on certain hardware and OS configurations only. More details and a workaround are available here.
  • Microsoft Windows 7 64-bit, Windows 7 32-bit, Windows Vista 64-bit with Service Pack 1 (SP1), Windows Vista 32-bit with SP1, Windows XP Professional x64 Edition, Windows XP Service Pack 3 (SP3), Windows XP Media Center Edition (MCE) 2005 or Windows XP MCE 2004
  • Sound Blaster X-Fi Titanium series audio devices listed above
  • To install this driver
    1. Download the file onto your local hard disk.
    2. Double-click the downloaded file.
    3. Follow the instructions on the screen.
My System SpecsSystem Spec
18 Nov 2011   #175

Windows 7 Ultimate x64

I have found with the beta posted by nireagle that I could only use Stereo sound. There was no option for 5.1 or 7.1!

I've just purchased the Creative Sound Blaster X-Fi™ Titanium Fatal1ty® Champion Series and the CD supplied or downloaded drivers will not install. It will unpack and that's it. If I manually unpack and try running the setup.exe, nothing happens. Process not even running. Tried changing compatibility modes and run as administrator with no success.

I've run Win7 updates and installed Microsoft’s driver version ok. Runs with no problems but I am unable to use the functions on the I/O drive. So I manually installed the Creative drivers via DM which does allow me to use the I/O Drive. However, I do get cracking and interference noises. (With beta of final version drivers from Creative website) I have discovered if you mute the Microphone FP under the Levels tab in the speaker properties this stops the horrid noises. (And no I don't have a Mic plugged in.) So you might wanna check that Gonz.

But I still have the problem trying to install the software. I can install other programs ok so this is starting to bug me now! lol. I haven't had the chance to get my teeth into it yet, but I am a techy so hopefully I will get on top of the problemo...

UPDATE:- TuneUp Utilities 2012 was my problem! It was stopping the installer from working and it only affected the Creative software. In the end I had to uninstall it as no matter what I did I just couldn’t get the installer to run while TuneUp was installed. Just disabling it did not work….
My System SpecsSystem Spec
23 Dec 2011   #176

Windows 7 professional 64 bit
Creative - Skype - Bluetooth - No sound

Who might think of the problem? The situation is next, when I connect the bluetooth headset and at the same time the creative sound card is connected I cannot hear a person while speaking on the skype. But the interesting part is that i can hear a music thru the headphone. Although the microphone works well and the listener can hear me.
My System SpecsSystem Spec
02 Jun 2012   #177

32 Bit Windows 7 Ultimate

Well, Heres something to stump you all.

Got an XFI fatal1ty, from a friend with no driver disc. Installed the PCI Card and I/O Module and windows found the Card etc, and tried to install drivers. As we all know that would never happen. SO i went to creative and got the latest driver package. What follows is a night and day of a complete farse of a card + install.

Everytime i load any driver to the card, When i restart the driver will be gone. And the only way to get the card to be registered is if i wipe the OS and reinstall windows. Put the card into another PC in the home. Perfect install no issues.

If the card installs, At times it will crash / restart / BSOD, then when i try to turn the PC back on it hangs after BIOS with a - flashing in the top corner. I have tried ALL drivers known to man. About to attempt an XP install to see how that goes. Bear in mind im on OS wipe number 13, and i HAVE tried Ccleaner etc to get rid of all the installed components and nothing changes.

Running, ASROCK KN7810D Motherboard, 8GB DDR2 Ram, ASUS GT420 1GB GFX Card, Belkin N1 Wireless card. 5x Sata HDD, 750W PSU, 1x Optical DVD Drive. The problem is atm, this is all going into a HTPC build as these are all my old parts. But it feels like a waste now its not working / causing more issues than i have ever had with a PC.
My System SpecsSystem Spec
02 Jun 2012   #178

windows 8.1 Pro x64

You have to make sure the drivers from windows update are not being installed at all. When you first install windows, disable auto updates from being installed (it asks you at the end of windows installation) and hide the update from within windows update when you manually run it.
My System SpecsSystem Spec
02 Jun 2012   #179

32 Bit Windows 7 Ultimate

Quote   Quote: Originally Posted by Zahl View Post
You have to make sure the drivers from windows update are not being installed at all. When you first install windows, disable auto updates from being installed (it asks you at the end of windows installation) and hide the update from within windows update when you manually run it.
As i stated they are not installing. windows update doesnt even find drivers.
My System SpecsSystem Spec
02 Jun 2012   #180

windows 8.1 Pro x64

Which chipset is that board using? I can find nothing about it
My System SpecsSystem Spec

 Creative Sound Cards.

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Low volume with new sound card(Creative Sound Blast 5.1 VX)
Hello! I got a new sound card today. Installed it, installed the drivers from the CD, plugged in the headphones and it works. But the sound levels are way to low. I raised the volume in all the places I could find, but it's still a bit low. Here's the card: Creative Sound Blaster 5.1 VX...
Sound & Audio
Creative SB cards not working on new pc setup
Hello, i have 3 creative audio cards SB X-Fi Xtreme Gamer/Audio and SB Audigy 2 zs. Resently i have changed motherboard Asus M5A78LUSB3 with fx 6xxx CPU to Asus P8P67 LE with i7 4xxx CPU, all other components remained (they are 2 DIMM G Skill RipjawsX F3-10666CL7-4GBXH, AMD Radeon HD 5800 Series)....
Sound & Audio
Pax Drivers for Creative Sound Cards
Tweaked drivers available which are alternatives to Creatives own drivers. Supports X-fi, Audigy and Forte cards, including Titanium HD and Fatality series. Can be found here - Get the latest X-fi Pax Drivers here Updated regularly. :D
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Non Creative Labs Sound cards
I'm tired of trying to get Creative cards (like the X-Fi XtremeGamer) to work reliably with Windows 7 Ultimate x64 (on a new install, after manually installing the drivers because Creative's installer fails consistently. Now the update called for by Windows Update also fails because "Setup is...
Sound & Audio
Sound skips after some time (tried diff. sound cards)
Hello, I used to have Vista on this computer and didn't have audio problems. I've upgraded to Windows 7 and use the latest drivers available for my sound card (Striker 7.1). I have also tried not using these drivers and instead using a USB sound card (Sennheiser that comes with one of their...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:05.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App