Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative Sound Cards.

13 Nov 2009   #41
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

May or may not help but are you using the latest motherboard drivers (Nforce 570 SLi),

NVIDIA DRIVERS 15.51 WHQL

or the default ones that Windows installed?


My System SpecsSystem Spec
.
13 Nov 2009   #42
Arcalimon

Windows 7 Ultimate 64bit
 
 

Win default drivers, i didn't update my mobo driver since i bought it

Is it worth to install them?
My System SpecsSystem Spec
13 Nov 2009   #43
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

I would, Nvidia chipsets can be finicky at the best of times. Just make sure to do a custom install and only install the ones you need (don't need the included audio driver, and I have never heard anything good about Nvidia's "Network Management Tools").
My System SpecsSystem Spec
.

13 Nov 2009   #44
Arcalimon

Windows 7 Ultimate 64bit
 
 

Ok installed.

Now i'll try to reboot and installe the Auzen WMD pack by Daniel K that is also the only one who made my card send a nice and clear sound even if without any chance to set it 5.1 like it was on Vista.

How can this be possible?

Launched the driver pack Auzen WMD and i got this message

''A newer version of Driver Audio has been detected''


I've uninstalled EVERYTHING.
My System SpecsSystem Spec
13 Nov 2009   #45
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

This the one you used?

SB X-Fi Series AuzenWDM Pack 1.0 (09/30/2009) - Creative Labs

If so did you do the channel re-assignment as he described? If not that would be why you aren't getting 5.1.
My System SpecsSystem Spec
13 Nov 2009   #46
Arcalimon

Windows 7 Ultimate 64bit
 
 

Yes they are

I can't install the driver cause it tells me that there's another version of the driver installed.

If i install it i can't use the apps cause ''No supported Device detected''


I'm going really mad don't know how to fix it
My System SpecsSystem Spec
13 Nov 2009   #47
Mcyoung5

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Just a bit of an addition to this as I have seen a few posts with people with Creative cards (can happen to the others too) where when they try to install the drivers they get the ever popular,

"Setup could not detect any Sound Blaster Audio Card on your system."

In most cases this can be fixed by installing the driver manually. First download the driver appropriate to your card (links to most Creative cards in the first post), then use something like Winrar or 7Zip to extract the downloaded driver file. Next follow the tutorial here (for Vista but the same applies for Windows 7),

Device Manager - Install Driver - Vista Forums

When you get to step #9 the file you want to point it to is,

for the Audigy SE/LS/DE/Value and X-Fi Xtreme Audio is P17.INF

for all X-Fi cards (except the above Xtreme Audio) and the rest of the Audigy series (1, 2 and 4) the file is wdma_emu.inf

In most cases the above files are located in the Drivers\WDM folder in the extracted folder. If the driver installs successfully, you should then be able to install any of the applications that have been updated to work with Vista (and will/should work with Windows 7); best to use one of the modded driver packs for this.
Just as a refference, if you're using an SB Audigy 1 and have this problem, just go into device manger, find the Multimedia Audio Device, then right click and select update driver. I tried it and it worked for me!
My System SpecsSystem Spec
13 Nov 2009   #48
Mcyoung5

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by Arcalimon View Post
Yes they are

I can't install the driver cause it tells me that there's another version of the driver installed.

If i install it i can't use the apps cause ''No supported Device detected''


I'm going really mad don't know how to fix it
Just follow the steps that I posted in my previous link, I'll bet it probably works with any SB soundcard.
My System SpecsSystem Spec
13 Nov 2009   #49
Arcalimon

Windows 7 Ultimate 64bit
 
 

It's not about setup

When i launch the setup it tells me that there's a newer version of the driver.

If i start the applications installed throug the pack they tell me that there are no supported devices, but the SB Creative X-Fi is present in the device list


And now i'm at yesterdays situation. Manually installed the WMD drivers and i have perfect sound back but only 2.1

Started the pack setup again, same errore message about newer driver, i ignored it and i'm installing all the applications.

But i'm sure they won't find the device again so they will not be usable again.

This is the key of the issue i fear.
My System SpecsSystem Spec
13 Nov 2009   #50
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

One thing with his Auzen packs, you have to do the speaker re-assignment using the THX Console, or you will only get 2.1. I got the same thing and had to do it today when I installed the UAA driver (driver only over the top of what was already there, the apps I have are from the original 2.0 Support Pack and still working); and yeah I got the warning about the currently installed driver being newer, just clicked on install anyway.
My System SpecsSystem Spec
Reply

 Creative Sound Cards.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Low volume with new sound card(Creative Sound Blast 5.1 VX)
Hello! I got a new sound card today. Installed it, installed the drivers from the CD, plugged in the headphones and it works. But the sound levels are way to low. I raised the volume in all the places I could find, but it's still a bit low. Here's the card: Creative Sound Blaster 5.1 VX...
Sound & Audio
Creative SB cards not working on new pc setup
Hello, i have 3 creative audio cards SB X-Fi Xtreme Gamer/Audio and SB Audigy 2 zs. Resently i have changed motherboard Asus M5A78LUSB3 with fx 6xxx CPU to Asus P8P67 LE with i7 4xxx CPU, all other components remained (they are 2 DIMM G Skill RipjawsX F3-10666CL7-4GBXH, AMD Radeon HD 5800 Series)....
Sound & Audio
Pax Drivers for Creative Sound Cards
Tweaked drivers available which are alternatives to Creatives own drivers. Supports X-fi, Audigy and Forte cards, including Titanium HD and Fatality series. Can be found here - Get the latest X-fi Pax Drivers here Updated regularly. :D
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Non Creative Labs Sound cards
I'm tired of trying to get Creative cards (like the X-Fi XtremeGamer) to work reliably with Windows 7 Ultimate x64 (on a new install, after manually installing the drivers because Creative's installer fails consistently. Now the update called for by Windows Update also fails because "Setup is...
Sound & Audio
Sound skips after some time (tried diff. sound cards)
Hello, I used to have Vista on this computer and didn't have audio problems. I've upgraded to Windows 7 and use the latest drivers available for my sound card (Striker 7.1). I have also tried not using these drivers and instead using a USB sound card (Sennheiser that comes with one of their...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:22.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App