Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Sound, Realtek AC'97, Windows 7, ASUS P4S800D-X

22 Aug 2009   #1
GreatEvilBetty

Windows 7 Ultimate (build 7100)
 
 
No Sound, Realtek AC'97, Windows 7, ASUS P4S800D-X

Hey there, just upgraded from Windows XP SP2 to Windows 7 Ultimate.

So far there have been a few kinks here or there that have needed working out and i've gotten them all taken care of with the exception of one; I have no sound!

I listed my system specs in my profile as best as i could find, and i have a link to my motherboard specs right here: ASUSTeK Computer Inc.

I updated my drivers from here: Realtek

Made sure to download the Vista/Windows 7 one.

Umm, can't think of anything else at the moment, going to try and get some sleep, will check back tomorrow. If anyone has any suggestions feel free to shout them out, i'm fresh out of ideas.


My System SpecsSystem Spec
.

22 Aug 2009   #2
GreatEvilBetty

Windows 7 Ultimate (build 7100)
 
 

ROFLMFAO I solved the problem and it was so simple... Yet, VERY unusual.

I was looking at the playback settings with some music playing see screenshot:

And i noticed that the computer was reading that sound was actually playing because the green bar was moving.

So i thought maybe it was my speakers, so i unplugged my speakers and plugged in headphones. Nothing, so i thought just for ****s i would plug my headphoens into the different slots, first one, nothing, then i plugged them into the MICROPHONE slot and BAM max volume Dragonforce Fury of the Storm straight into my brain, it was both painful and wonderful, and i laughed out loud for a good long while.


Well, problem solved, plugged speakers into the microphone spot and TA-DA! Sound!

Now i'm off to play some Champions Online till my eyes bleed.
My System SpecsSystem Spec
22 Aug 2009   #3
rightspin

Windows 7 Ultimate x64
 
 

Hey GreatEvilBetty,

i had the same problem with my Asus onboard sound. The Realtek drivers didn't work for me, and neither did the soundblaster drivers for my soundblaster life! card. What i did was google the audio chipset and look for some (modded) x32 or x64 drivers. One of them worked. I think yours is a AD1888 SoundMAX, right?
Maybe this link will help you, there is a vista driver:
analog device drivers

And there is an other thread here in forums about the AD1888:

SoundMax AD1888 driver


If you have an old sound card, try do put that one in and see if you find any working drivers for it.


I hope any of this helps.


EDIT: nvm.
My System SpecsSystem Spec
.


22 Aug 2009   #4
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by rightspin View Post
I think yours is a AD1888 SoundMAX, right?
Maybe this link will help you,
It is, and quite clearly says so on the page he linked to for his motherboard. Makes me wonder why he would install Realtek drivers in the first place. Install the correct drivers and things will probably work as they should.
My System SpecsSystem Spec
22 Aug 2009   #5
GreatEvilBetty

Windows 7 Ultimate (build 7100)
 
 

I installed the RealTech drivers because when i run dxdiag and Belarc and when i look at any information on my computer regarding sound it all says, and only says, RealTech AC'97 Audio. That is it, nothing else. But the problem has solved itself, somehow, but i will keep this thread in mind for future reference just in case i ever go to record something with a microphone and end up having problems.

I only discovered what my real sound card actually was after i read a thread on this site(can't remember what thread) that had a link to the ASUS website and a list of all the available motherboards and i searched for my own and found that.
My System SpecsSystem Spec
23 Apr 2010   #6
jtmawson

Windows 7 and XP
 
 
My Realtek AC'97 problem solved

I upgraded to Windows 7 from XP SP3 on a PC with Realtek AC'97 audio drivers and found they did not work - as it had indicated in the Microsoft Upgrade Advisor.

I upgraded the driver using both Windowsupdate and finding a driver on the Realtek site.There appeared to be no change to the sound. But I noticed that the upgrade had altered my options.


In Control Panel - Sounds, there were now 2 options under the playback tab:- "Speakers- Realtek AC'97 audio" and "Realtek Digital Output". It was currently not working on the default option of Speakers, so I changed the default to "Realtek Digital Output" and the sound worked normally.

Good luck
My System SpecsSystem Spec
16 May 2010   #7
zuser

Windows 7 Ultimate x86
 
 

If someone succeed to run these drivers on Windows 7, please can backup it using Driver Genius or similar software and upload here?

I have tested all, but nothing...

I have the same motherboard (Asus P4S800D-X)
My System SpecsSystem Spec
19 May 2010   #8
apjung

Windows 7 Home Premium 64-bit
 
 

I bought the Asus A8S-X SE mobo from 3btech.net about 2 years ago and they included the XP 64-bit drivers. The driver is called
SoundMAX Integrated Digital Audio
Driver Date: 2/3/2005
Driver Version: 5.12.2.5280

and it's working for me.
My System SpecsSystem Spec
14 Feb 2011   #9
TheRoadrunner

Windows 7 64 Home Premium + Ultimate
 
 

Quote   Quote: Originally Posted by rightspin View Post
i had the same problem with my Asus onboard sound. The Realtek drivers didn't work for me, and neither did the soundblaster drivers for my soundblaster life! card. What i did was google the audio chipset and look for some (modded) x32 or x64 drivers. One of them worked. I think yours is a AD1888 SoundMAX, right?
Maybe this link will help you, there is a vista driver:
analog device drivers
You are my Hero !

I have an Asus P5VD2-MX with integrated High Definition Audio, ADI AD1986A SoundMAX 6-channel CODEC.
When I upgraded to Windows 7 64 Home Pre. the audio only presented itself as High definition S/PDIF with no sound from the speakers. No trace of the SoundMax.
I read in multiple forums that there was no solution for Win7, but your link to Analog Devices site did the trick. Now it works like a charm.

Thx alot.
Roadrunner
My System SpecsSystem Spec
Reply

 No Sound, Realtek AC'97, Windows 7, ASUS P4S800D-X




Thread Tools





Similar help and support threads
Thread Forum
Distortion sound using onboard realtek sound card on windows 7ultimate
Hello,i recently upgrade my system from xp to windows7,i use the same realtek driver and get distortions!I try severall drivers,disable all enhancements/levels on speakers properties with no result(2.1speakers-),i configure them in stereo mode,i reduce the default format to 44100 16bits(cd...
Sound & Audio
No Sound Realtek HD - ASUS N53SV
Hallo, I have no sound right now using the Realtek HD audio drivers that I downloaded from my laptop manufactures site. These are the correct drivers too that were on the page for my laptop model ( ASUS N53SV , ) so I'm a bit confused why sound is not working...I do get sound for a bit after I...
Sound & Audio
Sound crackling and distortion, Asus P8Z68-V, Realtek and SB X-Fi Ti
Hello, first I would like to say that I have searched lots of threads about sound distortion, crackling or bad quality and haven't found any solution. Specs of my computer are: MB: Asus P8Z68-V CPU: Intel i5 2500k GPU: GIGABYTE N570OC-13I PS: Corsair HX650W Windows 7 Professional 64-bit ...
Sound & Audio
ASUS/Realtek, Latest Realtek versus default W7 Audio driver
I installed the Realtek HD audio driver from the ASUS download site (P8Z68-V Pro MB) and all was well until I installed an MSI 560TI video card and let it install the Nvidia HD Audio drivers. The problem I have been chasing ever since was the Realtek HD Audio Manager popping up after the system...
Sound & Audio
No sound. Realtek. Windows 7.
Hi, I have eMachine e725. Sound card is Realtek ALC272 @ Intel 82801IB ICH9 - High Definition Audio Controller. With Windows XP everything was OK, but I have a problem with Windows 7 x64. I instaled driver given by manufacturer, but it's only Vista x64. However other drivers for Vista works...
Sound & Audio
No Sound: Realtek Asus Motherboard Win7 64bit
Edit 1/22/2010 9pm. Post #9 is snap shots of all I have tinkered with or looked at. You might be able to read this and skip to post #9 Now back to the original message: I have no sound. My cpu is 3 months old. I have had extremely limited issues with the cpu since date of purchase. I was...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:07.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App