Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek HD Changing Jack output reassignments ( FIX )


08 Jul 2009   #51

vista x64/ win 7 x64
 
 

That's why i said it's a real problem. Firstly, Windows 7 has different audio endpoint mapping system. Audio endpoints can now be changed on the fly, whilst the app is still running.

In vista, the app readout the registry and latched on to the given endpoints. After that you needed to close the app, change the endpoint and restart.

Since 7, the registry endpoints don't point to the real hardware but to virtual hardware. This gives you the possibility (which for me is long time overdue, should be in vista sp2) to switch from headphones to speakers or such without shuttingdown the sound app.

Furthermore, for every chipset there are different settings. What works for one doesn't have to work for another even on the same computer.

If it works you're in luck if it doesn't......

My System SpecsSystem Spec
.

08 Jul 2009   #52

Windows 7
 
 

damn... i still can't get my logitech 5.1 to work =/ i hope this is gonna get fixed later on.
My System SpecsSystem Spec
09 Jul 2009   #53

Windows 7 RC1
 
 

can you post a screencap of your registry (on the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\" directory)

and what kind of setup are you planning to use for the pinouts
My System SpecsSystem Spec
.


09 Jul 2009   #54

Windows 7
 
 



I have 3 output jacks. the middle one is green, right one is blue and left one is orange/pink. on windows xp, when it worked fine, blue one used to be subwoofer and central speaker. green one was the two front ones and orange one was two rear ones.

my speakers are logitech x530: Logitech X-530 5.1ch Home Theatre Speaker (970114-0122 ) - Logitech - DealsDirect.com.au Australia

the weirdest thing though, is that when i test the speakers in system:



It works perfectly. Also when i test them in realtek, they also work perfectly:



but those are the only 2 applications I can get the sound from all of the speakers. another option is that ****ty "speaker fill", then i have sound from all of them, but as everyone already knows, it's not even sound, but just some ****ty noise.
My System SpecsSystem Spec
09 Jul 2009   #55

Windows 7 RC1
 
 

Quote   Quote: Originally Posted by simonfilth View Post


I have 3 output jacks. the middle one is green, right one is blue and left one is orange/pink. on windows xp, when it worked fine, blue one used to be subwoofer and central speaker. green one was the two front ones and orange one was two rear ones.

my speakers are logitech x530: Logitech X-530 5.1ch Home Theatre Speaker (970114-0122 ) - Logitech - DealsDirect.com.au Australia
can you post a screenshot of the opened folder above that?
where the pinouts are located.
My System SpecsSystem Spec
09 Jul 2009   #56

Windows 7
 
 

ok changed.
My System SpecsSystem Spec
09 Jul 2009   #57

Windows 7 RC1
 
 

did you try switching your subs/center with your rear?

according to the pinouts
pin01 = should be rear (05 00 00 00)
pin02 = should be subs (06 00 00 00)
My System SpecsSystem Spec
09 Jul 2009   #58

Windows 7
 
 

already tried that, nope, doesn't work.
My System SpecsSystem Spec
09 Jul 2009   #59

Windows 7 RC1
 
 

well, I guess I don't have the answers for that my friend.

Quote   Quote: Originally Posted by petrossa View Post

Furthermore, for every chipset there are different settings. What works for one doesn't have to work for another even on the same computer.

If it works you're in luck if it doesn't......
My System SpecsSystem Spec
09 Jul 2009   #60

Windows 7
 
 

what i don't understand, is why the hell do they work normally when i test them in those 2 applications? but any other thing, only 2 speakers work.
My System SpecsSystem Spec
Reply

 Realtek HD Changing Jack output reassignments ( FIX )




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33