Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Only 2-channel audio when using HDMI


06 Apr 2012   #1

Windows 7 Ultimate x64
 
 
Only 2-channel audio when using HDMI

First off, I've read through plenty of threads and guides already and none have worked.

I bought a new TV a couple months ago. I connected it through HDMI to my computer running Windows 7 Ultimate x64 and after setting the default audio device to my TV, I was able to get 5.1 audio when playing Skyrim.

Let me clarify how it was connected.
PC --HDMI--> "HDMI Splitter" --Optical--> Receiver
The video goes to the TV from the "HDMI Splitter" through an HDMI cable. But the audio is more relevant.

This setup worked fantastically. There were no issues.

I reinstalled Windows for some reason and the 5.1 audio stopped working. After the reinstall I first installed Realtek audio drivers. Since 5.1 wasn't working I uninstalled those and installed the nVidia audio drivers. No luck. The connection to the receiver has been exactly the same but I cannot get the audio working again.

When I set my TV as the audio device and go to "configure", I am able to select stereo, quadraphonic, 5-ch, 7-ch, etc. If I select anything but stereo then no sound comes out when testing the speakers.

When I go to "properties" instead of "configure", it says the Max number of channels is 8 and it lists a bunch of encoded formats like DTS audio, Dolby digital, etc.

What's strange is that if I go into Windows Media Center and have it detect/test my speakers, it plays from all 6 just fine. Also, in VLC when I select "A/52 over S/PDIF" as my audio device I get full 5.1. When I set it to 5.1 I only get stereo. It seems I can get 5.1 audio for every application except the one I want -- Skyrim (and other games).

The last tidbit that might be useful is that when I'm testing the speakers from "control panel" -> sound, like I said, only 2-channel works but when testing the speakers the audio doesn't play right away. There's a 1 second pause before the speakers play. It's not a delay, I just can't hear the 1st second of audio.

I don't know what else to try.

My System SpecsSystem Spec
.

Reply

 Only 2-channel audio when using HDMI




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:23 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33