Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: After Removing stdriver64.sys No Audio Output Device Installed

02 Jun 2012   #1
CrimsonHunter

windows 7 Home Premium Service Pack 1 x64
 
 
After Removing stdriver64.sys No Audio Output Device Installed

I was instructed to remove the stdriver64.sys from my system as it was causing crashes. Well after I've done so the audio device refuses to work I have attempted to uninstall and reinstall my Realktek High Definition device a few times, but it still refuses to work. I have to system restore to get stdriver64 back on my system which is the only way I have sound, but it crashes if I do.


My System SpecsSystem Spec
.

02 Jun 2012   #2
fireberd

Windows 7/10 64 bit
 
 

A google search does not turn up anything for stdriver64.sys. A search for stdriver.sys does turn up an Acer SCSI driver but that's all.

You didn't fill in the My System Specs so we can't give you help with your specific system.

If you do have an Acer PC, make sure you are using the Realtek driver from Acer. In many cases only the vendor supplied sound driver will work properly.
My System SpecsSystem Spec
02 Jun 2012   #3
CrimsonHunter

windows 7 Home Premium Service Pack 1 x64
 
 

APologies, I have grown very frustrated with this problem and I joined quickly just seeking for help. I have been up and down the internet trying to solve this problem. My System is a Dell XPS 8300. I have used the drivers from Dell's support website and from the manufacturer's website. Every time I have the situation remains unchanged, I have no sound and each of my sound devices is said to be corrupted or mission. It all seems to pertain to the stdriver64, because with it I have sound, but without it I don't. I would leave it be if it wasn't the case of many BSODs.
My System SpecsSystem Spec
.


02 Jun 2012   #4
fireberd

Windows 7/10 64 bit
 
 

With a Dell you definately need to use the Dell supplied driver. On the Dell users forum we have found that non-Dell drivers either do not work or do not work correctly. I do a lot of support on the Dell users forum and don't recall seeing this particular problem.

There have been some problems with the Dell Support Center and the "ST" may be part of that.

What is the status of the sound in the Device Manager? Does it show an error code or working correctly?

The Dell Downloads have an Intel motherboard chipset driver and the Realtek driver. Suggest you reinstall the chipset drivers then the Dell Realtek driver and see what that does.

On a reinstall, the chipset drivers must be installed before the sound drivers. One of the things the chipset drivers do is define (identify) all the hardware devices. Drivers and Downloads | Dell [United States]

Worst case (hassle) would be to do a reinstall (PC Restore) from the Dell recovery partition (F8 at power on) which will restore it to the original factory condition. Windows 7 PC Restore | Dell

Have you tried posting on the Dell community Desktop users forum? It is a good place to get "users helping users" help with Dell problems. Home - Dell Community
My System SpecsSystem Spec
02 Jun 2012   #5
CrimsonHunter

windows 7 Home Premium Service Pack 1 x64
 
 

I have not posted onto those forums, bit it is a fair idea. This is the code I get from the drivers.

"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"
My System SpecsSystem Spec
03 Jun 2012   #6
fireberd

Windows 7/10 64 bit
 
 

A code 39 error is missing drivers or registry entries. Usually, reinstalling the device driver will fix this.
My System SpecsSystem Spec
Reply

 After Removing stdriver64.sys No Audio Output Device Installed




Thread Tools





Similar help and support threads
Thread Forum
no audio output device installed
This is my wife's sony vaio, and she has had this problem with no sound on her laptop, when checking the volume control it says no audio output device installed. In device manager it says that she has Intel display audio. I need major help here please.
Sound & Audio
No Audio Output Device is installed.
I updated my sound card using a updating software and it changed into Realtek HD Audio. Now the problem there is no sound coming out and my sound mixer said that "No Audio Output Device is installed" but i have my speaker plugged in and when i troubleshoot it the troubleshooter said that :Audio...
Sound & Audio
No audio output device installed
I bought a generic computer. It had windows vista installed and it used to display a message that No audio output device is installed . I recently installed windows 7 home premium 32 bit on it but it still says the same thing. I went to properties of it and found following error message.This device...
Sound & Audio
No audio output device installed???
I swear this is going to kill me if I don't get it fixed. And I sure as hell ain't reinstalling the entire damn OS! Here's what's shown with a yellow exclamation in Device Manager: EVERYTHING under Sound, video and game controllers -Hauppauge WinTV-HVR-2250 (8851) -Microsoft Streaming Clock...
Sound & Audio
Realtek Audio: No Audio Output Device is Installed
Hello. Im having the dreadful "No Audio Output Device is Installed" problem on my realtek audio. It worked some months ago, but im in no position to do a roll back. Im sure the hardware is just fine, it works with Ubuntu. The computer is a Dell Vostro 430. My OS is win7 64bit. I tried...
Sound & Audio
No Audio Output Device is installed.
Hey guys, Ive looking all over the net on how to fix this problem but no luck yet after trying possibly everything. Basically the other after i booted up my computer i had no sound at all and on the bottom right hand corner there is a speaker with a X through it saying No Audio Output device is...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App