Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dell XPS 420 Sound Issue


09 Jun 2012   #1

Windows 7 64 bit
 
 
Dell XPS 420 Sound Issue

It shows on the mixer that there is sound coming out however, I can't hear any. I know that the Dell XPS 420 has problems with this since this happened to me last time I reformatted. This time I can't seem to find a fix as much as I've searched. I think I finally found the right driver version but still I can't hear any sound.

Dell XPS 420
Windows 7 64 bit

My System SpecsSystem Spec
.

09 Jun 2012   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Your problem is not a "common" problem. I do a lot of support on the Dell users forum.

Assuming you have the correct Dell sound driver installed (R157052 for the SigmaTel integrated audio), to to the Control Panel/Hardware and Sound and finally the Sound panel, Playback section. Make sure your "Speakers" are set as the default playback device. You can also configure the speaker type and test the speakers from this panel.
My System SpecsSystem Spec
09 Jun 2012   #3

Windows 7 64 bit
 
 

Well I got my sound to work. Now my mic doesn't work though. Oh dell
My System SpecsSystem Spec
.


10 Jun 2012   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

"Oh Dell". It may not be Dell's fault. You didn't say what happened before you had the problem. Did you install something? Uninstall something? Did you do a complete reinstall? I assume it all worked at one time?

The XPS 420 was not delivered with Windows 7, either XP or Vista was the original OS on this system.
My System SpecsSystem Spec
10 Jun 2012   #5

Windows 7 64 bit
 
 

I understand, this just seems to be the only brand I always have trouble with.

I did a complete re-install I figure this problem would occur again, since it did last time. Just happens to be a little different this time. I now have sound but the front mic won't pick up. I believe I downloaded the right chipset driver.
My System SpecsSystem Spec
10 Jun 2012   #6

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Generally, if you are connected to the internet when you install Windows 7, it will find most of the device drivers and install them. The Dell specific sound driver is needed, as we have found (on the Dell forum) that non-Dell sound drivers either do not work or do not work correctly.

Make sure the SigmaTel is shown as the sound device in the Device Manager. If it shows something else, such as "HD Audio Codec" or "IDT HD Audio" that is incorrect. Also, if it shows more than one sound device (other than possibly a Video card audio that is used for HDMI), uninstall the other devices (Right click on an entry for the device and then LEFT click "Uninstall" and also check the box to uninstall the drivers), then restart the PC and you should be left with only the SigmaTel sound driver.

You can also check the recording devices in the Sound Panel. If the mic is disabled, enable that. If you are lucky you will also have "System Mixer" in the recording panel and set this for the default recording device (this allows recording streaming audio from the internet).
My System SpecsSystem Spec
Reply

 Dell XPS 420 Sound Issue




Thread Tools



Similar help and support threads for2: Dell XPS 420 Sound Issue
Thread Forum
No Sound on Dell GX 620 Sound & Audio
RealTek OnBoard Sound Issue - No Sound Sound & Audio
Sound Blaster X-Fi Titanium Sound card issue Sound & Audio
Sound trouble, could be a memory issue? (Dell Inspiron 1545) Sound & Audio
Sound issue (Conexant sound driver) Sound & Audio
dell speakers no sound Sound & Audio
No sound on Dell laptop Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:41 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33