Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Edifier Speakers Not Getting Detected By The PC.

15 Jun 2012   #1
SevenGeek

Windows 7 Ultimate 32bit
 
 
Edifier Speakers Not Getting Detected By The PC.

Well I have bought these new Edifier speakers 2 days ago .. they are not getting detected by my PC at all .. I mean they are not even showing up/detecting inside the Device Manager. (I am Running Windows 7 Ultimate 32 Bit)
I have tried several USB ports .. which when used for other devices such as my headphones and webcam work fine...

When I hook them up with the USB, the light on the speakers light up .. so the power isn't the issue I guess...


And the weird thing is .. the speakers worked fine on my friend's laptop .. they got detected, were working like any normal speaker would ...

Any Help Would be appreciated guys


My System SpecsSystem Spec
.
15 Jun 2012   #2
fireberd

Windows 7/10 64 bit
 
 

Looking at the Edifier manual, you need both the USB connection (for power) and the 3.5 mm stereo cable connected between the Speaker/Headphone jack on the PC and the audio input jack on the speakers.

HERE is the link to the site and you can access the manual. http://www.edifier-international.com/
My System SpecsSystem Spec
Reply

 Edifier Speakers Not Getting Detected By The PC.




Thread Tools





Similar help and support threads
Thread Forum
Bluetooth dongle detected, items detected but not connecting.
Hi guys, I bought a bluetooth dongle off of amazon so I could use my bluetooth headset with my comp. Once plugged in it installs driver version 6.1.7601.17889 from microsoft and there are no yellow '?'s. When I look for devices it sees my headset no probs but will not connect, which it does...
Hardware & Devices
Bad scratchy noise from speakers, but speakers OK. No IDE ATA/ATAPI???
Hi! Please bear with me ... I will not be using the correct terminology, but hope I explain myself OK all the same! :D I have a DELL studio XPS PC With Windows 7. I used to have a DELL screen, with a speaker section attached, which belonged to my previous DELL. (Altec Lansing 5650 5.1 Surround...
Sound & Audio
No sound through speakers.Jack not being detected.HDMI sound only?
So I've got a problem,I changed my case 2 days ago and everything went great,all working as it should be.Up until an hour ago,when the lid got stuck in one of the little clips so after a quick bang it went in.But then I lost my picture on both monitors. So I went to investigate,I ended up...
Sound & Audio
5.1 speakers but test signal only on 2 speakers
I have a Creative SB X-Fi Xtreme PCI-Ex, and Logitech Z-5500 5.1 THX speakers. All speakers work; all software, drivers and codecs are up-to-date. Recently I noticed that in the Speaker Setup screen, the test button only results in sound from the left and right front speakers. I checked...
Sound & Audio
Need help with 5.1 speakers
First of all, please bare with me. I am not a total idiot when dealing with computers, but I may not know certain things. I recently got Windows 7 on one of my desktops. I plugged in my Logitech 5.1 speaker system and I am getting absolutely nothing out of them. I went through the obvious...
Sound & Audio
External Speakers work, Laptop speakers do not
Hi all, I have a Dell XPS M1330 laptop and have recently upgraded to windows 7 professional (32bit) from windows vista. Everything seems to be running smoothly except I can get no sound from the internal laptop speakers. When I plug in external speakers in via the jacks on the front, sound comes...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App