Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Creative SB-XFI Titanium - problem

05 Sep 2009   #1

W 7
 
 
Creative SB-XFI Titanium - problem

Hi guys thanks in advanced Umm my problem is i keep deleting/uninstalling my Soundcard and its programs but when i reinstall i seem to be having this same problem saying The audio device is not supported by this application will now exit


Sound card - Creative SB-XFI Titanium Champion series

My System SpecsSystem Spec
.

05 Sep 2009   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

Are you installing the latest from Creative or something like this,

SB X-Fi Series Support Pack 2.0 (05/15/2009) - Creative Labs

or are you installing what came on the disk with the card?
My System SpecsSystem Spec
05 Sep 2009   #3

W 7
 
 

Na i got the Creative auto update software program thingy from the website and i use that to update my drivers and software. Although i will give that support thingy a try thanks for that.
My System SpecsSystem Spec
.


05 Sep 2009   #4

W 7
 
 

Nope the support pack didn't do anything still get that same stupid problem occuring
My System SpecsSystem Spec
08 Sep 2009   #5
ECH

Win7
 
 

MS has offered an update for that and I've not experienced any problems using it. Did you check with them?
My System SpecsSystem Spec
09 Sep 2009   #6

Windows 7 Ultimate X64
 
 

Thanx to stormy13 for the link ...rep given !!
x64 X-Fi drivers installed flawlessly ....7.1 speakers never sounded so alive now wow!!
My System SpecsSystem Spec
21 Sep 2009   #7

windows 7
 
 

hi i have the same problem with mushroom also my speakers appear unplugged and i don't have any sound i tried the support pack 2.0 but nothing happened please help me
the only option that appear active is the spdf but not the speakers
My System SpecsSystem Spec
22 Sep 2009   #8

 

One thread per problem, please.
problem soundblaster xfi titanium
My System SpecsSystem Spec
Reply

 Creative SB-XFI Titanium - problem





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:46 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33