Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Old Sound Blaster Live Resurrected & Working in Win7!!! NO REVERB!!!

03 Jul 2012   #1
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition
 
 
Old Sound Blaster Live Resurrected & Working in Win7!!! NO REVERB!!!

For anyone who has an old Sound Blaster Live or similar soundcards laying around, I found a developement project for drivers for these older cards and many others that Creative has chosen to drop support of long ago (2003).

I was tearing apart an old PIII dinosaur I built in 1999, and decided to install the old Sound Blaster Live PCI card into my Win7 shop PC to replace the mobo sound for better tunes. I got the old Creative Lab XP drivers to install using Win7's XPSP2 compatibility, and it sounded great until I rebooted my shop PC.

Once I rebooted, I had a constant reverb that couldnt be turned off, none of the Creative apps would run. So I seached the net looking for solutions; and found the KX Project for these older cards. After a small struggle configuring their new WDM driver... My ears couldnt be happier!

This is an independent development project, focused on providing free WDM Audio Drivers for kX-Compatible sound cards.

Matter of fact, their website Official kX Project Site -- News claims that they support KX-compatible soundcards including all EMU10k1 and EMU10k2-based PC soundcards manufactured by Creative Technology Ltd. and/or E-mu Systems Inc., including:

The E-mu Audio Production Studio (APS) card
The motherboard models of 10k1 cards (M002, M003 and others)
PCI256 (CT4890, CT4891 and CT4893) and PCI512 (CT4820 and SB0150) including OEM model (CT4790)
The original Live! (CT4620) and Live! Value cards (CT4670)
The Live! X-Gamer, Live! MP3+, Live! Player 1024, Live! Platinum cards (CT4760) and value cards (CT4780)
The Live! X-Gamer 5.1, Live! MP3+ 5.1, Live! Player 5.1, Live! Platinum 5.1, Live! Digital Entertainment 5.1 cards (SB0060, SB0100, SB0102, SB0220, SB0222, SB0103 and SB0105) and Value 5.1 (SB0101)
The generic and custom OEM Live cards (CT4830, CT4831, CT4832, CT4850, CT4870, CT4871 and CT4872)
The Audigy series, including the Audigy MP3+, X-Gamer, Platinum and OEM cards (CT0070, CT0072, SB0090 and SB0092).
The Audigy 2 series, including Gamer, Platinum, Platinum eX and OEM cards (SB0242, SB0244, SB0320, SB0240, SB0240P, SB0280).
The Audigy 2 ZS series, including Audigy 2 ZS Gamer, Platinum and OEM cards (SB0350).


My System SpecsSystem Spec
.

03 Jul 2012   #2
solarmystic

Windows 7 x64 Professional SP1
 
 

Thanks for the info Darryl Licht, may it help others with dinosaurs for graphics cards.....

One of the great misfortunes of how the sound stack works in Windows Vista/7 is that hardware accelerated audio has been rendered largely irrelevant, requiring messy workarounds to get EAX and and other hardware accelerated sound effects working...

+rep
My System SpecsSystem Spec
Reply

 Old Sound Blaster Live Resurrected & Working in Win7!!! NO REVERB!!!




Thread Tools





Similar help and support threads
Thread Forum
Sound blaster Live! Value card - no sound
Done the research, and unless I've missed something, there's a caveat that hasn't been addressed in this issue. I have an SB Live! value card, have installed the Daniel_K driver for it, following the suggestions about deleting the existing RealTek (which didn't seem to work, though I didn't put...
Sound & Audio
sound blaster live does not work
hey my sound blaster live dosențt work at all it says that it is installed and everething seems fine ... just does not work
Sound & Audio
Sound Blaster Live for Windows 7
hello guys, can someone help me work my sound blaster live the model is SB0100 on my windows 7. i want to make it work but no matter drivers for win 7. the windows isnt digitally signing my soundcard. any help and suggestion are welcomed! hoping to get some reply from you guys!
Drivers
Sound blaster live!
The right drivers at the last post: http://www.sevenforums.com/sound-audio/79428-sound-blaster-live.html#post694541
Sound & Audio
Sound Blaster live
Please help. I have installed Win 7, but when I want to install Sound Blaster live software, it says that no sound card is installed. I installed the kx software and the sound works, but I cannot use my midi keyboard and somehow my micr0phone will not work in Skype. I would realy like my...
Hardware & Devices
Sound Blaster 5.1 Live!
hi at everybody. i'm new on this forum... yesterday i've installed windows 7 on my desktop pc, but i've some problems with audio card : model -> Creative Sound Blaster Live! 5.1 where i can find correct drivers for this audio card??? thanks a lot
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App