Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek AC'97 Audio BSOD

18 Jan 2009   #1
Knowle

windows 7
 
 
Realtek AC'97 Audio BSOD

So to make this story some what short, I installed Windows 7, it kinda hung on installing the creative sound blaster driver so I assumed it was an audio driver issue from the beginning. After a reboot my sound would always make snap crackle pop / static noises and what not. Totally maddening when you watch tons of stuff online / play games / listen to music.

Strange thing whenever I booted into safemode w/ networking my driver for the sound blaster card would always install first thing no problem. Still, tons of static and the like in the background. The main issue, any reboot would give me a bsod to no end unless I booted in safemode, then there was no issue. Disabled different sound cards until I found out it was the Realtek card. Then I checked out the control panel and there was a driver for realtek, sure enough if I uninstalled and rebooted without going into safemode I NEVER got a bsod. Happy days.

Then I thought I had fixed the static issue but so far I have not. I'm using a creative sound blaster audigy 2 zs card. I've installed the latest beta driver for it(when I thought I had fixed it) to no avail. Sorry it ended up being extremely long :P Sadly, none of this happened in XP, but im blaming it all on the drivers.


My System SpecsSystem Spec
.

18 Jan 2009   #2
limneos

Windows 7 RC 7100 32bit/64bit
 
 

Have you let windows update search for drivers for your sound card and install them ? This is probably the most compatible drivers you will find right now, and they are proven to solve the static issue too.

If you haven't , uninstall your beta drivers which I don't know where u got them from, and let Windows Update search and find anything. If found, use those.

I'll pray with you.
My System SpecsSystem Spec
18 Jan 2009   #3
Knowle

windows 7
 
 

Well that's were it all started from, it was the drivers from windows update which cause it to bsod on every start up(the realtek ones) the sound blaster drivers give me the distortion no matter if they come from windows update, which made me want to try both stable and then beta drivers from the creative site, all of them give me static no matter what.
My System SpecsSystem Spec
.


19 Jan 2009   #4
Hector

Windows XP
 
 

You still have this static or is it gone once you turned the realtek codec off?
If you do - disable that realtk codec in BIOS, so that it does not even show in the device manager. That's what I always do and having no issues.
My System SpecsSystem Spec
21 Jan 2009   #5
Knowle

windows 7
 
 

I've disabled it from the device manager and I still get static. Haven't tried from BIOS.
My System SpecsSystem Spec
21 Jan 2009   #6
Hector

Windows XP
 
 

Can't guarentee that if you do - the static will go but that is the first thing I would try - change BIOS settings:
1) disable AC97 and see if that helps
2) if it does not, mess around with PCI latency timer setting - try different values. I think by default PCI latency timer is set to 32 cycles meaning a PCI sound card can hold the bus for 32 clock cycles. Try increasing this to 64 or even 128. This might have an adverse effect as well - hard to say , as every system is different in this regard. Bad stock value for PCI latency timer is often the root of static-like audio issues on any OS. Anyway you can always revert to the original settings if needed. Hope this helps.
My System SpecsSystem Spec
31 Jan 2009   #7
Hacksaw

Windows 7 Beta
 
 

Was there a resolution to this issue? I disabled the AC97 in bios, checked for updated drivers, etc. but I am still getting static.

Let me now if it was magically solved.

Hacksaw.
My System SpecsSystem Spec
Reply

 Realtek AC'97 Audio BSOD




Thread Tools





Similar help and support threads
Thread Forum
Difference between Realtek HD Audio Manager & Realtek HD Audio Driver
It's been a year since I migrated from Windows XP to Windows 7 which I downloaded Realtek HD Audio Manager R2.70 and audio has been working fine except the only issue it didn't come with 'Stereo Mix' preventing capability to record sound direct from the soundcard. It took me 14 months to restore...
Sound & Audio
Realtek ALC889 audio, audio fine on S/PDIF, nothing from rear output
I'm having a strange problem in my HTPC. Audio is coming perfectly fine out from the S/PDIF coaxial output, and it's normally connected only that way to the receiver, but now for other reasons I also need to connect it using a 3.5 mm to a small mixer. So in the sound manager I changed the output to...
Sound & Audio
BSOD installing Realtek Audio driver
Hi all, Just had a BSOD in Windows 8 while installing the latest Realtek drivers. Can someone check my log? Thank-you :)
BSOD Help and Support
Audio Playback (Default Device Realtek) Knocks Out SRS Audio Sandbox
Hi, I finally upgraded from Windows XP to Windows 7 and almost went back shortly after finding out I could no longer organize or manually arrange my own personal files and/or folders but luckily I discovered an application called 'Folder Options X' which has re-enabled that feature for me so I'm...
Sound & Audio
ASUS/Realtek, Latest Realtek versus default W7 Audio driver
I installed the Realtek HD audio driver from the ASUS download site (P8Z68-V Pro MB) and all was well until I installed an MSI 560TI video card and let it install the Nvidia HD Audio drivers. The problem I have been chasing ever since was the Realtek HD Audio Manager popping up after the system...
Sound & Audio
Realtek HD Audio Manager and Realtek Audio Driver
Help. I recently did a clean install of Windows 7 64bit (on my HP Vista 32 machine). Life is grand! My problems started when I tried to listen to the microphone input through my speakers. The front microphone inputs did not work so I downlaed the Realtek HD Audio Drivers (recently updated) from...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App